1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

AC Compressor

Discussion in '1st Gen. Tacomas (1995-2004)' started by my6, May 1, 2012.

  1. May 1, 2012 at 6:23 PM
    #1
    my6

    my6 [OP] Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    49
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd
    My AC Compressor is making a thumping sound and the pulley has a slight wobble it seems. The system is still cooling as always but fear a catastrophic AC malfunction is on my horizon. Can someone give me an idea as to just what is going on inside the compressor? I'm thinking a bearing is going bad.
     
  2. May 1, 2012 at 6:26 PM
    #2
    NelsonTacoma

    NelsonTacoma This is my derpawayinator!!!!!

    Joined:
    Mar 25, 2010
    Member:
    #33969
    Messages:
    2,093
    Gender:
    Male
    Tucson, AZ
    Vehicle:
    06 PreRunner TRD Sport 03 4Runner Limited 4wd
    Bilstein 5100's , 6000k HID Hi/Low Kit, Magnaflow Muffler, 1.5 inch AP Wheel Spacers, Mudflap Delete
    If the pulley is wobbly then you are correct. The front bearing is going bad. I wouldnt wait too long. If the bearing seizes then you could have catastrophic compressor failure and that means $$$$.
     
  3. May 1, 2012 at 6:30 PM
    #3
    my6

    my6 [OP] Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    49
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd
    Can it be pulled apart and the bearing replaced?
     
  4. May 1, 2012 at 6:33 PM
    #4
    NelsonTacoma

    NelsonTacoma This is my derpawayinator!!!!!

    Joined:
    Mar 25, 2010
    Member:
    #33969
    Messages:
    2,093
    Gender:
    Male
    Tucson, AZ
    Vehicle:
    06 PreRunner TRD Sport 03 4Runner Limited 4wd
    Bilstein 5100's , 6000k HID Hi/Low Kit, Magnaflow Muffler, 1.5 inch AP Wheel Spacers, Mudflap Delete
    Yes it could. But the cost to rebuild possibly would exceed that if a new compressor. Shop around on the Internet and see if you can find any companies that rebuild them and compare the costs.

    Personally I would just replace the whole thing. But that's just the mechanic in me. :D
     
  5. May 1, 2012 at 6:40 PM
    #5
    my6

    my6 [OP] Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    49
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd
    Thanks for the info. Do you know if the same compressor found on any other models or do I need to pull one of a tacoma?
     
  6. May 1, 2012 at 6:44 PM
    #6
    Honey badger

    Honey badger Honey badger hits whatever tree he wants to hit!!

    Joined:
    Oct 22, 2009
    Member:
    #24735
    Messages:
    2,188
    Gender:
    Male
    First Name:
    Bon
    Kinder, Louisiana
    Vehicle:
    02 DC BLACK 3.4
  7. May 1, 2012 at 6:49 PM
    #7
    NelsonTacoma

    NelsonTacoma This is my derpawayinator!!!!!

    Joined:
    Mar 25, 2010
    Member:
    #33969
    Messages:
    2,093
    Gender:
    Male
    Tucson, AZ
    Vehicle:
    06 PreRunner TRD Sport 03 4Runner Limited 4wd
    Bilstein 5100's , 6000k HID Hi/Low Kit, Magnaflow Muffler, 1.5 inch AP Wheel Spacers, Mudflap Delete
  8. May 1, 2012 at 6:50 PM
    #8
    lotsoftoys

    lotsoftoys pavement is boring....

    Joined:
    Apr 22, 2010
    Member:
    #35790
    Messages:
    6,806
    Gender:
    Male
    First Name:
    Jace
    Denver
    Vehicle:
    98 lifted panda taco
    bunch of crap
    i just replaced my compressor bearing for 30 dollars last week....
     
  9. May 2, 2012 at 6:14 PM
    #9
    my6

    my6 [OP] Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    49
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd
    Well I knew it was coming.. AC quit today and theres black plastic stuff coming out from behind the pulley. It also popped the 10amp fuse. Gonna have to sweat a bit till the weekend when I can pull it apart and see if it's just the clutch gone bad or if it is completely fried. Oh joy and Rapture! Houston traffic and no AC..
     
  10. May 2, 2012 at 8:30 PM
    #10
    Robertgeejr1

    Robertgeejr1 Well-Known Member

    Joined:
    Dec 21, 2011
    Member:
    #69167
    Messages:
    774
    Gender:
    Male
    First Name:
    Robert
    Aorora, Ill, yeah!
    Vehicle:
    1996 Toyota Tacoma SR5 4x4
    I have done all the hi-pro mods for a life time, since I got this truck at a great price, I will be happy with showroom new.
    Im sorry to say but if it did that its gone. like radiator fluid, freon has oil in it to lub everything, that why even in winter you should turn in on one a month to keep the seal lubed up so they don't dry out and crack. I hate ac stuff, because when it goes wrong, it adds up. plus you have to be careful now if trash is now in your lines, if you just replace the compressor the trash will destroy it.
     
  11. May 2, 2012 at 8:46 PM
    #11
    my6

    my6 [OP] Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    49
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd
    Yes sir, it's a definite possibility. I've got a bud who told me to cut the belt off and rotate the clutch and pulley looking for flat spots and I found none. Before I pull the trigger on a new compressor we are gonna pull it and see if it just needs a bearing and or a clutch. It's a long shot but I'm hoping.
     
  12. May 5, 2012 at 10:23 PM
    #12
    my6

    my6 [OP] Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    49
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd
    NEVER EVER GIVE UP! AND It's confirmed..I AM living right! It turned out the clutch was indeed fried but that's all and no debris was sent through the system. My buddy Frank had an old salvaged compressor on a shelf and I drove home in comfort. All in all a very very good day.
     
  13. Jun 6, 2012 at 9:55 AM
    #13
    Tacoma2525

    Tacoma2525 Member

    Joined:
    Jun 6, 2012
    Member:
    #80195
    Messages:
    11
    Gender:
    Male
    Vehicle:
    03 tacoma prerunner
    LOTSOFTOYS : Do you by chance know the bearing number you replaced it with?
     
  14. Jun 6, 2012 at 12:05 PM
    #14
    998cc

    998cc Member

    Joined:
    Jun 6, 2012
    Member:
    #80201
    Messages:
    18
    Gender:
    Male
    First Name:
    Russ
    Shingle Springs, CA
    Vehicle:
    96 Tacoma 4WD
    Bone Stock
    For my 1996 Tacoma w/3RZFE engine, I bought a new Denso compressor from Partsgeek 2 weeks ago for 214.00. It does not come with a new manifold, so you have to use the one off the old compressor. New o-ring seals are included. So far, so good. Russ
     
  15. Jun 8, 2012 at 1:38 PM
    #15
    Tacoma2525

    Tacoma2525 Member

    Joined:
    Jun 6, 2012
    Member:
    #80195
    Messages:
    11
    Gender:
    Male
    Vehicle:
    03 tacoma prerunner
    was yours making a thumping noise as to why you replaced it when the compressor would engage?
     
  16. Jun 9, 2012 at 10:59 AM
    #16
    my6

    my6 [OP] Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    49
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd

    Yes sir it was.
     
  17. Jun 9, 2012 at 2:29 PM
    #17
    Tacoma2525

    Tacoma2525 Member

    Joined:
    Jun 6, 2012
    Member:
    #80195
    Messages:
    11
    Gender:
    Male
    Vehicle:
    03 tacoma prerunner
    Im assuming replacing your compressor solved your problem? Mine only has 112,000 miles on it, what about yours? I appreciate you helping me diagnose this thing, its been doing it for a while and getting annoying now.
     
  18. Jun 9, 2012 at 5:08 PM
    #18
    my6

    my6 [OP] Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    49
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd
    Yes sir it did. 188K.
     
  19. Jun 21, 2013 at 8:07 PM
    #19
    marintacoma

    marintacoma Well-Known Member

    Joined:
    Jun 25, 2012
    Member:
    #81288
    Messages:
    429
    Gender:
    Male
    San Luis Obispo
    Vehicle:
    2004 white toyota tacoma 4x4 trd
    saw 2.5 coilovers, wheelers 3 leaf AAL, bilstein 5100 dynomax exhaust
    Anyone find a write up in how to pull one out?
     
  20. Sep 11, 2013 at 12:27 PM
    #20
    mc3404

    mc3404 Well-Known Member

    Joined:
    Aug 28, 2013
    Member:
    #111363
    Messages:
    50
    Gender:
    Male
    Concord ,NC
    Vehicle:
    03 v6 tacoma
    Does anyones compressor clutch hub wobble when it is engauged? I have a bran new compressor and the hub wobbles when it is engaged? Anyone elses do that?
     
To Top