1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Addressing some common misnomers of the P0420 code

Discussion in '1st Gen. Tacomas (1995-2004)' started by Caligula, Oct 20, 2015.

  1. Jan 29, 2022 at 1:21 PM
    #41
    Nicklovin

    Nicklovin Mall Crawlin Through Life

    Joined:
    Jun 24, 2015
    Member:
    #158071
    Messages:
    12,696
    Gender:
    Male
    First Name:
    Nick
    Huntington Beach, CA
    Vehicle:
    04 Prerunner & 01 Mall Crawler
    Copious amount of horsepower gained through stickers, decals and devil horns
    Just had this light pop on… yay :goingcrazy:
     
  2. Jan 29, 2022 at 2:04 PM
    #42
    JSB10

    JSB10 Well-Known Member

    Joined:
    Dec 19, 2017
    Member:
    #238930
    Messages:
    129
    Gender:
    Male
    Vehicle:
    2005 Tacoma
    I have had this P0420 code for awhile. I have a 2005 regular cab 2.7 4cylinder 4wd tacoma. It came on three weeks after I had my spark plugs changed with NGK iridiums. Truck still ran ok for about six months but eventually developed a misfire/loss of power type feeling. Took it to shop mechanic pulled plugs and they were shot with roughly 18000 miles. Now mechanic says I need new catalytic converters and he thinks I need a new fuel pump because its running lean and fouling plugs. He already changed front O2 sensor and he says it passed fuel pressure test but still thinks fuel pump is bad because I have 266666 miles and have never had pump changed. May have to give in and go to dealership and hope they know whats wrong.
     
  3. May 2, 2022 at 8:39 PM
    #43
    1ChancetooLate

    1ChancetooLate Member

    Joined:
    May 2, 2022
    Member:
    #396334
    Messages:
    19
    Gender:
    Male
    First Name:
    Adam
    Vehicle:
    2003 3.4L Tacoma 4x4 Extended cab 5Speed
    Stock
    Caligula, is there a voltage range that should be seen with the scan tool when looking at said O2 sensors? Let's say a 2003 3.4L V6, at temp and running live data. What should be expected to be seen on the bank 1 sensor, and the bank 2 sensor? I have been trying to track down the actual oem spec for this scenario and have been coming up short.
     

Products Discussed in

To Top