1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

AFE CAI CX Pro Dry-S Fitment For 2010 2.7L 4CYL

Discussion in '2nd Gen. Tacomas (2005-2015)' started by vthokie, Jun 4, 2010.

  1. Jun 4, 2010 at 4:55 PM
    #1
    vthokie

    vthokie [OP] Member

    Joined:
    May 27, 2010
    Member:
    #37909
    Messages:
    15
    Gender:
    Male
    Virginia
    Vehicle:
    2010 2.7L 4X4 SR5
    If anyone has doubts whether the AFE CAI will fit the 2010 4 bangers, no worries it will. When I ordered the CAI I couldn't find any information on it, but the seller contacted me and he had his concerns.

    He had called AFE and they had said that they had done no tests on whether or not the CAI will be a direct bolt-on for the 2010's. I said go ahead and process the sale and send it to me. I installed it today and there were no issues except:

    1. The lowest attachment for the "box" for the air filter does not line up with any holes in the engine bay. The two higher attachments seem to do just fine. The attachments are pretty robust.

    2. The bolts included to attach the CSV are too short, but I used the OEM bolts and there were no issues.

    3. The breather hose provided seemed to be too long. I think AFE can solve this by providing a straight plastic fitting instead of a 90 degree one and providing a shorter hose.

    Everything else fit just right with no problems whatsoever. My check engine light came on after the install, but I think its because I had the car on when I disconnected the MAF sensor. I just went to Advanced Auto and they reset it for me with no problems.

    As for the CAI, I like it so far. The engine definitely sounds more "throaty" in gears 2-5. The throttle response seems to be improved and I feel it climbs hills a little better. Could be a placebo effect but I like it. As far as gas mileage, no idea so far as I just installed it. Let me know if anyone has questions.
     
  2. Jun 4, 2010 at 5:10 PM
    #2
    T0LLPHR33

    T0LLPHR33 Well-Known Member

    Joined:
    Sep 26, 2007
    Member:
    #2817
    Messages:
    1,596
    Gender:
    Male
    S1N C1TY...(from Hilo, HI)...
    Vehicle:
    BSP TRD Off-Road
    APR X-1 | TRD CAI w/Clear Cover | TRD Short Shifter w/ TRD "RED" Shift Knob | SGII w/Blendmount| Snugtop SL w/KeyLess Entry | 5% Tint | Pop-n-Lock | Bosch Icon WB | S2K Antenna | HRM | LS 8K Projectors w/BSP HLM & 8K Fogs w/FLM | Debadged |Tinted Tails | Black Weathertechs | MX RGM & RBM | Optima Red Top 35 | Gatorback Belt |
    good luck on the gas mileage...when I 1st put my intake on I couldn't keep my foot off the throttle...lol...but if you shift every 2K you will see good gas mileage...

    as far as the bottom holes lining up to the intake box...you can always drill 2 holes and use rubber spacers/washers to make the intake box level...

    let's see some pics...:D
     
  3. Jun 4, 2010 at 7:29 PM
    #3
    vthokie

    vthokie [OP] Member

    Joined:
    May 27, 2010
    Member:
    #37909
    Messages:
    15
    Gender:
    Male
    Virginia
    Vehicle:
    2010 2.7L 4X4 SR5
    Haha I noticed that it was hard to keep off the throttle...I just love hearing the the difference the CAI made in the sound. I've only put two full tanks off gas in so far and I've been getting 21MPG. I think as the engine breaks in and the CAI will improve it some more.

    The intake box sits pretty level with just the two bolts. I put a piece of insulation from the original breather tube under the lowest mounting point just to keep the metal from rubbing the engine bay. I want to stay rust free.

    I'll try to get some pictures in the morning. So far I love the thing. I know some people say CAIs don't do much as far as performance, but I guess AFE has got me fooled because the sound alone makes me think there has been a performance boost.
     
  4. Jul 29, 2010 at 7:45 PM
    #4
    MJonesTrumpet

    MJonesTrumpet Well-Known Member

    Joined:
    Jun 18, 2008
    Member:
    #7392
    Messages:
    424
    Gender:
    Male
    First Name:
    Michael
    Central PA
    Nice, i'll be looking forward to seeing some pictures as well ^_^
     
  5. Jul 29, 2010 at 7:55 PM
    #5
    ttylerr

    ttylerr Well-Known Member

    Joined:
    Jun 1, 2009
    Member:
    #17913
    Messages:
    833
    Gender:
    Male
    First Name:
    Tyler
    Fort McMurray, Alberta
    Vehicle:
    09 MGM 4Banger 4x4
    5% tint all around, Alpine IVA-W505, 16x8 Mojave Teflon Rims w/Hercules Terra Trac 265/75, Grillcraft Grill, Slimcubby HIDs, Front 5100's @ 0 w/Eibach 1.6" springs, URD Short Shifter, Extang Trifecta Tonneau Cover, Uniden Pro510XL and K30Mag Mount, Relentless Fab Bumper soon to come
    ^ x2. i want pics!
     
To Top