1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Afe pro dry question

Discussion in '1st Gen. Tacomas' started by Hektor, Mar 29, 2013.

  1. Mar 29, 2013 at 5:29 PM
    #1
    Hektor

    Hektor [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28955
    Messages:
    972
    Gender:
    Male
    Texas
    Vehicle:
    03 Tacoma DC TRD v6
    Hello guys I have a quick question for you all. Does the afe air filter fits a little loose when installing on the air box?? I notice fitment is not as flush and does not goes in all the way back as stock one, however when closing the box the retaining clips on top of the lid push it back and it seems like its more flust to the box. Is this the way the filter fit in your trucks as well did you all notice that??
     
    Last edited: Mar 29, 2013
  2. Mar 30, 2013 at 8:43 AM
    #2
    VlineSci09

    VlineSci09 My other truck is a Warthog

    Joined:
    Feb 25, 2012
    Member:
    #73560
    Messages:
    147
    Gender:
    Male
    SoDak
    Vehicle:
    2003 4x4 TRD
    OME sports with 881 and dakar leaf, raider vagabond topper, minor details to exterior, deckplate mod/afe pro dry s, grey wire mod, Trail Gear low profile bumper w/ light bar, lightforce 140mm driving spot lights, blinker light mod
    yeah when I first dropped mine in I thought the same thing. I got eye level with the lid to make sure the upper clips fit well and you can see it snug up to the air box or whatever. I haven't noticed any issues yet after at least 8-9000miles. my CEL is always on tho as well... damn charcoal canister

    pic just cuz
    [​IMG]
     
  3. Mar 30, 2013 at 9:14 AM
    #3
    Hektor

    Hektor [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28955
    Messages:
    972
    Gender:
    Male
    Texas
    Vehicle:
    03 Tacoma DC TRD v6
    Cool, my CEL is not on so it should be good . Thanks for you reply not I know it's normal. BTW I did notice better throttle response.
     
  4. Mar 30, 2013 at 10:11 AM
    #4
    VlineSci09

    VlineSci09 My other truck is a Warthog

    Joined:
    Feb 25, 2012
    Member:
    #73560
    Messages:
    147
    Gender:
    Male
    SoDak
    Vehicle:
    2003 4x4 TRD
    OME sports with 881 and dakar leaf, raider vagabond topper, minor details to exterior, deckplate mod/afe pro dry s, grey wire mod, Trail Gear low profile bumper w/ light bar, lightforce 140mm driving spot lights, blinker light mod
    ^^ sweet and no prob.

    I also thought (or really hoped) I felt a little increase in response.. probably not. But I didn't have the deckplate installed yet at that point. Then I put my topper on so it all canceled out with that extra weight. haha. It is a quality product though and worth the $
     
To Top