1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

air bag light on

Discussion in '2nd Gen. Tacomas (2005-2015)' started by mxracer16, Jun 4, 2009.

  1. Jun 4, 2009 at 12:48 AM
    #1
    mxracer16

    mxracer16 [OP] Well-Known Member

    Joined:
    Sep 22, 2008
    Member:
    #9403
    Messages:
    74
    Gender:
    Male
    Vehicle:
    2006 trd
    stock stock stock
    About 300 miles ago my air bag light came on.

    I have had no front end damage of any kind.

    Im just wondering what this could be from or what this means.

    Any ideas ?

    Thanks
     
  2. Jun 4, 2009 at 3:17 AM
    #2
    StandingCow

    StandingCow Well-Known Member

    Joined:
    Apr 24, 2009
    Member:
    #16373
    Messages:
    1,799
    Gender:
    Male
    First Name:
    John
    NJ
    Vehicle:
    09 SR5 4x4 V6 access cab
    Might want to take it to the dealer to take a look at under warranty.

    My pass side light came on now. :/ At least that one doesn't bother me, so I ignore it.
     
  3. Jun 4, 2009 at 4:08 AM
    #3
    FoxySandChick

    FoxySandChick Well-Known Member

    Joined:
    Sep 27, 2008
    Member:
    #9505
    Messages:
    2,963
    Gender:
    Female
    First Name:
    Kristin
    Henderson, NV
    Vehicle:
    07 DC 4x4 Base model V6 Impulse Red Pearl
    De-badged, limo tint, black wet okole's, weathertechs, extra d-rings, TSB bilsteins
    What does it say in the owners manual?

    I'm pretty sure it says to take it to a dealership asap, but I don't have the book with me at the moment.

    Air bags are not something you can just reset, the light only comes on if there is a problem with the system and it has to be diagnosed and serviced at a shop/dealer.
     
  4. Jun 4, 2009 at 6:03 AM
    #4
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    You can take a look under the seats- It may be as simple as a disconnected sensor or plug for the weight on seat stuff. It could also be a failed sensor or other issue with the system that you can not fix.

    Note that the air bag system should be in failsafe and should not fire if, god forbid, you do get into an accident and need it. Safest/Best bet imho is to get it to a dealer ASAP.
     
  5. Jun 4, 2009 at 6:51 AM
    #5
    headhunter247

    headhunter247 Well-Known Member

    Joined:
    Oct 16, 2008
    Member:
    #10013
    Messages:
    1,394
    Gender:
    Male
    St. Louis, MO area
    Vehicle:
    13 Taco Double Cab TRD
    Bilstein 5100's all around, front set at 2.5", Toytec AAL, 265/75/16 Duratracs, Pro Comp 5001, Weathertech's, AVS In Channel Visors, Nokya Hyper Yellow fogs, CB Set up, Color matched grill surround, ATC Camper Shell with Yakima Racks, SOS Concepts Regular Rear Bumper.
    Mine just came on too at 70k miles, I am taking it in on Sat. Ill let you know what they find. The guy over the phone said its probably the clock spring. I have no idea about airbags, so they could be telling me wrong.
     
  6. Jun 4, 2009 at 7:03 AM
    #6
    mxracer16

    mxracer16 [OP] Well-Known Member

    Joined:
    Sep 22, 2008
    Member:
    #9403
    Messages:
    74
    Gender:
    Male
    Vehicle:
    2006 trd
    stock stock stock

    thanks alot guys for all the help.

    all it says in the owners man. is to take it in to the dealer.

    mmmmm.... im pretty sure if i had a service man. i could figure it out.
    i need to get one.

    anyway, yes let me know whats up with yours.

    thanks again.
     
To Top