1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Air control lights not working

Discussion in '2nd Gen. Tacomas (2005-2015)' started by windowtinter, May 1, 2012.

  1. May 1, 2012 at 9:43 AM
    #1
    windowtinter

    windowtinter [OP] Member

    Joined:
    Jan 29, 2012
    Member:
    #71692
    Messages:
    21
    Gender:
    Male
    First Name:
    Chris
    NC
    Vehicle:
    TRD Sport 4x4
    Just bought
    Question:

    My 06 tacoma where you adjust air control my lights flicker on and off on occasion and now they are not coming on at all, occasionally they work. and that's on all 3 controls..Is there an easy fix that someone has had this happen? i haven't attempted to pull the unit apart yet to see if it's just a loose connection or whatnot..Is it fairly easy to pull that part of the unit out or a detailed process? Thanks for any info.. Chris
     
  2. May 1, 2012 at 9:56 PM
    #2
    XC4ME

    XC4ME Well-Known Member

    Joined:
    Jan 27, 2009
    Member:
    #13034
    Messages:
    375
    Gender:
    Male
    First Name:
    Mike
    Litchfield Park, Arizona
    Vehicle:
    05 Tacoma DC TRD Sport
    My '05 did the same thing. The two bulbs in the panel went out. The panel just pops out. I use a credit card to lift the edge then just pull it off. The bulbs have a circular brown base and unscrew with a 1/4 turn. The dealer charged me $12 a piece!

    Found this video on youtube that shows you were the bulbs are...
    http://www.youtube.com/watch?v=Rr8o8fM6H-A&feature=related
     
  3. May 1, 2012 at 10:07 PM
    #3
    JoeTacoma02

    JoeTacoma02 Well-Known Member

    Joined:
    Jul 27, 2010
    Member:
    #40831
    Messages:
    3,807
    Gender:
    Male
    Beaverton, OR
    Vehicle:
    SWB 05 Double Cab 4x4 TRD Off Road
    Hahah nice. I occasionally tap mine because half of it goes out(left half) here and there and tapping it makes it come back on.
     
  4. May 2, 2012 at 7:54 AM
    #4
    Bama_TACO

    Bama_TACO ROLL TIDE!!!!!!!

    Joined:
    Aug 3, 2010
    Member:
    #41157
    Messages:
    1,017
    Gender:
    Male
    Winfield, AL
    Vehicle:
    2006 PreRunner Double Cab TRD SPORT
    I had one go out completely a few months ago. Easy repair. Now, every once in a while one side will not illuminate and I can take my hand and bump it and it will come on.
     
To Top