1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Airbag light issue...

Discussion in 'Technical Chat' started by jwhelan, Aug 5, 2010.

  1. Aug 5, 2010 at 10:02 AM
    #1
    jwhelan

    jwhelan [OP] Well-Known Member

    Joined:
    Sep 19, 2009
    Member:
    #23006
    Messages:
    431
    Gender:
    Male
    First Name:
    JW
    Dallas Texas
    Vehicle:
    05 TRD Silver
    TRD PreRunner, 5100's on all four fronts @ 1.75, AAL, SP performance rotors, hawk pads, 17" FJ Cruiser wheels P/C black, 265/65/17 BFGR Rugged Trails, BHLM , painted grill, blacked out emblems
    My airbag light in the dash on the speedo side came on and stays on with nothing in the passenger seat...any ideas?
     
  2. Aug 5, 2010 at 10:03 AM
    #2
    Brunes

    Brunes abides. Staff Member

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,730
    Gender:
    Male
    First Name:
    Rotorhead
    Big Easy, USA
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit Upcoming: ATO Gas Tank Skid and Sliders w/ kickout. ATO Shackle Flip Kit. Down the line: Front/Rear ARB Lockers w/ OBA. 4.56 Gears
    Bad sensor, unplugged wires?? Have you stuffed another under the seats or removed them recently?? Made any electrical changes??
     
  3. Aug 5, 2010 at 10:33 AM
    #3
    jwhelan

    jwhelan [OP] Well-Known Member

    Joined:
    Sep 19, 2009
    Member:
    #23006
    Messages:
    431
    Gender:
    Male
    First Name:
    JW
    Dallas Texas
    Vehicle:
    05 TRD Silver
    TRD PreRunner, 5100's on all four fronts @ 1.75, AAL, SP performance rotors, hawk pads, 17" FJ Cruiser wheels P/C black, 265/65/17 BFGR Rugged Trails, BHLM , painted grill, blacked out emblems
    No but I will check...
     
  4. Aug 5, 2010 at 4:27 PM
    #4
    jwhelan

    jwhelan [OP] Well-Known Member

    Joined:
    Sep 19, 2009
    Member:
    #23006
    Messages:
    431
    Gender:
    Male
    First Name:
    JW
    Dallas Texas
    Vehicle:
    05 TRD Silver
    TRD PreRunner, 5100's on all four fronts @ 1.75, AAL, SP performance rotors, hawk pads, 17" FJ Cruiser wheels P/C black, 265/65/17 BFGR Rugged Trails, BHLM , painted grill, blacked out emblems
    Checked wires everything in intact, anyone know where the sensor is?
     
  5. Aug 5, 2010 at 4:46 PM
    #5
    Taco505

    Taco505 Well-Known Member

    Joined:
    Feb 15, 2009
    Member:
    #13659
    Messages:
    2,572
    Gender:
    Male
    First Name:
    Alex
    New Mexico
    Vehicle:
    08 4cly
    Dule Magnaflow Exhaust dumped behind axle, K&N Air intake, Aftermarket radio with a kicker L5 sub & a shit amp, 18" rims with tires, RHLM, DT header, color matched bumper, oem foglights, 8k hids in headlights and in fogs
    if its in the dash the little red light then the spring or wire (behind the steering wheel) whatever it is that tells the air bag to go off it most likely broken. so in other words if you get in a wreck where the air bag needs to deploy it wont.

    this happened to me and i took it to the dealership they told me it would cost $350 to fix it, all thought i was out of warranty i told them eff that its safety equipment thats is standard its not optional so fix it. they argued with me and told me that only the seat belts were covered and i said nope fix it or the GM, BBB, and attorney general will be getting a call from me. they said sorry to bad and i told them to look forward to hearing from me they called on my way home and said they would fix it for no charge :D

    just get it fixed, and dont take no for an answer best to keep you and others safe
     
  6. Aug 5, 2010 at 5:58 PM
    #6
    jwhelan

    jwhelan [OP] Well-Known Member

    Joined:
    Sep 19, 2009
    Member:
    #23006
    Messages:
    431
    Gender:
    Male
    First Name:
    JW
    Dallas Texas
    Vehicle:
    05 TRD Silver
    TRD PreRunner, 5100's on all four fronts @ 1.75, AAL, SP performance rotors, hawk pads, 17" FJ Cruiser wheels P/C black, 265/65/17 BFGR Rugged Trails, BHLM , painted grill, blacked out emblems
    Not under warranty any longer
     
  7. Aug 5, 2010 at 6:11 PM
    #7
    David K

    David K Well-Known Member

    Joined:
    Jun 27, 2009
    Member:
    #18969
    Messages:
    9,081
    Gender:
    Male
    San Marcos, Alta California
    Vehicle:
    2010 4WD Off Road DC
    Differential Breather Mod Light Bar: 2 Hella 4000 HID, 1 Cibie Halogen. Bilstein 5100s Ride Rite Air Bags
    It is a bad wire harness... My '05 light came on... out of warantee... close to $400 to fix.

    Definate a Toyota product failure that many of us have had... It was the only failure on my 2005 Tacoma (other than the soft rear springs) that I had to pay for in 102,000 miles... not bad at all, IMO.
     
  8. Aug 5, 2010 at 9:23 PM
    #8
    Taco505

    Taco505 Well-Known Member

    Joined:
    Feb 15, 2009
    Member:
    #13659
    Messages:
    2,572
    Gender:
    Male
    First Name:
    Alex
    New Mexico
    Vehicle:
    08 4cly
    Dule Magnaflow Exhaust dumped behind axle, K&N Air intake, Aftermarket radio with a kicker L5 sub & a shit amp, 18" rims with tires, RHLM, DT header, color matched bumper, oem foglights, 8k hids in headlights and in fogs
    i was out of warranty as well, but they did it for free
     
  9. Aug 5, 2010 at 9:32 PM
    #9
    afd23a

    afd23a Well-Known Member

    Joined:
    Sep 26, 2008
    Member:
    #9483
    Messages:
    1,811
    Gender:
    Male
    The Dynamo of Dixie
    Vehicle:
    05 Access Cab 5 Lugger
    Factory Fog Lights, Removed Secondary Air Filter, Metra Ipod Adapter, Int Wiper Stalk, Wet Okole's, URD Short Shifter, Scanguage II w/Blendmount, Fat Bob's 2.75" spacer lift, ARE topper, SP Performance Pads & Slotted Rotors, 4.10 gears
    when the airbag light came on, it turned out to be the clock spring on mine. about 3-400 for the dealer to fix
     
  10. Aug 5, 2010 at 9:37 PM
    #10
    Taco505

    Taco505 Well-Known Member

    Joined:
    Feb 15, 2009
    Member:
    #13659
    Messages:
    2,572
    Gender:
    Male
    First Name:
    Alex
    New Mexico
    Vehicle:
    08 4cly
    Dule Magnaflow Exhaust dumped behind axle, K&N Air intake, Aftermarket radio with a kicker L5 sub & a shit amp, 18" rims with tires, RHLM, DT header, color matched bumper, oem foglights, 8k hids in headlights and in fogs
    thats exactly what it is i couldnt remember the damn name haha
     
To Top