1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Airbag light on! Y? no airbags went off ! hmmm

Discussion in '2nd Gen. Tacomas (2005-2015)' started by stinky_truck, Sep 11, 2010.

  1. Sep 11, 2010 at 6:01 PM
    #1
    stinky_truck

    stinky_truck [OP] Well-Known Member

    Joined:
    Apr 28, 2009
    Member:
    #16549
    Messages:
    154
    Gender:
    Male
    First Name:
    ryan
    i=13 miles currently @ 75,500 miles
    Vehicle:
    Plane Jane:4x4,6 speed, shortest bed,URD3SC
    front baja bbq hoop bumper and rear allpro bumper, URD SCIII,urd short throw & stg IIIclutch combo kit w/throwout, DDM Hid 4000k, icon frt (coil overs)& rear shocks (piggy back rez)& add a leaf.
    :confused: my airbag light is on! Y? no airbags ever deployed. i was in an accident 8 months ago. :( y act up now? help me out. anybody ever have this problem?
    _stinky ghetto truck

    [​IMG]
     
  2. Sep 11, 2010 at 6:03 PM
    #2
    rex99

    rex99 Well-Known Member

    Joined:
    Dec 13, 2009
    Member:
    #27492
    Messages:
    6,963
    Gender:
    Male
    TArdCOMAWORLD
    Vehicle:
    Proton Cruiser
    Rocket Boosters, Flux Capacitor, Escape Pod, Throttle Body Spacer, Homeroshi, ATRAC disable
    check your fuses...did you do anything like install a new stereo or anything?
     
  3. Sep 11, 2010 at 6:04 PM
    #3
    Asgard

    Asgard Well-Known Member

    Joined:
    Apr 19, 2008
    Member:
    #6078
    Messages:
    1,093
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    06 PreRunner DC SR5 w/LSD
    Most likely a broken clockspring which means your airbag won't deploy in an accident.
     
  4. Sep 11, 2010 at 6:09 PM
    #4
    Cars0n`

    Cars0n` Well-Known Member

    Joined:
    Sep 8, 2008
    Member:
    #9091
    Messages:
    1,430
    Gender:
    Male
    First Name:
    Carson
    Edmonton AB
    Vehicle:
    07 2wd access cab base.
    Kenwood DDX-512 Deck, Boston Acoustics G5 Sub in Ported Bassworx Box, Kenwood eXcelon KAC-X10D Amp, Sirius Satellite Radio, Magellan GPS, DDM 55w bi-xenon headlights, 2 HID Hella 500ff's mounted behind grill, 4 pc ebay Billet grill, Fog Lights (my truck didnt have them stock), Pioneer Speakers 6x9's(front) 6.5's(rear) AFE Cold Air Intake, Hose Clamp Mod, Tailgate Strengthen Mod, Removed Gay Mud Flaps, De-Badged, BHLM, 245/45/20 on velocity wheels. VW865a, Extra D Rings In Box, OEM Cruise Added Optima Red Top Battery
    i had my airbag light on and it was from a unplugged connector in one of the door panels. something to do with the seatbelt pretensioner. maybe check that out?
     
  5. Sep 11, 2010 at 6:10 PM
    #5
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,566
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    Do the people that fixed you truck have a liftime warranty? When I got my truck fixed they told me if there is anything wrong to bring it back to them (Of what they were suposed to fix).
     
  6. Sep 12, 2010 at 11:43 AM
    #6
    Taco93

    Taco93 Well-Known Member

    Joined:
    Dec 9, 2008
    Member:
    #11429
    Messages:
    196
    Gender:
    Male
    Milton, Ontario
    Vehicle:
    2011 TRD Sport
    Extang Trifecta Tonneau, Weathertech Floor Liners
  7. Sep 12, 2010 at 11:47 AM
    #7
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    The airbag light means something is wrong with the aigbag system....Not that they have deployed. So you need to check the connectors under the seats, thru the doors, to the sensors, check the clockspring in the steering wheel, and continue from there...
    It could be related to your accident- so it might be worth checking with the company that did the repairs about it...See if it might be covered....
     
  8. Oct 16, 2010 at 12:44 PM
    #8
    Ray07tacoma

    Ray07tacoma Well-Known Member

    Joined:
    Jul 13, 2010
    Member:
    #40150
    Messages:
    97
    Gender:
    Male
    First Name:
    Ray
    Phoenix
    Vehicle:
    07 Tacoma access 4x4
    turbo KN Filter 3" Lift Kit Rock Sliders TRD Skid plate ProComp 285/75R16, Removed. FJ Wheels w/ 265/70R17 Delay wiper switch 168xxx miles, engine lost compression at cyl 1. Replaced with pulled engine with 63k miles (non Turbo).
    I had been wrestling this for the last 2 months. It is not just a nagging warning light, more important is that your airbags might not deploy in an accident.
    The only special tool required to remove the clockspring is a wheel puller and once out you can check the continuity of the cable with a ohm meter. From the multiple post and from what I saw of this part, this is probably 90% of the warning light issues.(10 minutes procedure)
    ck this post:
    http://www.tacomaworld.com/forum/te...ing-airbag-light-post2285436.html#post2285436
     
  9. Oct 16, 2010 at 12:47 PM
    #9
    xroller

    xroller Blowin by em sideways

    Joined:
    Apr 26, 2010
    Member:
    #36060
    Messages:
    2,356
    Gender:
    Male
    First Name:
    Ramon
    Albuquerque New Mexico
    Vehicle:
    2006 Toyota Tacoma Xrunner Speedway Blue
    1 hp mod
    I had mine turn on because I disconnected the plug where you can put the key in it to turn it on and off.... I just turned the airbag off started the truck and the light was gone.... I turned the airbag back on and it was still off.
     
  10. Oct 16, 2010 at 12:52 PM
    #10
    jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Moderator

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    28,119
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    none of that in a DC
     
  11. Oct 16, 2010 at 12:56 PM
    #11
    Krazie Sj

    Krazie Sj Resident Jackass

    Joined:
    Oct 9, 2008
    Member:
    #9849
    Messages:
    13,686
    Gender:
    Male
    First Name:
    Power Serge
    LV-426 (Acheron)
    Vehicle:
    07 TRD Off Road 4x4
    Borla Catback Exhaust, Airaid Short Ram Intake, 285x75R16 Mickey Thompson MTZs, 16" Konig Countersteer rims, ARB Bumper, All Pro LT w/Walker Evan Shocks front and back, All Pro expedition leaf pack, 10,000lb Superwinch, Intake Manifold Spacer, Bed Rack with ARB RTT, Rotopack and Hi Lift mounted, Husky Liner mats and an air freshener from 1995.
    Mine is finicky with my car starter. Sometimes when I use the starter function the airbag light comes on till I turn the truck off and on again.
     
To Top