1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Airbag notification on dash..

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Karo, Aug 21, 2010.

  1. Aug 21, 2010 at 7:35 PM
    #1
    Karo

    Karo [OP] Well-Known Member

    Joined:
    May 18, 2010
    Member:
    #37366
    Messages:
    192
    Gender:
    Male
    First Name:
    Karo
    La Crescenta, CA
    Vehicle:
    06 PreRunner TRD Sport
    Grill
    My airbag notification light just came on today. I have never deployed any of my airbags throughout the lifetime of my truck.

    I called my dealer and asked what could have caused this and they said it might be due to a malfunction at the seat-belt sensor.

    Is there anything I can do to fix this issue?
     
  2. Aug 21, 2010 at 7:41 PM
    #2
    trd7

    trd7 4wd tacoma

    Joined:
    Jun 14, 2010
    Member:
    #38931
    Messages:
    899
    Gender:
    Male
    First Name:
    Tyler
    Columbia, SC
    Vehicle:
    95.5 Tacoma 4x4 4cyl auto
    AEM air intake
    Take it somewhere and get the codes scanned and see what the codes read
     
  3. Aug 21, 2010 at 9:47 PM
    #3
    NelsonTacoma

    NelsonTacoma This is my derpawayinator!!!!!

    Joined:
    Mar 25, 2010
    Member:
    #33969
    Messages:
    2,080
    Gender:
    Male
    Tucson, AZ
    Vehicle:
    06 PreRunner TRD Sport 03 4Runner Limited 4wd
    Bilstein 5100's , 6000k HID Hi/Low Kit, Magnaflow Muffler, 1.5 inch AP Wheel Spacers, Mudflap Delete
    ^^x2

    It could be anything. From a bad airbag to a bad seatbelt buckle. Most likely it's the airbag coil, some on here call it a clockspring, it's the thing in your steering column that lets the steering wheel spin and have your airbag, horn & steering wheel controls work. I've seen numerous threads on here about that part going bad.
     
  4. Aug 21, 2010 at 9:48 PM
    #4
    MxRacer190

    MxRacer190 Well-Known Member

    Joined:
    Apr 15, 2010
    Member:
    #35345
    Messages:
    2,471
    Gender:
    Male
    Georgia
    Vehicle:
    06 SR5 4x4 Indigo
    this. Toyota conspiracy I tell you.
     
  5. Aug 24, 2010 at 6:58 AM
    #5
    akcoma

    akcoma Member

    Joined:
    Dec 20, 2009
    Member:
    #27881
    Messages:
    7
    Gender:
    Male
    First Name:
    alfredo
    Mckinney, TX
    Vehicle:
    '07 PreRunner
    If your airbaglight came on take it to your nearest dealer and have the DTC's read with a code reader. Then go to the TSM online and if it involves the clockspring under the steering wheel you can either try to fix it yourself :annoyed::confused: or buy the part from your dealer and install it yourself...., do a search here and you will get several good leads

    Here are some links that may help out!!!

    http://www.tacomaworld.com/forum/2nd-gen-tacomas/64792-air-bag-sensor-light-fail.html

    http://www.tacomaworld.com/forum/2nd-gen-tacomas/60061-srs-warning-light.html
     
  6. Sep 29, 2010 at 10:29 AM
    #6
    Ray07tacoma

    Ray07tacoma Well-Known Member

    Joined:
    Jul 13, 2010
    Member:
    #40150
    Messages:
    97
    Gender:
    Male
    First Name:
    Ray
    Phoenix
    Vehicle:
    07 Tacoma access 4x4
    turbo KN Filter 3" Lift Kit Rock Sliders TRD Skid plate ProComp 285/75R16, Removed. FJ Wheels w/ 265/70R17 Delay wiper switch 168xxx miles, engine lost compression at cyl 1. Replaced with pulled engine with 63k miles (non Turbo).
    Airbag light has been ON for a couple months, horn + cruise works.
    took to Autozone but they cannot read ABS codes!
    called Actron,they referred me to OTC Tools >>they want $$$ in the thousandss
    Would buy an OBDII reader that can also read ABS.
    Also able to scan the following:
    01 Ford F150
    02 Ford Ranger
    04 GMC Yukon
    05 Hyundai Accent
    07 Toyota Tacoma
    Anyone has suggestions/comments on what will do the job.
    Thanks
     
  7. Sep 29, 2010 at 11:43 AM
    #7
    Fortech

    Fortech Well-Known Member

    Joined:
    Mar 31, 2008
    Member:
    #5636
    Messages:
    878
    Gender:
    Male
    CANADA
    Vehicle:
    2005 Toyota Tacoma TRD OR
    Bilstein 5100's, rear TSB, Firestone bags
    SRS = Supplemental Restraint System (Airbags)

    ABS = Anti Lock Braking System (Brakes)

    Which do you require?
     
  8. Sep 29, 2010 at 11:50 AM
    #8
    afd23a

    afd23a Well-Known Member

    Joined:
    Sep 26, 2008
    Member:
    #9483
    Messages:
    1,838
    Gender:
    Male
    The Dynamo of Dixie
    Vehicle:
    05 Access Cab 5 Lugger
    Factory Fog Lights, Removed Secondary Air Filter, Metra Ipod Adapter, Int Wiper Stalk, Wet Okole's, URD Short Shifter, Scanguage II w/Blendmount, Fat Bob's 2.75" spacer lift, ARE topper, SP Performance Pads & Slotted Rotors, 4.10 gears
  9. Sep 29, 2010 at 12:40 PM
    #9
    David K

    David K Well-Known Member

    Joined:
    Jun 27, 2009
    Member:
    #18969
    Messages:
    9,941
    Gender:
    Male
    San Marcos, Alta California
    Vehicle:
    2010 4WD Off Road DC
    Differential Breather Mod Light Bar: 2 Hella 4000 HID, 1 Cibie Halogen. Bilstein 5100s Ride Rite Air Bags
    This is old news... my 2005 light also came on, out of warantee... faulty wire harness... $300 fix... at dealer... zillions of 2nd gen. tacos have had that light go on because of the 'defective' wire harness.
     
  10. Sep 29, 2010 at 12:57 PM
    #10
    IslandBoy71

    IslandBoy71 Well-Known Member

    Joined:
    Jul 25, 2009
    Member:
    #20177
    Messages:
    381
    Gender:
    Male
    First Name:
    Reggie
    Lakewood, CA
    Vehicle:
    06 TRD PreRunner Sport SR5 DC
    TRD Intake,TRD cat back exhaust, Billet front grill

    I have the same issue, mine has been on for over a year now.
     
  11. Sep 29, 2010 at 3:35 PM
    #11
    DOT

    DOT Well-Known Member

    Joined:
    Apr 14, 2010
    Member:
    #35260
    Messages:
    2,341
    Gender:
    Male
    First Name:
    Jobin
    Littleton CO
    Vehicle:
    2007 FJ
    3'' toytec lift
    It came on in my 2005 50 miles after the warrenty was up, anyone know how many toyota has to get to make it a recall ? This is just rip from the stealership if you ask me !
     
  12. Sep 29, 2010 at 4:41 PM
    #12
    Ray07tacoma

    Ray07tacoma Well-Known Member

    Joined:
    Jul 13, 2010
    Member:
    #40150
    Messages:
    97
    Gender:
    Male
    First Name:
    Ray
    Phoenix
    Vehicle:
    07 Tacoma access 4x4
    turbo KN Filter 3" Lift Kit Rock Sliders TRD Skid plate ProComp 285/75R16, Removed. FJ Wheels w/ 265/70R17 Delay wiper switch 168xxx miles, engine lost compression at cyl 1. Replaced with pulled engine with 63k miles (non Turbo).
    Ok, I've read the forum and seen write ups on the ribbon assembly inside the steering wheel.
    The Ford Ranger has the same set up for the horn and whatever, but it does not trigger the airbag light; and I've resoldered that stupid ribbon in the past.

    I will hate to take apart the steering wheel of the Tacoma just to check that ribbon, anyone knows of easier way check it out?
    My Tacoma horn and cruise seemed to work fine.
    The truck was involved in light rollover but the airbag light was OFF then, light only came on a couple months ago so I am thinking that some sensor went out.
     
  13. Sep 29, 2010 at 4:49 PM
    #13
    Ray07tacoma

    Ray07tacoma Well-Known Member

    Joined:
    Jul 13, 2010
    Member:
    #40150
    Messages:
    97
    Gender:
    Male
    First Name:
    Ray
    Phoenix
    Vehicle:
    07 Tacoma access 4x4
    turbo KN Filter 3" Lift Kit Rock Sliders TRD Skid plate ProComp 285/75R16, Removed. FJ Wheels w/ 265/70R17 Delay wiper switch 168xxx miles, engine lost compression at cyl 1. Replaced with pulled engine with 63k miles (non Turbo).
    FORTECH,
    you are right as I was thinking SRS and I typed ABS.

    I am looking to read AIRBAG LIGHT codes to see which sensors are giving me trouble.
     
  14. Sep 29, 2010 at 5:02 PM
    #14
    David K

    David K Well-Known Member

    Joined:
    Jun 27, 2009
    Member:
    #18969
    Messages:
    9,941
    Gender:
    Male
    San Marcos, Alta California
    Vehicle:
    2010 4WD Off Road DC
    Differential Breather Mod Light Bar: 2 Hella 4000 HID, 1 Cibie Halogen. Bilstein 5100s Ride Rite Air Bags
    The wire harness defect ONLY caused the airbag light to come on, nothing else failed or doesn't work.
     
  15. Sep 30, 2010 at 6:41 PM
    #15
    Ray07tacoma

    Ray07tacoma Well-Known Member

    Joined:
    Jul 13, 2010
    Member:
    #40150
    Messages:
    97
    Gender:
    Male
    First Name:
    Ray
    Phoenix
    Vehicle:
    07 Tacoma access 4x4
    turbo KN Filter 3" Lift Kit Rock Sliders TRD Skid plate ProComp 285/75R16, Removed. FJ Wheels w/ 265/70R17 Delay wiper switch 168xxx miles, engine lost compression at cyl 1. Replaced with pulled engine with 63k miles (non Turbo).
    so I took the steering wheel apart and removed the springclock for inspection.
    Physically looks good and clean, so I did a continuity test fom end to end.
    found 2 pins that seemed to be shorted out and 2 others that are showing nothing??
    Took the assembly apart, cable was dusty, there was a couple tears in the middle of the cable with breaks in the insulation + copper, also 2 lines are shorted out somewhere.
    Now I need to replace this assembly as there is no way to repair this ribbon.
    anyone has one laying around?? I am shopping for one.

    [​IMG]
     
  16. May 13, 2011 at 2:58 PM
    #16
    cactuspete1972

    cactuspete1972 Member

    Joined:
    Aug 23, 2009
    Member:
    #21611
    Messages:
    6
    Gender:
    Male
    First Name:
    Pete
    Wilmington NC
    Vehicle:
    2002 SR5 V6 4x4 Double Cab
    Took my 2002 tacoma to the dealership because the airbag light is blinking. They checked it out and said its a bad wire harness. They want $406 to replace it. Has anyone ever replaced it themselves. The part is only $60 bucks.
     
  17. May 14, 2011 at 4:00 PM
    #17
    Ray07tacoma

    Ray07tacoma Well-Known Member

    Joined:
    Jul 13, 2010
    Member:
    #40150
    Messages:
    97
    Gender:
    Male
    First Name:
    Ray
    Phoenix
    Vehicle:
    07 Tacoma access 4x4
    turbo KN Filter 3" Lift Kit Rock Sliders TRD Skid plate ProComp 285/75R16, Removed. FJ Wheels w/ 265/70R17 Delay wiper switch 168xxx miles, engine lost compression at cyl 1. Replaced with pulled engine with 63k miles (non Turbo).
    Not too difficult on the 2007,

    BE SURE TO DISCONNECT BATTERY. would be a bad day if airbag blows on you.:mad:

    pay attention to wires connections, also may need a wheel puller.
     
  18. May 24, 2011 at 3:08 PM
    #18
    shockittillyareconizeit

    shockittillyareconizeit Well-Known Member

    Joined:
    Jul 7, 2009
    Member:
    #19405
    Messages:
    230
    Gender:
    Male
    First Name:
    Dustin
    California
    Vehicle:
    '07 Coma PreRunner
    Front - Icon 2.5 Coilovers, Maxtrac 4" lift spindles, TC UCA's Rear - Billy's 5100/1.5 AAL, 3" lift blocks MB Predator wheels - 16x8 plasti-dipped matte black Toyo Open Country A/T 305/70/16 Satoshi grille Blacked out badges DTRL Wet Okole seat covers
    Ok, so it can be multiple issues, some of which aren't very important it seems. Mine just came on today and NelsonTacoma referred to the Airbag coil or "clockspring"... My question is with the clockspring, if that is the problem, is there a possibility of the airbag deploying suddenly because the wheel turned too far or something else? I mean, other than if you got into an accident :)
     
  19. May 24, 2011 at 6:43 PM
    #19
    NelsonTacoma

    NelsonTacoma This is my derpawayinator!!!!!

    Joined:
    Mar 25, 2010
    Member:
    #33969
    Messages:
    2,080
    Gender:
    Male
    Tucson, AZ
    Vehicle:
    06 PreRunner TRD Sport 03 4Runner Limited 4wd
    Bilstein 5100's , 6000k HID Hi/Low Kit, Magnaflow Muffler, 1.5 inch AP Wheel Spacers, Mudflap Delete
    If your airbag light is on the entire system is disabled, therefore the airbag should not deploy suddenly. That's not to say it can't happen, but the likelyhood of it happening is very small. You probably have a better chance of winning the lottery than having your airbag suddenly deploy for no reason.
     
  20. May 27, 2011 at 9:11 AM
    #20
    dalucca

    dalucca Member

    Joined:
    Jun 6, 2007
    Member:
    #1775
    Messages:
    9
    I believe I have pinpointed my issue to the drivers side. When I have a passenger buckled in the front the SRS light shows on. So my thoughts are it may not be a problem with the springclock bit either the sensor under the drivers seat or the seat belt buckle. The sensor seems to be plugged in properly, so I am at a loss. Any ideas what to check next?
     
To Top