1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Alternator..BATT light..Question..?????

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Mr.Tacoma, Jul 13, 2011.

  1. Jul 13, 2011 at 8:03 PM
    #1
    Mr.Tacoma

    Mr.Tacoma [OP] Well-Known Member

    Joined:
    Oct 25, 2010
    Member:
    #45225
    Messages:
    156
    Gender:
    Male
    toronto
    Vehicle:
    DoubleCab4x4
    TRD Exhaust, Side step bar & ARE cap
    Heyfolks..The Batt light comes on dash soon as truck is started and doesnt go away. Owners manual says..check charging system. The battery is just a year old. It starts fine without any hesitation. A/C doesnt work too. Mine is a V6 SR5 (Not TRD) i guess it has standard alternator. I recently towed my travel trailer (3800 lbs) with 7 pin harness. Question is would the load hav killed the alternator..reason i ask is i smelt hot coolant kind of smell during the return leg.
    Is the arrow pointing the alternator in the picture..?? thnks :)

    IMAG0307a.jpg
     
  2. Jul 13, 2011 at 8:08 PM
    #2
    1Bigbird

    1Bigbird Yo! Wat up peeps?

    Joined:
    Apr 24, 2011
    Member:
    #55460
    Messages:
    420
    Gender:
    Male
    winter-peg
    Vehicle:
    2010 TRD D-Cab
To Top