1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Amp and sub Help Asap

Discussion in 'Audio & Video' started by Newlife, Sep 5, 2013.

  1. Sep 5, 2013 at 11:47 PM
    #1
    Newlife

    Newlife [OP] Well-Known Member

    Joined:
    Jun 22, 2013
    Member:
    #106845
    Messages:
    5,157
    Gender:
    Male
    First Name:
    Adam
    Knoxville TN
    Vehicle:
    Underdog
    Pioneer avh x3500 bhs, Alpine amp and subs, avs window visors, 3" omelift with bastard pack, full synthetic fluid swap, 15% tint all over, debadged all the way around.,two cree led pods near windshield, Katzkins grey and barracuda red leather interior all around. BFG at ka 33's. American out law buckshot 16x9. Bruteforce Fab rear bumper. SOS concepts front bumper. Engo 10000s winch And a bunch of other money tied up in it,
    I picked up a ported double 8" box today with an alpine mrv f545 and two 8" arc audio subs. I know it is a cheap system but I got it for a great deal and just wanted to add a little more thump to my truck. ( one of the biggest things I miss about the mustang).

    Tonight I installed everything and got it all hooked up. Everything comes on the display on the amp stays around 13.1-13.2 but the subs are barely thumping. What could be causing this issue. It has to be something in my install.

    Only thing I am thinking it could be was not good enough wire or bad ground. I grounded to the seat in the back.

    I know it works well because I took it to best buy and had a friend test everything and it was pretty decent there. So what could I have done wrong?

    I ran power and remote down drivers side and ran rca's down pass side. and like I said ground is to one of the seat bolts that holds the top of the seat to the bottom.
     
  2. Sep 5, 2013 at 11:48 PM
    #2
    Newlife

    Newlife [OP] Well-Known Member

    Joined:
    Jun 22, 2013
    Member:
    #106845
    Messages:
    5,157
    Gender:
    Male
    First Name:
    Adam
    Knoxville TN
    Vehicle:
    Underdog
    Pioneer avh x3500 bhs, Alpine amp and subs, avs window visors, 3" omelift with bastard pack, full synthetic fluid swap, 15% tint all over, debadged all the way around.,two cree led pods near windshield, Katzkins grey and barracuda red leather interior all around. BFG at ka 33's. American out law buckshot 16x9. Bruteforce Fab rear bumper. SOS concepts front bumper. Engo 10000s winch And a bunch of other money tied up in it,
    Also I checked the settings on my head unit and they are fine. I even turned sub gain up to 6 on the pioneer. There are no controls on the amp itself that I can see.
     
  3. Sep 5, 2013 at 11:55 PM
    #3
    Newlife

    Newlife [OP] Well-Known Member

    Joined:
    Jun 22, 2013
    Member:
    #106845
    Messages:
    5,157
    Gender:
    Male
    First Name:
    Adam
    Knoxville TN
    Vehicle:
    Underdog
    Pioneer avh x3500 bhs, Alpine amp and subs, avs window visors, 3" omelift with bastard pack, full synthetic fluid swap, 15% tint all over, debadged all the way around.,two cree led pods near windshield, Katzkins grey and barracuda red leather interior all around. BFG at ka 33's. American out law buckshot 16x9. Bruteforce Fab rear bumper. SOS concepts front bumper. Engo 10000s winch And a bunch of other money tied up in it,
    Hang on I found the owners manual online. There are settings for specific radios to follow. Gotta take off the top cover
     
  4. Sep 6, 2013 at 12:34 AM
    #4
    Newlife

    Newlife [OP] Well-Known Member

    Joined:
    Jun 22, 2013
    Member:
    #106845
    Messages:
    5,157
    Gender:
    Male
    First Name:
    Adam
    Knoxville TN
    Vehicle:
    Underdog
    Pioneer avh x3500 bhs, Alpine amp and subs, avs window visors, 3" omelift with bastard pack, full synthetic fluid swap, 15% tint all over, debadged all the way around.,two cree led pods near windshield, Katzkins grey and barracuda red leather interior all around. BFG at ka 33's. American out law buckshot 16x9. Bruteforce Fab rear bumper. SOS concepts front bumper. Engo 10000s winch And a bunch of other money tied up in it,
    Got it all set
     
To Top