1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Another "moulding" is coming off question

Discussion in 'X-Runners' started by gsy971, May 13, 2024.

  1. May 13, 2024 at 6:11 PM
    #1
    gsy971

    gsy971 [OP] Member

    Joined:
    Apr 11, 2024
    Member:
    #447695
    Messages:
    12
    Gender:
    Male
    Vehicle:
    ‘15 Xrunner
    Ok gang new Xrunner owner here as i am trying to tidy up my NEW used '15 Hawaii Only
    X-Runner.
    Seems as if moulding side skirts are an issue and mine is no exception. Not only do i have a few missing clips but the some retainers that are glued or molded into the moulding have broken off. Dealer was somewhat helpful but determined that the retainer clips are part of the complete moulding (75805-04901 - passenger) and cannot be ordered separately.
    Any ideas now of how to fix this to flush the moulding to the body without the retainers? I am probably going to take this to body shop but am afraid they will tell me to get a new moulding which is going to be almost $400 i don't think i want to pay and is not color matched.

    I was thinking of using adhesive magnets applied to the body and moulding?
     
  2. May 15, 2024 at 11:53 PM
    #2
    hemitruk

    hemitruk Old man , young boi truk

    Joined:
    Oct 17, 2009
    Member:
    #24461
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Kurt
    Hawaii
    Vehicle:
    2010 Dbl Cab Sport,
    A few
    JB plastic epoxy puddy and JB plastic epoxy works pretty good . What side skirts you talking about . Cab , Bed ? Pics of broken tabs. I repaired mine.
     
  3. May 29, 2024 at 11:14 AM
    #3
    gsy971

    gsy971 [OP] Member

    Joined:
    Apr 11, 2024
    Member:
    #447695
    Messages:
    12
    Gender:
    Male
    Vehicle:
    ‘15 Xrunner
    My passenger side moulding running along the door and access cab and the driver side rear moulding on the opposite side of the exhaust.

    k updates. I just did the rear driver mouldingl where there were 3 clips. Clips were intact but the 3 attached retainers broke off the moulding.
    I used 1" cable zip tie mounts. Secondly remove the 3M adhesive pad so it is just plastic. CLEAN THE AREA WELL!!! Use JB Weld 2 part epoxy for plastics to glue the zip tie mounts to the area where the retainer broke off.
    I used 18g stainless steel wire instead of zip ties. You will need to drill a hole beneath the existing body holes to run the SS wire through. Spray the holes with paint to inhibit rust. Ran the wire through the mounts then through body panel holes then twisted it as close to the base as possible. Hand twisted the wire then used a pliers with a twisting action to twist tighten the wire as close to and as tight so the moulding pulls flush on the body. It's on there solid! CHEEE HOOO!!!

    Now to attack the larger passenger side moulding
     
  4. May 29, 2024 at 3:14 PM
    #4
    hemitruk

    hemitruk Old man , young boi truk

    Joined:
    Oct 17, 2009
    Member:
    #24461
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Kurt
    Hawaii
    Vehicle:
    2010 Dbl Cab Sport,
    A few
    Tabs still attached . Use epoxy on mine and still good since 2019. Easier if you take spoiler off

    20240529_115446.jpg
     

Products Discussed in

To Top