1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Any XS650 owners on here?

Discussion in 'Motorcycles' started by pittim, Jul 25, 2011.

  1. Jul 25, 2011 at 12:58 PM
    #1
    pittim

    pittim [OP] Play stupid games, win stupid prizes

    Joined:
    May 28, 2008
    Member:
    #6939
    Messages:
    10,852
    Gender:
    Male
    First Name:
    Tim
    IN, PA
    Vehicle:
    Dented and rusty
    Pink slider.
    I'm going to be looking at an 79 Special this week, has 7xxx miles on it. Current owner just put new wires and plugs in, plus fork boots. Some other recent work was fresh oil, carbs cleaned, timing chain adjusted, points adjusted, clutch adjusted, new fuel and vac lines. He does say that the battery in it does not hold a charge for more than a week, but it kick starts pretty easily, thinking this is an alternator issue?

    Anyway, if any of ya'll have/had one and can give me some tips on things to look out for, let me know!
     
  2. Sep 26, 2011 at 7:10 PM
    #2
    oldtimertoyota

    oldtimertoyota Well-Known Member

    Joined:
    Aug 5, 2009
    Member:
    #20697
    Messages:
    278
    Gender:
    Male
    New Mexico
    Vehicle:
    2009 4X4 Double Cab
    I recently sold my 78 XS650, it was a fun and easy bike to ride and work on. Finding neutral can sometimes be tricky on many XS bikes. Here is my old bike, kind of miss it!

    [​IMG]
     
To Top