1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Anyone have problems with their 09?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by 09tacoma, Oct 9, 2008.

  1. Oct 9, 2008 at 8:39 PM
    #1
    09tacoma

    09tacoma [OP] Well-Known Member

    Joined:
    Sep 13, 2008
    Member:
    #9199
    Messages:
    50
    OKC
    Vehicle:
    4x4 off road
    access tonneau cover, smitty built side steps
    I am going to take delivery of my 09 in a week and I want to know has anyone had any problems? Bottoming out? Bad radio? Anything? I am getting a double cab 4x4 off road model and I would like to know about any problems so I can make the dealer fix them before I pay for the truck, give them a little motivation to get it done. Thanks
     
  2. Oct 9, 2008 at 9:03 PM
    #2
    LonghornTaco

    LonghornTaco Can you pass the bailout please?

    Joined:
    Oct 6, 2008
    Member:
    #9763
    Messages:
    3,355
    Gender:
    Male
    First Name:
    Jason
    Minnesota
    Vehicle:
    Black 09 4x4 TRD Off Road Doublecab
    3" ToyTec coilover lift on Bilstein 5100s, Total Chaos UCAs, ToyTec diff drop, Scangauge II, 4D MagLite mounted on the drivers seat, Painted engine cover, Painted calipers (red), Painted skid plate (red) Valentine 1 radar detector hard wired, Damplifier Pro on the floor, back wall and doors, Luxury Liner Pro on the floor and doors, Kenwood DNX8120, 2 Pioneer TS-SW1041D 10" shallow mount subs, 2 Pioneer PRS-D4200F 1200W amps, Mr Marv sub enclosure, Hybrid Audio Clarus 6.5" components in the front doors, Alpine 5.25" coaxials in the rear doors, A.R.E. LSII fiberglass tonneau cover, All Pro bumper, All Pro sliders, Wet Okole seat covers, Sockmonkey Mountain badges, PIAA 510 SMR Driving Lights, Warn M8000 Winch, Bud Built skids
    I just traded my '06 for an '09 on Monday. I had a small alignment problem that they fixed and there is a small rattle/vibration coming from either behind the glovebox or the passenger door panel - can't tell (still hear it when the glovebox is empty). I also checked the leaf springs in the back and the part numbers indicate that they are eligible for the TSB T-SB-0305-08 replacement.

    Love my truck though!
     
  3. Oct 9, 2008 at 10:56 PM
    #3
    Okkine

    Okkine Well-Known Member

    Joined:
    Jun 26, 2008
    Member:
    #7590
    Messages:
    771
    Gender:
    Male
    Vancouver, BC
    Vehicle:
    2009 Magnetic Grey Access Cab - 2.7L I4 - 4x2
    My only problem is that it hasn't arrived yet.:D
     
  4. Oct 10, 2008 at 5:19 AM
    #4
    rc2125

    rc2125 Well-Known Member

    Joined:
    Sep 3, 2008
    Member:
    #8965
    Messages:
    69
    Gender:
    Male
    Indiana/Michigan border
    Vehicle:
    09 TRD
    Mine may have warped front rotors.......pretty violent vibration when braking at any speed........haven't had a good opportunity to take it to a dealer as of yet.
     
  5. Oct 10, 2008 at 5:31 AM
    #5
    hate2work

    hate2work Well-Known Member

    Joined:
    Sep 23, 2008
    Member:
    #9431
    Messages:
    185
    Washington State
    Vehicle:
    06 standard cab
    You might think about putting some better aftermarket rotors and pads on your truck. Many have gone to the SP Performance slotted rotors and Hawk pads. Not sure if they are available for an 09 yet though.

    Do a search and you'll find those threads :)
     
  6. Oct 10, 2008 at 6:35 AM
    #6
    TacoCo

    TacoCo Aspiring wrench monkey

    Joined:
    Aug 13, 2008
    Member:
    #8512
    Messages:
    913
    Gender:
    Male
    Colorado
    Vehicle:
    09 TRD Off-Road DC V6 Magnetic Gray
    Snugtop XV Shell, Yakima Rack, AFE Pro Dry Filter, Secondary Air Filter Removed, Michelin AT2's, Partially Debadged, HID conversion, Dynomax Super Turbo Muffler, Rear leaf spring TSB, Foglights always on Mod, URD Short Throw Shifter, Toytec Coilovers on the way!
    No problems with mine.
     
  7. Oct 10, 2008 at 7:09 AM
    #7
    Lithified

    Lithified Member

    Joined:
    Sep 24, 2008
    Member:
    #9450
    Messages:
    23
    Vancouver, BC
    Vehicle:
    09 4x2 Access Cab SR5
    side step bars
    no problems with mine, I love it. Only small issue is I find the radio reception to be poor at times.
     
  8. Oct 10, 2008 at 7:19 AM
    #8
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    the rattle could be the glovebox damper. Make sure it is snapped on.
     
  9. Oct 10, 2008 at 7:45 AM
    #9
    TacoCo

    TacoCo Aspiring wrench monkey

    Joined:
    Aug 13, 2008
    Member:
    #8512
    Messages:
    913
    Gender:
    Male
    Colorado
    Vehicle:
    09 TRD Off-Road DC V6 Magnetic Gray
    Snugtop XV Shell, Yakima Rack, AFE Pro Dry Filter, Secondary Air Filter Removed, Michelin AT2's, Partially Debadged, HID conversion, Dynomax Super Turbo Muffler, Rear leaf spring TSB, Foglights always on Mod, URD Short Throw Shifter, Toytec Coilovers on the way!
    Yeah, good luck with that... I just removed mine and threw it in the glove box. Pretty pointless if it won't stay on.
     
  10. Oct 10, 2008 at 7:48 AM
    #10
    Shark

    Shark Nobody's Hero

    Joined:
    Sep 25, 2008
    Member:
    #9460
    Messages:
    20
    Gender:
    Male
    N.E. Ohio
    Vehicle:
    2014 4x4, TRD Off-Road, Access Cab
    Had mine for 2 weeks, so far, so good!
     
  11. Oct 10, 2008 at 7:51 AM
    #11
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    mine stays. You could also try putting a screw through the pinch stub to expand it out to hold it tight after the damper is on it.

    it makes more sense in my head than in my words. Sorry.
     
  12. Oct 10, 2008 at 7:54 AM
    #12
    TacoCo

    TacoCo Aspiring wrench monkey

    Joined:
    Aug 13, 2008
    Member:
    #8512
    Messages:
    913
    Gender:
    Male
    Colorado
    Vehicle:
    09 TRD Off-Road DC V6 Magnetic Gray
    Snugtop XV Shell, Yakima Rack, AFE Pro Dry Filter, Secondary Air Filter Removed, Michelin AT2's, Partially Debadged, HID conversion, Dynomax Super Turbo Muffler, Rear leaf spring TSB, Foglights always on Mod, URD Short Throw Shifter, Toytec Coilovers on the way!
    :laugh:
    I know what you meant. I've seen the write up on it, but I'm not even sure I'd bother.
     
  13. Oct 10, 2008 at 8:00 AM
    #13
    fubar

    fubar Active Member

    Joined:
    Aug 27, 2008
    Member:
    #8812
    Messages:
    32

    +1 Radio is sometimes staticy in places where my 01 Cavalier never was.
     
  14. Oct 10, 2008 at 12:49 PM
    #14
    Impala1ss

    Impala1ss Member

    Joined:
    Sep 4, 2008
    Member:
    #9006
    Messages:
    23
  15. Oct 10, 2008 at 1:08 PM
    #15
    rc2125

    rc2125 Well-Known Member

    Joined:
    Sep 3, 2008
    Member:
    #8965
    Messages:
    69
    Gender:
    Male
    Indiana/Michigan border
    Vehicle:
    09 TRD

    One of the reasons I went back to a tacoma, was my last two went 168k and 90k with the original brake pads/rotors(still good when sold)........so I figured they were bullet proof.......and I get a brand new one with bad rotors already:cool:
     
  16. Oct 10, 2008 at 2:26 PM
    #16
    tdm156

    tdm156 Well-Known Member

    Joined:
    Apr 24, 2008
    Member:
    #6166
    Messages:
    590
    Gender:
    Male
    San Antonio, TX
    Vehicle:
    2009 DC 4x4 SR5**Sold
    I have a buzzing noise and a bad rattle from the dash on the passenger side when I go over cattle guards or wash boarded roads, I have problems with dirt coming in through the door handle on the front passenger side door so naturally I have a dirt problem all inside too! Thats the only problems so far and overall I am pleased with my Taco!
     
  17. Oct 10, 2008 at 7:59 PM
    #17
    weihenstephaner

    weihenstephaner Hooked

    Joined:
    Aug 20, 2008
    Member:
    #8644
    Messages:
    310
    Gender:
    Male
    Atlanta, GA
    Vehicle:
    2009 4x4 TRD OR DC SB Mag Grey
    Slee Slidersteps, 05-08 tails, Pioneer HU, XM through factory antenna, AFE Pro Dry S, mudflaps and TRD sticker delete, Weathertechs, bed extender
    No problems so far except a gouge in the composite bed, nearly all the way through the driver's wheel well. Haven't hauled anything except a gas grill. Guess a sharp edge must have hit just the right way or something.

    Oh well. At least it won't rust out! :D
     
  18. Oct 11, 2008 at 7:35 AM
    #18
    09silvertaco

    09silvertaco Well-Known Member

    Joined:
    Aug 17, 2008
    Member:
    #8586
    Messages:
    137
    Gender:
    Male
    Massachusetts
    Vehicle:
    2010 AC TRD Sport V6 6SPD
    bad radio reception and volume knob works sparatically...my duramax didnt rattle as much as the taco going over bumps either. but everything else is typical toyota. nothing i cant live with for the sake of reliability.
     
  19. Oct 11, 2008 at 7:51 AM
    #19
    Bonefish79

    Bonefish79 New Member

    Joined:
    Sep 24, 2008
    Member:
    #9438
    Messages:
    3
    Annapolis, MD
    Vehicle:
    09 Access Cab I4 SR5 Timberland Mica
    So far, so good, and 26 mpg from the last tank, mostly highway
     
  20. Oct 11, 2008 at 7:30 PM
    #20
    sch0enne

    sch0enne Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9550
    Messages:
    367
    Gender:
    Male
    penticton British Columbia Canada
    Vehicle:
    03 Tacoma TRD
    bed lights, cobra 19 dx cb radio, flow pro muffler

    I have that same rattle/vibration problem on that side, tried to figure it out but i had no luck. also i got a dealer installed ipod interface and i assume there was an incorrect installation because my stereo will shutt off without reason and sometimes when i get out of the vehichle it will stay on and i cannot turn the power off
     
To Top