1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

anyone know anything about kenwood radios?

Discussion in 'Technology' started by fireturk41, Jul 12, 2011.

  1. Jul 12, 2011 at 10:18 PM
    #1
    fireturk41

    fireturk41 [OP] I like to break shit!

    Joined:
    Dec 23, 2008
    Member:
    #11857
    Messages:
    4,805
    Gender:
    Male
    First Name:
    Kevin
    High Point, NC
    Vehicle:
    280k miles
    SAS, Locked front rear, Ufab sliders and bumpers, air compressor, 35" BFG KM2 on steelies and 36" TSLs
    i got a mobile kenwood tk-980, when powered up the display just says hardee...does this sound like a programming issue or and internal eff up type issue? if it is an internal eff up are they cheapish to fix? also anyone here in enc that can program it lol? I'm gonna let a buddy look at it but i dont know when im going to see him. any help is appreciated lol i only have 20 bucks into this thing
     
  2. Jul 13, 2011 at 10:24 AM
    #2
    fireturk41

    fireturk41 [OP] I like to break shit!

    Joined:
    Dec 23, 2008
    Member:
    #11857
    Messages:
    4,805
    Gender:
    Male
    First Name:
    Kevin
    High Point, NC
    Vehicle:
    280k miles
    SAS, Locked front rear, Ufab sliders and bumpers, air compressor, 35" BFG KM2 on steelies and 36" TSLs
  3. Jul 15, 2011 at 9:28 AM
    #3
    Chickenmunga

    Chickenmunga Nuggety

    Joined:
    Apr 10, 2008
    Member:
    #5877
    Messages:
    6,963
    Gender:
    Male
    First Name:
    Mike
    Hillsboro, Oregon
    Vehicle:
    08 TRD Offroad DC 4x4 (read the build)
    ask a mod to move this to the audio/video section
     
To Top