1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Anyone running 5100s set at 1.75 with stock rear suspension?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by bgsmith, Nov 25, 2011.

  1. Nov 25, 2011 at 7:36 PM

    bgsmith [OP] Well-Known Member

    Sep 19, 2011
    First Name:
    Hingham, MA
    06 Speedway Blue TRD Sport 4x4
    Pro Comp Series 52 Rock Crawlers, 265/70 17 Bridgestone Dueler ATs, Spidertrax 1.25" spacers (front and rear), Bilstein 5100 all around up front set at 1.75", Blacked out badges, Pioneer AVIC D3 DVD/NAV Head Unit, K&N Air Filter, Tyger Tri Fold Tonneau Cover.
    OK, I have a set of 5100s I am getting installed in the front. I want to get them set at 1.75 to fully avoid the cab mount rub I am experiencing when I have my wheel fully turned (very limited as to when I have rubbing issues). In measuring the rear vs. the front of my truck this should level it perfectly. Is anyone running this setup? I have searched couldn't find a definitive answer.

    I currently have a three leaf spring pack in the rear and will eventually add a leaf and 5100s in the rear, however my mod budget has been cut recently since I got into an accident and had to pay a deductible. I just want to make sure I won't be too high in the front as I am looking for a level stance for my truck.
To Top