1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

AR Trigger Won't Reset

Discussion in 'Guns & Hunting' started by Rivet Joint, May 27, 2011.

  1. May 27, 2011 at 11:04 AM
    #1
    Rivet Joint

    Rivet Joint [OP] Well-Known Member

    Joined:
    Aug 2, 2009
    Member:
    #20549
    Messages:
    114
    Gender:
    Male
    Albuquerque, NM
    Vehicle:
    2010 SWB DC Sport
    5100s @ .85, OME 885s, Rear TSB, Helo Max 6's, General AT2 Tires, Black Badges, Demello Offroad Bumper, Grillcraft, Sub/Amp, Pioneer DVD HU, TRD Intake & Exhaust.
    Hey,

    So I was at the range this morning and fired about 6 rds from my Bushmaster. Then the OEM trigger would not reset for some reason. The weapon still cyles rounds properly (when the trigger resets or by doing it manually). Weapon is cleaned/lubed after each range session and I'm very picky about that. I broke it down this morning and again it will only reset after working the action about 6 or so times...usually it will only reset when the bolt catch is locked and then released.

    I dont know what's up. Worst case scenario I need a new trigger group. I have ~800 rds through it.

    What say you?
     
  2. May 27, 2011 at 11:27 AM
    #2
    Zombie Runner

    Zombie Runner Are these black helicopters for me?

    Joined:
    Mar 13, 2008
    Member:
    #5246
    Messages:
    15,036
    Gender:
    Male
    First Name:
    Kevin
    Wichita Falls, TX
    Vehicle:
    Tundra, double cab.
    LED interior lights, stubby antenna, Pioneer in dash screen, good driver mod.
    Bushmaster :gossip:
     
  3. May 27, 2011 at 11:52 AM
    #3
    Rivet Joint

    Rivet Joint [OP] Well-Known Member

    Joined:
    Aug 2, 2009
    Member:
    #20549
    Messages:
    114
    Gender:
    Male
    Albuquerque, NM
    Vehicle:
    2010 SWB DC Sport
    5100s @ .85, OME 885s, Rear TSB, Helo Max 6's, General AT2 Tires, Black Badges, Demello Offroad Bumper, Grillcraft, Sub/Amp, Pioneer DVD HU, TRD Intake & Exhaust.
    awww...thanks Kevin! :rolleyes:
     
  4. May 27, 2011 at 3:32 PM
    #4
    Rivet Joint

    Rivet Joint [OP] Well-Known Member

    Joined:
    Aug 2, 2009
    Member:
    #20549
    Messages:
    114
    Gender:
    Male
    Albuquerque, NM
    Vehicle:
    2010 SWB DC Sport
    5100s @ .85, OME 885s, Rear TSB, Helo Max 6's, General AT2 Tires, Black Badges, Demello Offroad Bumper, Grillcraft, Sub/Amp, Pioneer DVD HU, TRD Intake & Exhaust.
    it's fixed...nevermind.
     
To Top