1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Attempting the bed light mod...

Discussion in 'Lighting' started by Experience_Life, Apr 26, 2010.

  1. Experience_Life

    Experience_Life [OP] Active Member

    Joined:
    Apr 24, 2010
    Member:
    #35885
    Messages:
    32
    Gender:
    Male
    Monroe, La
    Vehicle:
    '07 Black Prerunner Shortbed
    Maglite Mod, LED Dome Light Mod, Cubby Lock Mod
    Alright, i'm stuck. I enclosed every wire w/ wire loom & used zip ties, ran the wire through the grommet under the seat & along the sides of the truck back to the actual light wires in the bed. The connection from the switch inside the cab to the battery works (lights up when flipped on), but i'm having problems from the main power cable to each of the lights. When I turn the switch on & connect each wire, the lights don't turn on. My guess is a bad ground maybe? I'm an amateur @ this, but decided to give it a shot. Any advice would be helpful.

    And yes, I've looked @ the threads that talk about this lol!! :p
     
  2. dhurley

    dhurley Well-Known Member

    Joined:
    May 30, 2009
    Member:
    #17817
    Messages:
    1,005
    Gender:
    Male
    First Name:
    Doug
    Colorado Springs, CO
    Vehicle:
    04 Double Cab TRD SR5 V6
    TRD, Snugtop Super-Sport, bedliner, receiver hitch, alarm mod, deck plate mod, AFE Pro-Dry S, Saddleman camo seat covers, TW decal, grey wire mod w/switch, DRL, LED cupholder mod, Dynomax Super Turbo, aux back-up lights, Devil Horns by Andres, "blue plug" mod for 2LO, shorty antenna, Pro Comp fog & driving lights, receiver shackle, 15% tint front windows, stainless nerf bars, Ultra Gauge, diff breather mod
    Possibly the ground. Do you have fuses going to the lights? Maybe the lamps are bad. Just some ideas.
     
  3. Experience_Life

    Experience_Life [OP] Active Member

    Joined:
    Apr 24, 2010
    Member:
    #35885
    Messages:
    32
    Gender:
    Male
    Monroe, La
    Vehicle:
    '07 Black Prerunner Shortbed
    Maglite Mod, LED Dome Light Mod, Cubby Lock Mod
    I actually don't have fuses going to each light. If that's needed, that might be where the problem is. The only fuse I installed is attached to the hookup by the battery. I just bought the lights a few days back & started the install that same day.
     
  4. Manlaan

    Manlaan Well-Known Member

    Joined:
    Jan 25, 2010
    Member:
    #30054
    Messages:
    1,030
    Gender:
    Male
    First Name:
    Greg
    Riverton, Utah
    Vehicle:
    2002 XtraCab SR5 V6 4x4 Black
    See Signature
    Are you using a relay, or running the power through the switch? Some more details about how you have it wired up would also be helpful.
     
  5. Experience_Life

    Experience_Life [OP] Active Member

    Joined:
    Apr 24, 2010
    Member:
    #35885
    Messages:
    32
    Gender:
    Male
    Monroe, La
    Vehicle:
    '07 Black Prerunner Shortbed
    Maglite Mod, LED Dome Light Mod, Cubby Lock Mod
    Here are a few pics of how I have it wired. If this is wrong/different then please let me know as I went off of my opinion of how it should go....

    Starting @ the battery w/ fuse installed...

    [​IMG]



    Next is the grommet...

    [​IMG]



    Up through the cab...

    [​IMG]



    Continued (notice you can see where I grounded the switch on the side)

    [​IMG]



    Up to the switch (which is just used to test, getting another one)

    [​IMG]



    This is how I wired it from the grommet to the back of the truck & to the lights

    [​IMG]



    Any advice would be appreciated. I am an amateur @ all of this, so please be nice hahaha! Thank you all for your help! :D
     
  6. jefferson

    jefferson needs to stop cruising Buy/Sell/Trade....

    Joined:
    Jul 31, 2008
    Member:
    #8260
    Messages:
    5,325
    Gender:
    Male
    First Name:
    Sex Panther
    San Diego (North Park!), CA
    Vehicle:
    05 PreRunner SR5
    toyota brand hitch and uhaul wiring harness, fog lamps on anytime, bed lamps, map lights on with dome, day time running lamps, remove secondary air filter, painted bumper grill, Double Din touch screen stereo, Sockmonkey custom SR5 decal, door & seatbelt bells disabled, painted engine cover, installed compass/temperature overhead console, failed mod: passenger side auto down window switches, weathertech front mats, RedLine hood struts, Cheap Beep piezo buzzer locking beep, 5100s in the front set at 2.5, 5100s in the rear, AAL, hitch safe, revenge fab sliders, bed bar, prerunner light, cb wired
    my guess could be that the ground you used there isn't a real ground, or that the switch is wired incorrectly. When i've wired things in the cab, i havent been very lucky finding a ground. I ended up grounding the wire inside next to the shifter under the cupholder.

    (lemme know if you'd like me to snap some pics for ya)

    I'd check how the switch is wired and make sure the correct wires are goin to the correct areas. and maybe move that ground
     
  7. Experience_Life

    Experience_Life [OP] Active Member

    Joined:
    Apr 24, 2010
    Member:
    #35885
    Messages:
    32
    Gender:
    Male
    Monroe, La
    Vehicle:
    '07 Black Prerunner Shortbed
    Maglite Mod, LED Dome Light Mod, Cubby Lock Mod
    Jefferson....after scratching my head a thousand times yesterday & taking your advice to yet again do the same thing....i double checked it & it finally works. The ground I used under the dash is a good ground, I just had the wires hooked up wrong. Knew it had to be a stupid mistake. Ugh, amazing how you can miss things when you're "in the moment" haha! Thanks again for your help & i will post pics when I finish the installation.
     
  8. SManZ

    SManZ el tráfico más lento se queda derecha

    Joined:
    Sep 15, 2009
    Member:
    #22817
    Messages:
    1,339
    Gender:
    Male
    Centreville, VA
    Vehicle:
    '10 Supercharged 4x4 Sport 6-spd
    TRD Supercharger, King 2.5" extended travel remote-resi coilovers, OME Dakar leaf packs, King 2.5" extended travel rear shocks, Total Chaos UCAs, MBRP turndown exhaust, TRD intake, TRD Quickshifter, Goodridge SS brake lines, EBC Sport Rotors, Hawk HPS pads, TRD FJ Cruiser Special Edition 16" Anthracite Rims, Spidertrax wheel spacers, 265/75R16 A/T, Autometer oil pressure, oil temp gauges, TRD boost gauge, PLX DM-100 OBD II scanner, flexpod mounts, A-pillar gauge pods
    Nice job Experience!

    Is the electrical tape just a temporary install until you got the lights working? Curious because that probably won't stay on there long like that.

    Where did you run the wiring out of the cab and to the bed?
     
  9. MJonAgs32

    MJonAgs32 asphinctersayswhat?

    Joined:
    Apr 14, 2009
    Member:
    #15949
    Messages:
    9,141
    Gender:
    Male
    First Name:
    MJ
    Union City, CA (SF Bay Area)
    Vehicle:
    07 Mid-Travel 4x4 DCSB 6spd
    check out my build
    I've done this install as well. My only tip (its to late now) would have been to use black wire loom. I guess that just me being anal.

    Also, I just grounded to the frame. Look in your rear wheel wells and you'll see a bunch of stuff grounded to the frame.

    For reference, my cardomain has a half-ass write up to how I did it:
    http://www.cardomain.com/ride/2569025/5
     
  10. jefferson

    jefferson needs to stop cruising Buy/Sell/Trade....

    Joined:
    Jul 31, 2008
    Member:
    #8260
    Messages:
    5,325
    Gender:
    Male
    First Name:
    Sex Panther
    San Diego (North Park!), CA
    Vehicle:
    05 PreRunner SR5
    toyota brand hitch and uhaul wiring harness, fog lamps on anytime, bed lamps, map lights on with dome, day time running lamps, remove secondary air filter, painted bumper grill, Double Din touch screen stereo, Sockmonkey custom SR5 decal, door & seatbelt bells disabled, painted engine cover, installed compass/temperature overhead console, failed mod: passenger side auto down window switches, weathertech front mats, RedLine hood struts, Cheap Beep piezo buzzer locking beep, 5100s in the front set at 2.5, 5100s in the rear, AAL, hitch safe, revenge fab sliders, bed bar, prerunner light, cb wired
    ah great job! Wiring is easy if you take your time and think logically how power flows through. Glad you figured it out! :D
     
  11. Experience_Life

    Experience_Life [OP] Active Member

    Joined:
    Apr 24, 2010
    Member:
    #35885
    Messages:
    32
    Gender:
    Male
    Monroe, La
    Vehicle:
    '07 Black Prerunner Shortbed
    Maglite Mod, LED Dome Light Mod, Cubby Lock Mod
    Yeah, that was just to keep the wire out of the way & to make sure I was running it right. I'm fixing it later. Just about done! About the wire loom, I totally agree with you on that. I was in a hurry & no shops in town had anymore black wire loom. I hid & secured the wires pretty well though, so they shouldn't pop out where I would look like white trash driving a Taco hahah!
     
  12. Experience_Life

    Experience_Life [OP] Active Member

    Joined:
    Apr 24, 2010
    Member:
    #35885
    Messages:
    32
    Gender:
    Male
    Monroe, La
    Vehicle:
    '07 Black Prerunner Shortbed
    Maglite Mod, LED Dome Light Mod, Cubby Lock Mod
    Finally done!! Thanks for the help guys!!

    [​IMG]


    [​IMG]


    [​IMG]


    [​IMG]


    [​IMG]


    [​IMG]


    [​IMG]
     
  13. jefferson

    jefferson needs to stop cruising Buy/Sell/Trade....

    Joined:
    Jul 31, 2008
    Member:
    #8260
    Messages:
    5,325
    Gender:
    Male
    First Name:
    Sex Panther
    San Diego (North Park!), CA
    Vehicle:
    05 PreRunner SR5
    toyota brand hitch and uhaul wiring harness, fog lamps on anytime, bed lamps, map lights on with dome, day time running lamps, remove secondary air filter, painted bumper grill, Double Din touch screen stereo, Sockmonkey custom SR5 decal, door & seatbelt bells disabled, painted engine cover, installed compass/temperature overhead console, failed mod: passenger side auto down window switches, weathertech front mats, RedLine hood struts, Cheap Beep piezo buzzer locking beep, 5100s in the front set at 2.5, 5100s in the rear, AAL, hitch safe, revenge fab sliders, bed bar, prerunner light, cb wired
    very awesome. I love mine - i use them when surfing mostly (we go till it gets really late.. by the time we're loading the truck its DARK so we switch the lights on and it helps a TON)
     
  14. Veccster

    Veccster bass turds

    Joined:
    Aug 8, 2008
    Member:
    #8407
    Messages:
    2,090
    Gender:
    Male
    First Name:
    Eric
    Pittsburgh - The City of Champions
    Vehicle:
    2009 DC V6 TRDsport
    5100's all around - fronts at 1.75", 265/70/17 Bridgestone Revo 2, HID headlights and fog lights, factory skid plate, ss exhaust tip, tube steps, Access roll-up tonneau cover, Redline hood struts, 6 D-rings, seat MagLite, LED dome, fumoto oil drain, DTRL, fog light anytime, Kenwood/Clarion speakers, Pop-N-Lock 5300, LED bed lights and a few other things...
    Great job! I love my bed lights. I used LED strips that are tucked under the cleat rails and not really noticeable. I also put a switch in the bed and in the cab. Took a bit more wiring but I can turn it on in the cab then off in the bed (or vice versa). Pretty cool.

    Anyway, I was going to recommend that you check the fuse. Mine was blown and I started ripping everything apart looking for the problem. Should've checked that first!
     
  15. Experience_Life

    Experience_Life [OP] Active Member

    Joined:
    Apr 24, 2010
    Member:
    #35885
    Messages:
    32
    Gender:
    Male
    Monroe, La
    Vehicle:
    '07 Black Prerunner Shortbed
    Maglite Mod, LED Dome Light Mod, Cubby Lock Mod
    Decided to keep the stock fittings, so I just took an exacto knife to it & cut out a slot for the mini rocker switch I picked up @ O'Reilly's :D

    [​IMG]

    [​IMG]

    [​IMG]
     
  16. SCFirefighter

    SCFirefighter on idiot patrol ;)

    Joined:
    Apr 20, 2010
    Member:
    #35670
    Messages:
    1,607
    Gender:
    Male
    First Name:
    Stephan
    Cary, NC
    Vehicle:
    Silver 2010 DC TRD Sport 4x4 5'
    K&N Air Intake, MagnaFlow Performance Exhaust, ScanGauge II, Map, dome and license plate LED's, Custom Fire/Rescue decals, Weathertech deflectors, Removed mud flaps, Rear spring TSB, Spidertrax spacers, Tinted windows (5%/27%), Black Tacoma badges, 5100 Billstein x4, ToyTec Coilovers, ToyTec TSB AAL, Devil horns, Hose clamp tailgate mod, OEM bed mat, HomeLink module, Hardwire GPS, Weathertech digital fit floor lines, Front Diff drop, Rear Diff breather mod, 4xInnovation welded sliders.
    Eric, can you share what strip you used? I wanted to do the exact thing, use LED's, and a double switch setup.
    Thanks!
     
  17. SampleFool

    SampleFool Three Percenter

    Joined:
    Jul 4, 2009
    Member:
    #19264
    Messages:
    2,245
    Gender:
    Male
    First Name:
    Steve
    Ga
    Vehicle:
    Silver
    08 off-road
    Looks good man doing mine very soon to, I can say find a better place to zip the wire loom up to before it falls and wrecks all your hard work.
     
To Top