1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

bad day for me and my truck

Discussion in '1st Gen. Tacomas (1995-2004)' started by bigdaddytaco, Jul 30, 2011.

  1. Jul 30, 2011 at 8:35 PM
    #1
    bigdaddytaco

    bigdaddytaco [OP] Well-Known Member

    Joined:
    Feb 6, 2011
    Member:
    #50644
    Messages:
    233
    Gender:
    Male
    First Name:
    jared
    sylva nc
    Vehicle:
    2000 tacoma
    ARB bumper 3 inch oldman emu lift piaa fog lights
    was having some trouble with my breaks last week so took it to my perferd shop friday morning.He gave me the call that after noon sad it was ready went to the shop he said the two back axel seals were bad and were leaking causing them to coat the back breaks.After shucking out $400.00 bucks to the man thought every thing was good,well that night i noticed the E break light was on and would not go off didnt think much about it just thought i would take it to the shop monday.Then today taking the girl thru town coming down a hill to a red light went to apply the brakes, the pedel went stright to the floor with out fasing the truck!!By the grace of god was able to make it to the turning lane and kept going with no stops.Was able to put it in low and use what E break i had to get to the shop and parked in in front of the gate locked her up and had a friend come get me..I lucked out on this one was able to make it safe and not hurt anyone or my self
     
  2. Jul 30, 2011 at 8:38 PM
    #2
    MTgirl

    MTgirl too many frogs, not enough princes... Moderator

    Joined:
    Sep 29, 2009
    Member:
    #23531
    Messages:
    58,268
    Gender:
    Female
    First Name:
    Weesa
    in the forest
    Vehicle:
    Now: 12 T4R SR5 Then: 99 - 3.4L SR5 4WD
    Wheeler's/Alcan 5-pack leaf springs, Bilstein 5100's front and rear, OME 881's, de-badged, Jungle Fender Flares, Herculined bed, HomerTaco grille, Anzo headlights, clear corners, CVT Mt. Bachelor RTT, custom bed rack & CBI sliders
    did they forget to bleed the brake lines once they finished up the work? :notsure:

    regardless...might be time to find a new, more reliable shop or learn to do the work yourself! glad you were able to keep things under control.
     
  3. Jul 30, 2011 at 8:43 PM
    #3
    fireturk41

    fireturk41 I like to break shit!

    Joined:
    Dec 23, 2008
    Member:
    #11857
    Messages:
    4,804
    Gender:
    Male
    First Name:
    Kevin
    High Point, NC
    Vehicle:
    280k miles
    SAS, Locked front rear, Ufab sliders and bumpers, air compressor, 35" BFG KM2 on steelies and 36" TSLs
    make sure you dont have brake fluid leaking out the sides, it may be a bad wheel cylander
     
  4. Jul 30, 2011 at 8:57 PM
    #4
    tacoma04

    tacoma04 Laissez les bons temps rouler

    Joined:
    Mar 9, 2011
    Member:
    #52717
    Messages:
    499
    Gender:
    Male
    First Name:
    Bruce
    Northern Louisiana
    Vehicle:
    2007 DCSB SR5 4X4
    Man, just glad you and others on the road are ok! Good job handling the situation.
     
To Top