1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Bad Install and My Engine Overheated

Discussion in '2nd Gen. Tacomas (2005-2015)' started by dbiland, Jun 3, 2010.

  1. Jun 3, 2010 at 10:37 PM
    #1
    dbiland

    dbiland [OP] Member

    Joined:
    Feb 22, 2010
    Member:
    #31925
    Messages:
    21
    Gender:
    Male
    Northern Cal
    Vehicle:
    07 TRD Off Road
    TRD: CAI, CAT Back, Doug Thorley Longtubes, URD: Y-Pipe, MAF CAL, SS. APR T-Stat(uninstalled) Bilstein 5100(4) eibach toytec coilover. Rear suspension TSB.
    I was stranded on a back road in Zenia, CA a few nights ago. AAA couldn't respond until noon and I broke down at 3am. The person that installed my APR low temp thermostat didn't rotate the lower radiator hose out of the way of the fan???At least that's the opinion of the people that did the fix. The hose was cut and spewed pink everywhere. What an effing mess. My scangauge showed my temps climbing wildly so I had to pull over and turn the engine off. My max temp reached was 252 deg F. My cel never went on, and my temp needle was quarter inch shy of the red H. I am so disappointed in the installer who also happens to be my neighbor down the street.

    I had the hose replaced by my regular guys at South County Automotive. I had to settle for a Napa Hose but at least i'm running toyota coolant thru the system. Everything seems fine, but I know the damage has been done to some degree. I really have bad luck with dealerships and independent guys. Im the guy who had a dealership mechanic redline his truck. My scangauge busted the punk. AHHHHH!!!:mad:
     
  2. Jun 3, 2010 at 10:40 PM
    #2
    ktmrider

    ktmrider Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    4,969
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    That sucks, I was always worried about this happening so when Installing my SC I zip tied all the hoses near the belts or the fan to something secure
     
  3. Jun 3, 2010 at 10:44 PM
    #3
    06BLUEDBLSPORT

    06BLUEDBLSPORT Well-Known Member

    Joined:
    Apr 22, 2008
    Member:
    #6140
    Messages:
    4,070
    Gender:
    Male
    First Name:
    Colin
    Lubbock Texas
    Vehicle:
    12 Tundra DC SR5 4x4 5.7L
    True Dual Flowmaster 40 Series exhaust, Volant CAI, HIDs, Raptor series Side Steps, Weathertech Floorliners, OME 613 Shocks and Coils with Diff Drop, Rear Bilstein 5100 Shocks, ToyTec AAL, Fearless Fabrication Front Bumper
    Because of the OP im now afraid to take my truck to the dealsrship cause I have an exhaust and cai and don't someone to redline my truck. Sorry for your bad situation, shit happens I guess, I hope you don't have any more troubles
     
To Top