1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Bad paint finish!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by CanTac, Aug 5, 2009.

  1. Aug 5, 2009 at 4:32 PM
    #1
    CanTac

    CanTac [OP] Well-Known Member

    Joined:
    Jul 9, 2008
    Member:
    #7833
    Messages:
    51
    Gender:
    Male
    Peterborough On./Ocala Fl.
    Vehicle:
    09 TRD Sport 4X4 D/Cab Long Box
    I have a 2009 DC TRD, white. Was washing it today and noticed quite a few little rust marks. Anyone else have this problem and what might it be caused from?

    CanTac

    Hal
     
  2. Aug 5, 2009 at 4:38 PM
    #2
    Caddmannq

    Caddmannq MotoNerd

    Joined:
    Sep 1, 2008
    Member:
    #8917
    Messages:
    496
    Gender:
    Male
    California
    Vehicle:
    2012 PreRunner TRD Sport DC LB
    Undercover toneau
    Where was yours built? I have the same model (except 4x2) and it's white, built in Mexico. It has been 11 months since I bought it and no rust at all.

    Then again, things don't rust apart here quite like they do in Florida.
     
  3. Aug 5, 2009 at 4:42 PM
    #3
    fishshooter

    fishshooter Well-Known Member

    Joined:
    Feb 13, 2009
    Member:
    #13586
    Messages:
    317
    Gender:
    Male
    Northwest Florida
    Vehicle:
    09 Super White TRD Off Road 4X4
    Stock
    Is the rust where the paint has chipped?
     
  4. Aug 5, 2009 at 4:50 PM
    #4
    Incognito

    Incognito μολὼν λαβέ

    Joined:
    May 25, 2009
    Member:
    #17626
    Messages:
    13,643
    Gender:
    Male
    First Name:
    Colton
    VA
    Vehicle:
    2012 Pyrite AC TRD OR
    See Build thread
    Most likely, because the water gets in there and just goes to work on the rusting.
     
  5. Aug 5, 2009 at 4:58 PM
    #5
    PSUnick

    PSUnick Lets Go State!

    Joined:
    May 23, 2009
    Member:
    #17556
    Messages:
    170
    Gender:
    Male
    MA
    Vehicle:
    2007 AC 4x4 Sport
    Typically this is caused by rail dust. It gets embedded into the clear during shipping.
     
  6. Aug 5, 2009 at 5:05 PM
    #6
    Plain Jane Taco

    Plain Jane Taco I have small lugnuts because I drive a Prerunner

    Joined:
    Apr 19, 2009
    Member:
    #16179
    Messages:
    5,522
    Gender:
    Male
    First Name:
    Bill
    USA
    Vehicle:
    2015 DCSB TRD Sport PR
    This is exactly what it is. Your truck is not rusting. Try a good cleaner wax to remove it.
     
  7. Aug 5, 2009 at 5:06 PM
    #7
    fishshooter

    fishshooter Well-Known Member

    Joined:
    Feb 13, 2009
    Member:
    #13586
    Messages:
    317
    Gender:
    Male
    Northwest Florida
    Vehicle:
    09 Super White TRD Off Road 4X4
    Stock
    Yeah, it will rust pretty quick if the paint is chipped, but I was wondering if the rust was a result or a cause of the blemishes. Is it rusting under or on the paint, or where the paint has been compromised?
     
  8. Aug 5, 2009 at 8:16 PM
    #8
    JKD

    JKD Well-Known Member

    Joined:
    Jun 9, 2009
    Member:
    #18207
    Messages:
    2,016
    Gender:
    Male
    Would clay bar work to remove that sort of embedded dust?
     
  9. Aug 5, 2009 at 8:17 PM
    #9
    beastlytaco

    beastlytaco Well-Known Member

    Joined:
    Jun 30, 2008
    Member:
    #7660
    Messages:
    4,042
    Gender:
    Male
    First Name:
    Ian
    Vehicle:
    08 Access Cab SR5
    it wouldnt hurt to try. since clay removes alot of top coat oxidation.
     
  10. Aug 5, 2009 at 8:17 PM
    #10
    DanGer

    DanGer Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,491
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    I noticed when I was waxing the same issue. It is only on the passenger side rear fender
     
  11. Aug 5, 2009 at 8:41 PM
    #11
    WilsonTheDog

    WilsonTheDog Kylie's dad

    Joined:
    Nov 17, 2007
    Member:
    #3496
    Messages:
    4,837
    Gender:
    Male
    First Name:
    Eric
    Myrtle Beach SC
    Vehicle:
    07 Prerunner SR5 DC/SB V6
    Magnaflow 12576 muffler & chrome tip, Westin step bars, 27% tint, Pop N Lock, AFE ProdryS, bed mat, Husky liners, D-rings added, Access Literider tonneau, Pioneer 4-ways all around, GY Wrangler Duratracs 265/75/16, 5100's @ 1.75", 1.5" AAL
    Yes.
     
  12. Aug 6, 2009 at 2:17 AM
    #12
    CanTac

    CanTac [OP] Well-Known Member

    Joined:
    Jul 9, 2008
    Member:
    #7833
    Messages:
    51
    Gender:
    Male
    Peterborough On./Ocala Fl.
    Vehicle:
    09 TRD Sport 4X4 D/Cab Long Box
    Mine too seems to be on the passenger rear 1/4 panel. It is not where it has chipped. It seems to be on the surface in numerous places.
     
  13. Aug 6, 2009 at 4:15 AM
    #13
    Endurozw

    Endurozw War Damn Eagle!

    Joined:
    May 12, 2009
    Member:
    #17122
    Messages:
    216
    Gender:
    Male
    First Name:
    Zach
    Birmingham, Alabama
    Vehicle:
    09 PreRunner DC SR5 w/ tow package
    Fold-a-cover G4 - Wranger Duratrac 265/75/16 Audio Upgrades: Pioneer AVH-P4200DVD / JL Audio HD600/4 amp / Hybrid Audio 6.5 Clarus up front / Arc Audio 10 in subwoofer
    Yeah when I bought my truck I had three spots that I am assuming were from this....I asked them to take it back and remove those spots to make sure it wasn't rust before I bought it.
     
To Top