1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

bad speed signal to ecu?

Discussion in '1st Gen. Tacomas (1995-2004)' started by Stout890, May 28, 2011.

  1. May 28, 2011 at 6:03 PM
    #1
    Stout890

    Stout890 [OP] Well-Known Member

    Joined:
    May 8, 2011
    Member:
    #56287
    Messages:
    511
    Gender:
    Male
    First Name:
    Jason
    Rosamond ca
    Vehicle:
    99 prerunner sr5
    HID head lights, fagtech coil overs and an AAL, gay ass 2 inch body lift (soon to be removed) taneau cover, k&n intake, soon to have an axle swap with a E locker
    well my truck is a 99 preruner ext cab with the e-3rz in it and an automatic transmission. it has a body lift of about 2-2.5 inches with 31x10.5 tires on it.

    my issue is that my speedometer is off by +20 mph. and the truck can not keep up on the freeway with other cars. it has to be literally floored to just enter the freeway at a safe enough speed. and up here in the av with 70mph speed limits on the freeway my car tops out at 80 due to the governor. and if you know this valley the constant 30mph winds on the freeway makes it even worse to maintain that speed in this truck


    it feels to me as if the tranny does not hold the gears long enough it will shift too soon (right at 3k)and the next gear up will require me to floor it just to maintain an acceleration than as it picks up speed it will shift again causing me to again, press the pedal to the floor. than once i'm up to 70 it cruses at 3/4 throttle.

    the throttle response at at cruising speed is horrible i can rock the gas pedal hearing the engine only slightly rev and i get nothing.

    i use the o.d button to pass cars or sometime to get on the freeway if i don't want to floor it.

    i do not know exactly why the spedo is off. i need to hook up a code reader i believe and see if its putting out a correct speed to see if its actually the speed signal or the cluster.

    and if it is a bad speed signal would it be the reason for my poor preformance issue or is that actually how a 4 banger taco drives on 31's with a body lift?

    thanks in advance for all your help
     
  2. May 28, 2011 at 6:24 PM
    #2
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    have you by chance checked the butterfly in the throttle body to see how far its opening? kinda sounds like it may not be opening all the way. get someone to push the gas pedal in while you look at it.
     
  3. May 28, 2011 at 6:30 PM
    #3
    Stout890

    Stout890 [OP] Well-Known Member

    Joined:
    May 8, 2011
    Member:
    #56287
    Messages:
    511
    Gender:
    Male
    First Name:
    Jason
    Rosamond ca
    Vehicle:
    99 prerunner sr5
    HID head lights, fagtech coil overs and an AAL, gay ass 2 inch body lift (soon to be removed) taneau cover, k&n intake, soon to have an axle swap with a E locker
    nope i haven't even thought of checking that. i will get my hanes out and see if i cant get to it and see. how much should it be opening than?
     
  4. May 28, 2011 at 9:15 PM
    #4
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    Under wot....butterfly should be 3/4 to fully open I believe. If its not....need to clean the tb and adjust the cable.
     
  5. May 28, 2011 at 10:00 PM
    #5
    Stout890

    Stout890 [OP] Well-Known Member

    Joined:
    May 8, 2011
    Member:
    #56287
    Messages:
    511
    Gender:
    Male
    First Name:
    Jason
    Rosamond ca
    Vehicle:
    99 prerunner sr5
    HID head lights, fagtech coil overs and an AAL, gay ass 2 inch body lift (soon to be removed) taneau cover, k&n intake, soon to have an axle swap with a E locker
    i was imagining checking this with the engine running but i just realized i should probably just do it with it off. would that be sufficient?
     
  6. May 28, 2011 at 10:01 PM
    #6
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    Yeah........don't see a problem checking it not running.
     
  7. May 28, 2011 at 10:13 PM
    #7
    Stout890

    Stout890 [OP] Well-Known Member

    Joined:
    May 8, 2011
    Member:
    #56287
    Messages:
    511
    Gender:
    Male
    First Name:
    Jason
    Rosamond ca
    Vehicle:
    99 prerunner sr5
    HID head lights, fagtech coil overs and an AAL, gay ass 2 inch body lift (soon to be removed) taneau cover, k&n intake, soon to have an axle swap with a E locker
    ill check this in the morning but i have to say i am really skeptical on this because of the fact that my engine is screaming still when im trying to accelerate it feels to like its all in the shifting. but iv been wrong plenty of times before lol
     
  8. May 28, 2011 at 10:14 PM
    #8
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    Quite a few things it could be man. Is there any cel at all coming on?
     
  9. May 28, 2011 at 10:21 PM
    #9
    Stout890

    Stout890 [OP] Well-Known Member

    Joined:
    May 8, 2011
    Member:
    #56287
    Messages:
    511
    Gender:
    Male
    First Name:
    Jason
    Rosamond ca
    Vehicle:
    99 prerunner sr5
    HID head lights, fagtech coil overs and an AAL, gay ass 2 inch body lift (soon to be removed) taneau cover, k&n intake, soon to have an axle swap with a E locker
    cel? what do you mean?
     
  10. May 28, 2011 at 10:31 PM
    #10
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    Check engine light
     
  11. May 28, 2011 at 11:06 PM
    #11
    Stout890

    Stout890 [OP] Well-Known Member

    Joined:
    May 8, 2011
    Member:
    #56287
    Messages:
    511
    Gender:
    Male
    First Name:
    Jason
    Rosamond ca
    Vehicle:
    99 prerunner sr5
    HID head lights, fagtech coil overs and an AAL, gay ass 2 inch body lift (soon to be removed) taneau cover, k&n intake, soon to have an axle swap with a E locker
    oh my bad, nope no check engine light
     
To Top