1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Bad Vibration and squeak in drive

Discussion in 'Technical Chat' started by TacoBoss05, Aug 17, 2010.

  1. Aug 17, 2010 at 6:05 AM
    #1
    TacoBoss05

    TacoBoss05 [OP] Well-Known Member

    Joined:
    Dec 3, 2009
    Member:
    #26978
    Messages:
    46
    Gender:
    Male
    First Name:
    Julio
    Fayetteville,GA
    Vehicle:
    PreRunner SR5 Six speed
    Ipod converter on stock head unit, detachable fiberglass bedcover
    My dad has a 06 prerunner and every time he puts it in drive it the truck starts to vibrate and squeak, it does not happen when its in neutral and rolling. What could be the issue?
     
  2. Aug 17, 2010 at 9:43 AM
    #2
    Bama_TACO

    Bama_TACO ROLL TIDE!!!!!!!

    Joined:
    Aug 3, 2010
    Member:
    #41157
    Messages:
    1,020
    Gender:
    Male
    Winfield, AL
    Vehicle:
    2006 PreRunner Double Cab TRD SPORT
    Check the U-Joints. There was a post on here where a guy took his truck to the dealership with a similar problem as yours and they told him he needed a new transmission and it was going to be $4000 to replace it. He took it to an independent transmission shop and it turned out to be a $24 u-joint that had gone bad.
     
  3. Aug 17, 2010 at 9:47 AM
    #3
    Zombie Runner

    Zombie Runner Are these black helicopters for me?

    Joined:
    Mar 13, 2008
    Member:
    #5246
    Messages:
    15,111
    Gender:
    Male
    First Name:
    Kevin
    Wichita Falls, TX
    Vehicle:
    Tundra, double cab.
    LED interior lights, stubby antenna, Pioneer in dash screen
    I just had my rear U joint replaced. total cost 500 bucks...good thing im still under warranty. it was making a weird squeaking noise and would increase as my speed would increase.
     
  4. Aug 18, 2010 at 3:16 PM
    #4
    TacoBoss05

    TacoBoss05 [OP] Well-Known Member

    Joined:
    Dec 3, 2009
    Member:
    #26978
    Messages:
    46
    Gender:
    Male
    First Name:
    Julio
    Fayetteville,GA
    Vehicle:
    PreRunner SR5 Six speed
    Ipod converter on stock head unit, detachable fiberglass bedcover
    thanks guys, before I could read your replies, i took my automotive college instructor for a ride and he told me to check the u-joints, went into the shop took me about an hour to change and reinstall everything, and only cost like 25 dollars just for parts, saved my dad big money doing it my self. I still thank you guys for replying anyways.
     
  5. Aug 19, 2010 at 5:52 AM
    #5
    Zombie Runner

    Zombie Runner Are these black helicopters for me?

    Joined:
    Mar 13, 2008
    Member:
    #5246
    Messages:
    15,111
    Gender:
    Male
    First Name:
    Kevin
    Wichita Falls, TX
    Vehicle:
    Tundra, double cab.
    LED interior lights, stubby antenna, Pioneer in dash screen
    Glad you got it fixed :thumbsup:
     
To Top