1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

battery light flickers, but new alternator a week ago

Discussion in '2nd Gen. Tacomas (2005-2015)' started by wrxRome, Nov 21, 2011.

  1. Nov 21, 2011 at 12:13 PM
    #1
    wrxRome

    wrxRome [OP] Houston's Swamp Rat

    Joined:
    Aug 25, 2011
    Member:
    #62338
    Messages:
    5,880
    Gender:
    Male
    First Name:
    Brandon
    Covington, LA/Friendswood,TX
    Vehicle:
    06 SWB 4x4 trd off road
    so i was driving home from new orleans today when almost the whole way back my battery light was flickering randomly, it wouldnt stay lit or flash but completely random flicker, then sometimes go off and come back, i just had the alternator and battery replaced last week and no problems since then (here is the story for that one, http://www.tacomaworld.com/forum/2nd-gen-tacomas/187526-electrial-problems-need-help.html )

    i read all the battery light threads i could and still am confused as what it could be,
     
  2. Nov 21, 2011 at 12:18 PM
    #2
    Leggo

    Leggo slow is smooth, and smooth is fast.

    Joined:
    Dec 16, 2010
    Member:
    #47805
    Messages:
    2,420
    Gender:
    Male
    First Name:
    Steve
    Newton,Ma.
    Vehicle:
    10 TRD Sport AC 4x4 MGM
    Kenwood HU,Infinity Kappa speakers (x4), Infinity reference tweeters(x2),10" Kicker sub, Box by Subthump, Infinty Five channel amp,DVD anytime bypass, DTRL Mod, Xtang trifecta, Fogs anytime Mod, Bed Mat,Westin running boards, Console vault, Maglite mod, Weathertechs,Autopage remote starter, Power tailgate lock, HID Bi Zenon, Hella Supertones,Rain guards,Rear leaf TSB,Steering shaft TSB, Fisher Homesteader plow, 886 reverse lights mod, Redline Hood struts, Hankook Dynapro ATM LT265/70R17, power sliding rear window, Auto dimming/on anytime Bed lights, Blue Sea fuse panel & 100amp Breaker, de- badged,Rear headrest's removed, imMrYo mirror relocation,Homeroshi grill
    the history suggests a short somewhere.
     
  3. Nov 21, 2011 at 12:21 PM
    #3
    wrxRome

    wrxRome [OP] Houston's Swamp Rat

    Joined:
    Aug 25, 2011
    Member:
    #62338
    Messages:
    5,880
    Gender:
    Male
    First Name:
    Brandon
    Covington, LA/Friendswood,TX
    Vehicle:
    06 SWB 4x4 trd off road
    thats what i was thinking but everything is back to stock wiring from the fog light ordeal. so im stuck.
     
  4. Nov 21, 2011 at 12:55 PM
    #4
    2010Tacoma4x4

    2010Tacoma4x4 "Man Ho"

    Joined:
    Jan 19, 2011
    Member:
    #49556
    Messages:
    644
    Gender:
    Male
    First Name:
    Dave
    Jacksonville, Fl
    Vehicle:
    2010 4x4 SR5
    Tinted windows, Bug deflector, Rain guards, Bed mat, Rear leaf TSB, Bilsteins front & rear (front set @ 1.75), 16x8 chrome Helo wheels, Toyo open country AT P265/75/R16 tires. CBI bolt on sliders. BSP color matched M1 Satoshi grill. BHLM. UWS low profile black powder coat crosover truckbox. Pioneer DVD/CD head unit - 4 channel amp - front mids & highs - 8" sub box.
    I would check for a loose (or corroded) ground somewhere. Starting from the battery making sure the terminals are clean and work your way throughout the vehicle.
     
  5. Nov 21, 2011 at 1:25 PM
    #5
    wrxRome

    wrxRome [OP] Houston's Swamp Rat

    Joined:
    Aug 25, 2011
    Member:
    #62338
    Messages:
    5,880
    Gender:
    Male
    First Name:
    Brandon
    Covington, LA/Friendswood,TX
    Vehicle:
    06 SWB 4x4 trd off road
    will do. i already looked everywhere in the engine compartment though.
     
  6. Nov 21, 2011 at 2:15 PM
    #6
    Leggo

    Leggo slow is smooth, and smooth is fast.

    Joined:
    Dec 16, 2010
    Member:
    #47805
    Messages:
    2,420
    Gender:
    Male
    First Name:
    Steve
    Newton,Ma.
    Vehicle:
    10 TRD Sport AC 4x4 MGM
    Kenwood HU,Infinity Kappa speakers (x4), Infinity reference tweeters(x2),10" Kicker sub, Box by Subthump, Infinty Five channel amp,DVD anytime bypass, DTRL Mod, Xtang trifecta, Fogs anytime Mod, Bed Mat,Westin running boards, Console vault, Maglite mod, Weathertechs,Autopage remote starter, Power tailgate lock, HID Bi Zenon, Hella Supertones,Rain guards,Rear leaf TSB,Steering shaft TSB, Fisher Homesteader plow, 886 reverse lights mod, Redline Hood struts, Hankook Dynapro ATM LT265/70R17, power sliding rear window, Auto dimming/on anytime Bed lights, Blue Sea fuse panel & 100amp Breaker, de- badged,Rear headrest's removed, imMrYo mirror relocation,Homeroshi grill
    disconnect the neg. side of the Batt. and put a test light between the cable and the - battery terminal. If it lights up, you have something drawing voltage. ( something left on OR a short circuit somewhere.) I never seen a bad ground cause a voltage draw or cause a Battery to run down sitting around..
     
  7. Nov 21, 2011 at 4:22 PM
    #7
    2010Tacoma4x4

    2010Tacoma4x4 "Man Ho"

    Joined:
    Jan 19, 2011
    Member:
    #49556
    Messages:
    644
    Gender:
    Male
    First Name:
    Dave
    Jacksonville, Fl
    Vehicle:
    2010 4x4 SR5
    Tinted windows, Bug deflector, Rain guards, Bed mat, Rear leaf TSB, Bilsteins front & rear (front set @ 1.75), 16x8 chrome Helo wheels, Toyo open country AT P265/75/R16 tires. CBI bolt on sliders. BSP color matched M1 Satoshi grill. BHLM. UWS low profile black powder coat crosover truckbox. Pioneer DVD/CD head unit - 4 channel amp - front mids & highs - 8" sub box.
    I thought the voltage draw problem has been corrected and now it was only the battery light flickering.
    Yes if your still having problems with the battery going dead then it would more than likely be something else other than a loose ground.
     
  8. Nov 21, 2011 at 4:38 PM
    #8
    2010Tacoma4x4

    2010Tacoma4x4 "Man Ho"

    Joined:
    Jan 19, 2011
    Member:
    #49556
    Messages:
    644
    Gender:
    Male
    First Name:
    Dave
    Jacksonville, Fl
    Vehicle:
    2010 4x4 SR5
    Tinted windows, Bug deflector, Rain guards, Bed mat, Rear leaf TSB, Bilsteins front & rear (front set @ 1.75), 16x8 chrome Helo wheels, Toyo open country AT P265/75/R16 tires. CBI bolt on sliders. BSP color matched M1 Satoshi grill. BHLM. UWS low profile black powder coat crosover truckbox. Pioneer DVD/CD head unit - 4 channel amp - front mids & highs - 8" sub box.
    To elaborate on what Steve recommends to determine if you have a parasidic battery drain...make sure you have the ignition turned off and the doors closed when using the test light method ;)
     
  9. Nov 21, 2011 at 5:06 PM
    #9
    joes06tacoma

    joes06tacoma Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28588
    Messages:
    3,056
    Gender:
    Male
    First Name:
    Joe
    Central Coast, CA
    Vehicle:
    06 4x4 Off Road Access Cab v6 6spd
    LEER Shell with dome lights operated with 3 way switches, aux backup lights with relay and 3 position switch, modified wiring to compass/temp display and clock to include switch that disables dimming function (poor man's DRL solution), Scan Gauge 2
    Where did you get the alternator from? I worked in auto parts for a few years. Just because it's new doesn't mean it's any good.
     
  10. Nov 21, 2011 at 6:46 PM
    #10
    wrxRome

    wrxRome [OP] Houston's Swamp Rat

    Joined:
    Aug 25, 2011
    Member:
    #62338
    Messages:
    5,880
    Gender:
    Male
    First Name:
    Brandon
    Covington, LA/Friendswood,TX
    Vehicle:
    06 SWB 4x4 trd off road
  11. Nov 21, 2011 at 7:20 PM
    #11
    joes06tacoma

    joes06tacoma Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28588
    Messages:
    3,056
    Gender:
    Male
    First Name:
    Joe
    Central Coast, CA
    Vehicle:
    06 4x4 Off Road Access Cab v6 6spd
    LEER Shell with dome lights operated with 3 way switches, aux backup lights with relay and 3 position switch, modified wiring to compass/temp display and clock to include switch that disables dimming function (poor man's DRL solution), Scan Gauge 2
    Don't know much about them currently, but used to be crap. There are usually two lines of remanufactured electrical in the aftermarket. You get what you pay for. If they gave you two options and you went cheap, it's probably a bad alternator they sold you.

    I would pull it back out and tell them the warning light keeps coming on. As long as it starts okay, the battery is probably fine.
     
  12. Nov 21, 2011 at 7:28 PM
    #12
    NC15TRD

    NC15TRD Well-Known Member

    Joined:
    Sep 14, 2010
    Member:
    #43212
    Messages:
    6,283
    Gender:
    Male
    First Name:
    Nick
    PA
    Vehicle:
    16 Silverado Z71
    Stock
    Is the Alt. new or refurbed? Just changed one in a car friday put in a refurb, car showed up at garage this afternoon deader than a doornail. Has a brand new battery too, not a high quality one though
     
  13. Nov 21, 2011 at 9:15 PM
    #13
    Leggo

    Leggo slow is smooth, and smooth is fast.

    Joined:
    Dec 16, 2010
    Member:
    #47805
    Messages:
    2,420
    Gender:
    Male
    First Name:
    Steve
    Newton,Ma.
    Vehicle:
    10 TRD Sport AC 4x4 MGM
    Kenwood HU,Infinity Kappa speakers (x4), Infinity reference tweeters(x2),10" Kicker sub, Box by Subthump, Infinty Five channel amp,DVD anytime bypass, DTRL Mod, Xtang trifecta, Fogs anytime Mod, Bed Mat,Westin running boards, Console vault, Maglite mod, Weathertechs,Autopage remote starter, Power tailgate lock, HID Bi Zenon, Hella Supertones,Rain guards,Rear leaf TSB,Steering shaft TSB, Fisher Homesteader plow, 886 reverse lights mod, Redline Hood struts, Hankook Dynapro ATM LT265/70R17, power sliding rear window, Auto dimming/on anytime Bed lights, Blue Sea fuse panel & 100amp Breaker, de- badged,Rear headrest's removed, imMrYo mirror relocation,Homeroshi grill
    (Nice tip. I had a minor electrical problem with bulbs recently, this would have come in handy. Just so I know for the future,does the key need to be on or anything to do this? If i had a short in a wire and pulled and replugged in the fuse there would be a spark?)


    I saw this in your last thread, what was the problem here?
     
  14. Nov 21, 2011 at 9:29 PM
    #14
    wrxRome

    wrxRome [OP] Houston's Swamp Rat

    Joined:
    Aug 25, 2011
    Member:
    #62338
    Messages:
    5,880
    Gender:
    Male
    First Name:
    Brandon
    Covington, LA/Friendswood,TX
    Vehicle:
    06 SWB 4x4 trd off road
    It said remanufactured on the box. I just told them my truck and they gave me that. They never told me any other options. I'll put my old one back on because it's still good and just return the "new" one.
     
  15. Nov 21, 2011 at 9:31 PM
    #15
    wrxRome

    wrxRome [OP] Houston's Swamp Rat

    Joined:
    Aug 25, 2011
    Member:
    #62338
    Messages:
    5,880
    Gender:
    Male
    First Name:
    Brandon
    Covington, LA/Friendswood,TX
    Vehicle:
    06 SWB 4x4 trd off road
    That was just for future reference if I need to pinpoint a short. But I knew what te prob was there.

    I'm sure it's the new alt now. But today when I went to work after letting my truck cool. The light never even flicked

    So now I'm still confused lol
     
  16. Nov 22, 2011 at 4:47 AM
    #16
    NC15TRD

    NC15TRD Well-Known Member

    Joined:
    Sep 14, 2010
    Member:
    #43212
    Messages:
    6,283
    Gender:
    Male
    First Name:
    Nick
    PA
    Vehicle:
    16 Silverado Z71
    Stock
    Return it and get another one. A refurbished part like that will carry a warranty
     
  17. Nov 22, 2011 at 12:20 PM
    #17
    wrxRome

    wrxRome [OP] Houston's Swamp Rat

    Joined:
    Aug 25, 2011
    Member:
    #62338
    Messages:
    5,880
    Gender:
    Male
    First Name:
    Brandon
    Covington, LA/Friendswood,TX
    Vehicle:
    06 SWB 4x4 trd off road
    yeah thats what i plan on doing, because my stock still is good
     
To Top