1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Battery swap and compass broke

Discussion in '2nd Gen. Tacomas (2005-2015)' started by awhillia, Dec 25, 2010.

  1. Dec 25, 2010 at 3:27 PM
    #1
    awhillia

    awhillia [OP] Active Member

    Joined:
    May 18, 2009
    Member:
    #17398
    Messages:
    26
    Gender:
    Male
    Charlotte, NC
    Vehicle:
    2007 Double Cab TRD Sport
    I know there is a simple fix for the overhead console but my situation seems awful strange. woke up yesterday morning with a dead battery. when i put a new one in there the truck fired up fine and everything works as normal excepts for the overhead compass/temp. does anyone have any idea if this is just coincidence or did something happen in the process.
     
  2. Dec 26, 2010 at 9:20 AM
    #2
    joes06tacoma

    joes06tacoma Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28588
    Messages:
    3,056
    Gender:
    Male
    First Name:
    Joe
    Central Coast, CA
    Vehicle:
    06 4x4 Off Road Access Cab v6 6spd
    LEER Shell with dome lights operated with 3 way switches, aux backup lights with relay and 3 position switch, modified wiring to compass/temp display and clock to include switch that disables dimming function (poor man's DRL solution), Scan Gauge 2
    You did try pressing the button on the compass to make it come on, right?:cool:
     
  3. Dec 26, 2010 at 9:35 AM
    #3
    awhillia

    awhillia [OP] Active Member

    Joined:
    May 18, 2009
    Member:
    #17398
    Messages:
    26
    Gender:
    Male
    Charlotte, NC
    Vehicle:
    2007 Double Cab TRD Sport
    yeah i checked that. actually i did the soldering fix. one of the 510s was broke loose like so many people have had trouble with. must have been a major coincidence.

    thanks
     
To Top