1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Battery Trouble

Discussion in '2nd Gen. Tacomas (2005-2015)' started by bennett, Jan 14, 2012.

  1. Jan 14, 2012 at 11:00 AM
    #1
    bennett

    bennett [OP] Well-Known Member

    Joined:
    May 19, 2011
    Member:
    #56931
    Messages:
    69
    Gender:
    Male
    First Name:
    Bennett
    Georgia
    Vehicle:
    08 SR5 4X4
    5100s on all 4 corners(Fronts at .85); Eibach Coils; Toytec Diff Drop; Toytec Top Plate Spacers; Toytec AAL; 285/75R16 MTZs
    So I was about to drive home from school the other day. I got in my truck and turned the key and all I heard was a click. I knew what that meant. Found a buddy and he jumped me off and i drove home. I got back in my truck and tried to crank it again and click was all i heard. Thought i was gonna need a new battery, but it turned out that my positive connection was just really loose. I just had to tighten it. Cost me $0
     
  2. Jan 14, 2012 at 2:56 PM
    #2
    bennett

    bennett [OP] Well-Known Member

    Joined:
    May 19, 2011
    Member:
    #56931
    Messages:
    69
    Gender:
    Male
    First Name:
    Bennett
    Georgia
    Vehicle:
    08 SR5 4X4
    5100s on all 4 corners(Fronts at .85); Eibach Coils; Toytec Diff Drop; Toytec Top Plate Spacers; Toytec AAL; 285/75R16 MTZs
    You're right about the luck part! I just new I was gonna have to get a new battery
     
To Top