1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Bestop seems "floppy"

Discussion in 'Off-Topic Discussion' started by tacomathunder, Mar 27, 2011.

  1. Mar 27, 2011 at 12:30 AM
    #1
    tacomathunder

    tacomathunder [OP] Well-Known Member

    Joined:
    Nov 9, 2009
    Member:
    #25672
    Messages:
    1,572
    Gender:
    Male
    First Name:
    Mike
    Florida
    Vehicle:
    07 4 cyl reg cab
    pop-a-lock on tailgate, tailgate damper by ez down, extang platinum snap tonneau cover, rampage LED light bar, etrailer wiring harness, black led tail lights, tsi clutter catcher center console, griffin itrip ipod player,BHLM,35W DDM Tuning hid's 5000K, Day Time Running Light Mod, New Sony Stereo
    my bestop has been on for about 2 and a half weeks now and it seems like its not very tight....it seems flappy, it scared the shit out of me when i was on the highway i thought it was going to get caught in the wind and fly off... anyone else have this problem???
     
  2. Mar 27, 2011 at 10:07 AM
    #2
    tacomathunder

    tacomathunder [OP] Well-Known Member

    Joined:
    Nov 9, 2009
    Member:
    #25672
    Messages:
    1,572
    Gender:
    Male
    First Name:
    Mike
    Florida
    Vehicle:
    07 4 cyl reg cab
    pop-a-lock on tailgate, tailgate damper by ez down, extang platinum snap tonneau cover, rampage LED light bar, etrailer wiring harness, black led tail lights, tsi clutter catcher center console, griffin itrip ipod player,BHLM,35W DDM Tuning hid's 5000K, Day Time Running Light Mod, New Sony Stereo
    no one else has this??? it seems ass though the bestop is on too loose or something, but i have all the snaps snapped
     
  3. Mar 27, 2011 at 10:15 AM
    #3
    bamma

    bamma Well-Known Member

    Joined:
    Apr 14, 2008
    Member:
    #5974
    Messages:
    271
    Vehicle:
    07 silver acc cab trd OR 4x4
    I read in a different thread that one poster used clamps towards the front of the cab as the snaps/straps didn't have enough holding power and was causing a lot of noise.
     
  4. Mar 27, 2011 at 10:29 AM
    #4
    tacomathunder

    tacomathunder [OP] Well-Known Member

    Joined:
    Nov 9, 2009
    Member:
    #25672
    Messages:
    1,572
    Gender:
    Male
    First Name:
    Mike
    Florida
    Vehicle:
    07 4 cyl reg cab
    pop-a-lock on tailgate, tailgate damper by ez down, extang platinum snap tonneau cover, rampage LED light bar, etrailer wiring harness, black led tail lights, tsi clutter catcher center console, griffin itrip ipod player,BHLM,35W DDM Tuning hid's 5000K, Day Time Running Light Mod, New Sony Stereo
    its not that the straps and snaps dont have enough holding power or there is too much noise, for me anyway...it just seems as though the topper is just really loose on the frame that its on..... on I75 down here it was flapping very violently which scared me, thought it was goingto cause me an accident, or come off and cause someone else an accident
     
  5. Apr 14, 2011 at 7:07 PM
    #5
    jackwithcorona

    jackwithcorona Well-Known Member

    Joined:
    Apr 2, 2010
    Member:
    #34436
    Messages:
    608
    Gender:
    Male
    First Name:
    Mike
    Eastern Mass
    Vehicle:
    13 DCSB SR5 4x4
    bestop supertop, rubber bed mat, weathertech floor mats
    did you move the forward posts to the furthest forward notch on the the zig zag piece? theres three settings, and the instructions dont tell you to move it back and unless you realize it, you could forget to do that and it would be very floppy then
     
  6. Apr 15, 2011 at 7:18 AM
    #6
    indycross

    indycross Well-Known Member

    Joined:
    Jun 16, 2009
    Member:
    #18508
    Messages:
    388
    Gender:
    Male
    First Name:
    Ross
    Austin, Texas
    Vehicle:
    2011 Tundra Crewmax 4x4
    Mine worked perfect on the highway doin 80.

    Where are you clamps that came with the top positioned? I moved both sets of mine a bit closer to the rear window and tailgate because it initially didn't seems to be holding the top a tight as i expected.

    I also place clamps on the front "window" of the top (that clamped to the truck bed channel) for extra support.

    Post some pics of how yours is set up... including the tension bar so we can make some suggestions. A lot of us have/had them. :D
     
To Top