1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Blower fan squeaking?

Discussion in 'Technical Chat' started by usmc0311, May 16, 2011.

  1. May 16, 2011 at 8:15 AM
    #1
    usmc0311

    usmc0311 [OP] Well-Known Member

    Joined:
    May 3, 2011
    Member:
    #56006
    Messages:
    50
    Gender:
    Male
    Vehicle:
    2011 Tacoma dble cab long bed
    nerf bars and bug deflector
    I have a 2011, the blower fan seems to be squeaking when it is on the LO setting and the med setting. It will not squeak if it is on the high setting. I went to the dealer ship and they said that toyota was working on redesigning it and that they couldn't do anything for me until then, I don't know much about mechanics but i was wondering if anyone else had this problem and if there is a quick fix or anything I can do until toyota fixes this problem?
     
  2. May 16, 2011 at 8:21 AM
    #2
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,164
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
To Top