1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Blower Only Works on High - Resistor or Connector Only?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by dutd33, Nov 13, 2023.

  1. Nov 13, 2023 at 8:58 PM
    #1
    dutd33

    dutd33 [OP] Well-Known Member

    Joined:
    Feb 27, 2016
    Member:
    #179589
    Messages:
    74
    Gender:
    Male
    Hi Everyone, I know this question has been asked a million times, but I had two questions regarding the issue of the blower only working on the High setting and none of the other ones:

    1. Do I absolutely have to order the replacement kit that includes the resistors and the connector or should I just the resistor?

    2. Is Dorman still a decent brand for this? I read somewhere that their quality has gone downhill the past couple of years.

    Thank you in advance!
     
  2. Nov 13, 2023 at 9:01 PM
    #2
    TnShooter

    TnShooter The TacomaWorld Stray

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    18,061
    Gender:
    Male
    First Name:
    Deogee
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    Unplug the resistor and see. It’s easy to get too.
    If the connector looks good, you won’t need to order the connector.
    It it’s burnt, you will need it.
     
  3. Nov 13, 2023 at 9:02 PM
    #3
    TnShooter

    TnShooter The TacomaWorld Stray

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    18,061
    Gender:
    Male
    First Name:
    Deogee
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    I don’t like any electronic products manufactured for/by Dorman.
     
  4. Nov 13, 2023 at 9:02 PM
    #4
    dutd33

    dutd33 [OP] Well-Known Member

    Joined:
    Feb 27, 2016
    Member:
    #179589
    Messages:
    74
    Gender:
    Male
    Good call, thank you! :)
     
  5. Nov 13, 2023 at 9:03 PM
    #5
    dutd33

    dutd33 [OP] Well-Known Member

    Joined:
    Feb 27, 2016
    Member:
    #179589
    Messages:
    74
    Gender:
    Male
    That's unfortunate as the kits on Amazon are either some generic Chinese brand or Dorman.

    I could try to order from RockAuto but there's only one other brand there other than Dorman that has a heart next to it (I only order products that have a heart next to them LOL).

    Thanks again!
     
  6. Nov 13, 2023 at 9:07 PM
    #6
    TnShooter

    TnShooter The TacomaWorld Stray

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    18,061
    Gender:
    Male
    First Name:
    Deogee
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    This is your best option. It’s the updated part from Toyota.

    https://www.amazon.com/TOYOTA-Genui...5489753&mcid=31d0ba80a60739d7be570b16003d8b7d

    Here is the link to the wiring diagram to match the wires.
    https://www.tacomaworld.com/threads/2nd-gen-information-diagnostics.784008/#post-28042158
     
  7. Nov 13, 2023 at 10:26 PM
    #7
    caliburrito

    caliburrito Member

    Joined:
    May 30, 2019
    Member:
    #294820
    Messages:
    18
    Gender:
    Male
    San Clemente
    Vehicle:
    2015 DCLB TRD Sport 4X4
    TRD Baja Suspension Camburg UCA Method NV Toyo Open Country AT III TRD catback exhaust
    Happens to me every now and then. Tapping the blower under/behind the glove compartment does the trick every time
     
    dutd33[OP] likes this.
  8. Nov 13, 2023 at 10:50 PM
    #8
    davidstacoma

    davidstacoma Friendly Curmudgeon

    Joined:
    Nov 2, 2019
    Member:
    #309695
    Messages:
    4,588
    Gender:
    Male
    First Name:
    David
    NC
    Vehicle:
    2019 Tacoma SR Access cab - Utility
    *OEM Mods: Intermittent wipers, Fogs, Keyless Entry, Lomax
    Not in my Tacoma but in every other vehicle I’ve replaced the blower resistor the connector also showed signs of overheating. I inspected and replaced both.
     
    dutd33[OP] and TnShooter like this.
  9. Nov 14, 2023 at 2:54 AM
    #9
    2013XSPX

    2013XSPX Well-Known Member

    Joined:
    Nov 29, 2015
    Member:
    #170975
    Messages:
    2,463
    Gender:
    Male
    First Name:
    Matt
    GA/FL Border
    Vehicle:
    2013 XSP-X
    Pelfreybilt front/rear, RCI underneath, Morimoto Headlights, Prinsu racks, SCS Brushed Copper Ray 10's, EO Sliders, Baja Designs and Rigid lights, Inca 4x4 Camper
    I just replaced mine for the second time, 2013 160K miles. I got the Amazon one and I replace both parts each time because it is so cheap and I did see signs of "burning" on the sensor.

    Closed_Front.jpg
     
    dutd33[OP] likes this.

Products Discussed in

To Top