1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

blowing fuses with halos

Discussion in 'Lighting' started by 6dirty9, Jul 31, 2011.

  1. Jul 31, 2011 at 12:39 PM
    #1
    6dirty9

    6dirty9 [OP] Active Member

    Joined:
    May 28, 2011
    Member:
    #57383
    Messages:
    44
    Gender:
    Male
    First Name:
    jason
    covington, virginia
    Vehicle:
    2011 mag grey off road
    Toy tech ultimate 3 inch lift, large tires, wet okle seat covers, sunroof, green led interior lights, tonneau cover, spare tire flip and full size spare, billet grill(customized),ccfl halo headlights, 2 rockford fosgate 12 inch subs behind seat, rockford 6x9 in front door and infighting 6.5 in rear door pushing 100 rms, pioneer 130 double din head unit with factory camera intergrated into head unit. During hunting season have a light bar with 2 go lights mounted on top. want list is Sliders, sock monkey decals.
    I installed eagle eye headlights yesterday. And today the fuses keep blowing. Replace the fuse and with seconds of turning on running lights ( which is the halo and eyebrows and sum interior lights) the fuse blows. I know don't want to up the fuse size. I had set in last truck but didn't have any problems out of them. Any help would greatly be appreciated. I couldn't find what i needed with the seArch button. LOL also this is on brand nee 2011 tacoma.
     
To Top