1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Brake controller issues, first-gen tacoma

Discussion in 'Towing' started by davidpick, Sep 2, 2012.

  1. davidpick

    davidpick [OP] Well-Known Member

    Joined:
    Jan 21, 2010
    Member:
    #29760
    Messages:
    1,902
    Gender:
    Male
    First Name:
    David
    Everett, WA
    Vehicle:
    2004 Xcab 4x4 TRD
    Ok, so my new Tekonsha P2 brake controller is pissing me off. It only intermittently connects to my trailer (I'd guess only 20% of the time it works). Typically all it displays is the two dots (boost 1 is on), but no .c. when the trailer is connected. Occasionally, it will flash n.c. on startup for 15 seconds and then go to . . but won't recognize the trailer.

    I've got test lights on the 7pin trailer connector at the back of the truck and they light up correctly. Lights and turn signals on the trailer are working.

    I am having the ABS light come on randomly while driving -- pretty sure the ABS computer is failing. Would that cause the trailer not to connect?

    I know the trailer is good -- my roommate tows it with his truck with no problems.

    Thoughts? How do I figure out what's going on?
     
  2. davidpick

    davidpick [OP] Well-Known Member

    Joined:
    Jan 21, 2010
    Member:
    #29760
    Messages:
    1,902
    Gender:
    Male
    First Name:
    David
    Everett, WA
    Vehicle:
    2004 Xcab 4x4 TRD
    Well, I plugged in my roommate's Tekonsha Primus brake controller to my truck (same wiring, same trailer) and it connects every time without a problem. Pretty sure I've just got a defective brake controller then.

    That's why I buy things from Amazon! Replacement en route.
     
  3. davidpick

    davidpick [OP] Well-Known Member

    Joined:
    Jan 21, 2010
    Member:
    #29760
    Messages:
    1,902
    Gender:
    Male
    First Name:
    David
    Everett, WA
    Vehicle:
    2004 Xcab 4x4 TRD
    got the new controller... works like a champ! defective controller was the culprit
     
To Top