1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Brake Help!!!!

Discussion in '2nd Gen. Tacomas' started by jwhit1977, Dec 14, 2012.

  1. Dec 14, 2012 at 7:50 AM
    #1
    jwhit1977

    jwhit1977 [OP] New Member

    Joined:
    Jul 5, 2012
    Member:
    #81976
    Messages:
    3
    Gender:
    Male
    First Name:
    Joseph
    Crestview Florida
    Vehicle:
    12 Prerunner 4cylinder
    I have a 2012 Tacoma 4cyl. When I start my day and after a mile or so and I come to a stop my brakes make a grabbing noise and my sterring wheel shakes pretty violently. This only happens after I have not driven my truck for a while. I have had the dealer look at it and they did replace the brake booster but that did not fix it. I have it in there today in hopes that they find out what is wrong. Is there anyone out there that has any idea what is happening?
     
  2. Dec 14, 2012 at 8:00 AM
    #2
    mirraman

    mirraman Well-Known Member

    Joined:
    May 17, 2011
    Member:
    #56818
    Messages:
    309
    Gender:
    Male
    First Name:
    Tim
    Ventura
    Vehicle:
    98 4Runner Limited 4X4 e-locker :-)
    99 4Runner springs all around: 1" over factory.
    Does it seem to happen more at a higher speed? If so, you might need to have the rotors turned(resurfaced). If you have to brake hard from high speed to a stop, you can make the surface of the rotors uneven. This causes, sometimes violent, vibration and jerking in the steering wheel.
     
  3. Dec 14, 2012 at 11:10 AM
    #3
    ntilehman

    ntilehman Well-Known Member

    Joined:
    Oct 15, 2012
    Member:
    #89088
    Messages:
    1,497
    Gender:
    Male
    First Name:
    Seth
    Charlotte, NC
    Vehicle:
    09 Prerunner Off Road
    Rock Sliders Front Light Bar +1.5" Front Arms with Ext. Kings
    2012??? Brakes should be like new. I have 46k miles on my factory brakes. Booster only helps assist the pedal pressure. Unless you really jammed on your brakes I couldn't imagine the rotors being warped. There could always be bad parts from the factory though. Saying that, it could be in the drums as well. You feel more vibrations from front rotors though. Look at them in the morning to see if you get some flash rust on the rotor surface from all the humidity and salt air there. It may just be grinding that crap off the first few stops you makes.
    Have them see if the pads are wearing evenly. If the sliders are already stuck from sitting on the lot for a long time, maybe, a pad may be in constant contact with the rotor creating to much heat all the time. Warping them.
     
  4. Dec 14, 2012 at 5:00 PM
    #4
    maineah

    maineah Well-Known Member

    Joined:
    Mar 24, 2011
    Member:
    #53641
    Messages:
    3,689
    Gender:
    Male
    First Name:
    Tim
    Maine
    Vehicle:
    4X4 SR5 V6 6spd
    If it sits for a long time it's probably rust and should go away after a few stops. Where the pads sit it does not rust so it thumps when ever it hits that spot. Common problem on light air craft lots of the owners chrome plate the rotors to keep them from rusting.
     
  5. Dec 14, 2012 at 5:09 PM
    #5
    Dobri56

    Dobri56 Well-Known Member

    Joined:
    Nov 3, 2009
    Member:
    #25389
    Messages:
    105
    Gender:
    Male
    First Name:
    Dan
    Massachusetts
    Vehicle:
    2012 trd sport longbed
    Smitty Bull bar, PIAA 540, MBRP turn down exhaust, Tractor trailer tool box. Black headlight mod, fog light mod, TRD seat covers, tacoma floor mats, Recon under tailgate light
    my 2012 does the same thing. I feel that the brakes are cranked on pressure. I usually try to feather so I do not get a vibe when braking. It's still there but I just deal. This started when my truck had 2k on it i have 11 k on it now.
     
  6. Dec 14, 2012 at 6:21 PM
    #6
    Rich91710

    Rich91710 Well-Known Member

    Joined:
    Feb 23, 2012
    Member:
    #73470
    Messages:
    16,493
    Gender:
    Male
    First Name:
    Rich
    Los Angeles
    Vehicle:
    08 Base
    Satoshi with FJ badge, factory cruise, factory intermittent wipers, Redline Tuning hood-lift struts, Hellwig Swaybar, Rosen DVD-Nav
    Vibration would potentially be an ABS issue.
    If it's happening when the truck has been parked for a week or more, it could be surface rust on the rotors, but I would more suspect air in the ABS processor.

    Take it to a different dealer and request that they bleed the ABS system.
     
  7. Dec 15, 2012 at 6:31 AM
    #7
    jwhit1977

    jwhit1977 [OP] New Member

    Joined:
    Jul 5, 2012
    Member:
    #81976
    Messages:
    3
    Gender:
    Male
    First Name:
    Joseph
    Crestview Florida
    Vehicle:
    12 Prerunner 4cylinder
    The dealer adjusted my brake pedal and it seems to be working fine! I will continue to monitor the situation!
     
To Top