1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Brake issues!!! Can anyone help?

Discussion in '1st Gen. Tacomas (1995-2004)' started by slawdog, Feb 24, 2010.

  1. Feb 24, 2010 at 10:03 AM
    #1
    slawdog

    slawdog [OP] Member

    Joined:
    Sep 21, 2009
    Member:
    #23075
    Messages:
    18
    Gender:
    Male
    Georgia
    Vehicle:
    03 SR5
    I've got an 03 Tacoma SR5. When i apply the brakes everything works fine until right before the truck comes to a complete stop. It then acts as if the brakes lock down. Sometimes, after I stop, I can let go of the brakes & the truck sits still. If I tap the gas & the truck lunges forward but comes to a stop again without pressing the brake. Once I give it enough gas the brake releases & its back to normal operation. I've taken it to the mechanic twice but theu have not found anything. Only problem is it only does this about twice a week. Sometimes it shakes the truck violently as if i am slamming on & off the brakes as I come to a complete stop. Has anybody else had this issue? The mech wants me to leave it with him for a week so maybe he can catch it, but I dont want to be without my taco for a week. Any help would be great. Thanks in advance.
     
  2. Feb 24, 2010 at 10:58 AM
    #2
    EnolaGaia

    EnolaGaia Well-Known Member

    Joined:
    Sep 9, 2006
    Member:
    #9
    Messages:
    1,129
    Gender:
    Male
    Midwest USA
    Vehicle:
    '01 & '04 S-Runners
    01 SR: Double Cab conversion, S/C, lowered.
    Sounds to me like something's 'way out of adjustment with your ABS.

    What are the details on the Taco (engine / transmission)?

    Any suspension or other modifications?
     
  3. Feb 24, 2010 at 11:12 AM
    #3
    slawdog

    slawdog [OP] Member

    Joined:
    Sep 21, 2009
    Member:
    #23075
    Messages:
    18
    Gender:
    Male
    Georgia
    Vehicle:
    03 SR5
    It's got the V-6 with an auto trans.
    There's a 3 inch body lift that was on it when i got it.
    Other than that everything is stock.
     
  4. Feb 24, 2010 at 11:59 AM
    #4
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,256
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    Pull your ebrake handle a few times. I'm thinking the ebrake might be stuck.

    Check the ebrake cable make sure its moving freely the while length of the truck.

    Take your rear wheels off, and take the rear drums off...check the ebrake mechanism, the adjuster, and the shoes.
     
To Top