1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Brake lights come on when parking lights are turned on.

Discussion in 'Technical Chat' started by tonyjoe2, Sep 11, 2010.

  1. Sep 11, 2010 at 7:17 PM
    #1
    tonyjoe2

    tonyjoe2 [OP] New Member

    Joined:
    Sep 11, 2010
    Member:
    #43097
    Messages:
    2
    Gender:
    Male
    First Name:
    tony
    Vehicle:
    00 PreRunner excab
    I just bought a 00 Tacoma excab prerunner. When I bought it someone had wired in a trailer harness, now when I turn my lights on the brake lights come on. When I push on the brake the lights on the dash come on. Anyone know what I need to do to get it fixed back the right way.
     
  2. Sep 11, 2010 at 7:28 PM
    #2
    wildjerseyfirefighter

    wildjerseyfirefighter I sell fishing and fishing accessories

    Joined:
    Dec 17, 2008
    Member:
    #11677
    Messages:
    7,951
    Gender:
    Male
    First Name:
    Joe
    NJ
    Vehicle:
    05 Tacoma TRD Sport
    stock, for now
    take the trailer harness out..
     
  3. Dec 10, 2016 at 12:04 PM
    #3
    Bassett_02Tacoma

    Bassett_02Tacoma New Member

    Joined:
    Dec 10, 2016
    Member:
    #204504
    Messages:
    3
    Gender:
    Male
    First Name:
    Isaac
    Vehicle:
    2002 Black Tacoma SR5 Double Cab
    Aftermarket alarm/remote start. Canopy, stereo system, heated seats
    I have a similar issue, when I press on my brake pedal the dash lights come on and if I turn my running lights on the brake lights come on and stay on, if I keep them off and press the brake pedal the dash lights up and the running lights come on.. I've removed the trailer harness and grounded out the tail lights checking all the connections but still the problem persists.. has anyone found out any other reason behind this problem?
     
  4. Dec 10, 2016 at 1:04 PM
    #4
    Wyoming09

    Wyoming09 Well-Known Member

    Joined:
    Apr 24, 2015
    Member:
    #153833
    Messages:
    3,700
    Gender:
    Male
    New Tripoli Pa
    Vehicle:
    2000 Work truck
    Super Springs
    If you have removed the Converter box

    Check your tail light sockets That socket and the wiring harness for the rear lights some place you have the Brake light and tail light circuit wires touching

    If you have splices were you removed the trailer harness parts it might be there.
     
  5. Dec 10, 2016 at 4:43 PM
    #5
    Bassett_02Tacoma

    Bassett_02Tacoma New Member

    Joined:
    Dec 10, 2016
    Member:
    #204504
    Messages:
    3
    Gender:
    Male
    First Name:
    Isaac
    Vehicle:
    2002 Black Tacoma SR5 Double Cab
    Aftermarket alarm/remote start. Canopy, stereo system, heated seats
    I never had a converter box for my 7 pin harness... either way i disconnected it completely so I know it isn't that.

    I have aftermarket tail lights and I think the parking and brake light is somehow fused together inside the actual taillight, the problem is im in Cali on my honeymoon and I'm from Oregon where my original tail lights are.. i'll have it fixed and then we start driving and it just happens again. It is very frustrating to say the least..
     
  6. Dec 10, 2016 at 4:49 PM
    #6
    cory02taco

    cory02taco Well-Known Member

    Joined:
    Jan 19, 2012
    Member:
    #71007
    Messages:
    301
    Gender:
    Male
    First Name:
    Cory
    Maine
    Vehicle:
    2013 trd super sport
    Pull your tail/brake light bulbs and make sure someone didn't put in the wrong style. A dual filament in a single filament hole will cause wacky things like you mention.
     
  7. Dec 13, 2016 at 11:39 AM
    #7
    mechanicjon

    mechanicjon They call me "Jonny 9 Fingers"

    Joined:
    Dec 2, 2016
    Member:
    #203828
    Messages:
    3,816
    Gender:
    Male
    First Name:
    Jon
    Scottsdale Arizona
    Vehicle:
    04 Tacoma 4dr SR5 TRD Prerunner
    Fabtech AAL, Billie's wrapped with 880's , Tundra big brake conversion, bully bars and Pioneer DDin Stereo/dvd with exterrnal usb ports. 240K and going strong.
    Yeppers. Or wired them wrong. They mentioned after market tail lights.
     

Products Discussed in

To Top