1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

brakes

Discussion in '2nd Gen. Tacomas (2005-2015)' started by 10silvertaco, Sep 7, 2009.

  1. Sep 7, 2009 at 7:05 AM
    #1
    10silvertaco

    10silvertaco [OP] Well-Known Member

    Joined:
    Sep 1, 2009
    Member:
    #22085
    Messages:
    343
    Gender:
    Male
    First Name:
    Brent
    Vehicle:
    no longer own Tacoma, now own 2011 Outback
    Hey there,

    A little concern about my rear brakes. I don't drive city road very much. Yesterday I use lots of city road. From stop is no problem. When the light turn green, I felt a little bump in the rear when I let go the brake. Is that normal? I never have drum brakes, all of my previous vehicle is four wheels disc brakes.
    Let me know before I am taking it down to Toyota tomorrow. Almost 2000 miles on my truck.
     
  2. Sep 7, 2009 at 7:22 AM
    #2
    fireturk41

    fireturk41 I like to break shit!

    Joined:
    Dec 23, 2008
    Member:
    #11857
    Messages:
    4,804
    Gender:
    Male
    First Name:
    Kevin
    High Point, NC
    Vehicle:
    280k miles
    SAS, Locked front rear, Ufab sliders and bumpers, air compressor, 35" BFG KM2 on steelies and 36" TSLs
    axle wrap maybe, its normal unfortunately
     
To Top