1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Break Problems

Discussion in '2nd Gen. Tacomas (2005-2015)' started by jnguyen832@yahoo.com, Feb 9, 2010.

  1. Feb 9, 2010 at 8:24 PM
    #1
    jnguyen832@yahoo.com

    jnguyen832@yahoo.com [OP] Member

    Joined:
    Jun 8, 2009
    Member:
    #18199
    Messages:
    6
    Gender:
    Male
    First Name:
    Jack
    Cypress
    Vehicle:
    05 PreRunner
    Leveling lift kit
    i Have a 05 tacoma and ,my breaks are acting up. It only happens when i come to a complete stop at a red light or stop sign, and when i release the break pedal i feel and hear a clunk comming from the front breaks.You can feel the clunk pretty good. It feels like there is a delay for the break calipers to release. I adjusted the rear breaks and it still makes the noise. If anyone had the same problem please let me know
     
  2. Feb 9, 2010 at 8:28 PM
    #2
    mountainwolfpup

    mountainwolfpup Ford Guy (Formerly known as a Toyota Guy)

    Joined:
    Jan 1, 2009
    Member:
    #12116
    Messages:
    980
    Gender:
    Male
    Vancouver, WA
    Vehicle:
    2015 Ford F150 Lariat FX4 3.5l Eco
    First month of ownership... This month I'm removing front air dam, and also Rhino lining the bed.
    My advise... Goto a qualified mechanic right away. It is absolutely essential your brake system is in good working condition. Your life and the lives of others are potentially at risk.
     
  3. Feb 9, 2010 at 9:11 PM
    #3
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    Search the forum for axle wrap, it's probably what you're experiencing.
     
  4. Feb 10, 2010 at 4:19 AM
    #4
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    If it's coming from the front of the car- Probably not axle wrap.

    If you know breaking systems- Dig in. Otherwise get it to a mechanic and demo the problem to him and get them working on it.
     
To Top