1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Camber

Discussion in 'Suspension' started by Hairy Taco, Mar 17, 2012.

  1. Mar 17, 2012 at 5:58 PM
    #1
    Hairy Taco

    Hairy Taco [OP] Masterbrachiator

    Joined:
    Nov 25, 2011
    Member:
    #67666
    Messages:
    8,681
    First Name:
    Chris
    Manitoba
    Vehicle:
    08 TRD
    My last alignment left me a front camber of 1.07 on left and .98 right. Is this significantly too high? What sort of tire wear have people experienced who have comparable numbers?

    -thanks in advance
     
  2. Mar 17, 2012 at 10:23 PM
    #2
    maxamillion2345

    maxamillion2345 Go home if you don't like guns liquor and whores.

    Joined:
    Feb 20, 2010
    Member:
    #31761
    Messages:
    7,880
    Gender:
    Male
    First Name:
    Max
    Nevada
    Vehicle:
    80 series LC
    Too many
    It's a bit high but rotate your tires often and you'll be okay, IMO.

    When I had 265s I had .8 and .7 and when I ran em bald they wore pretty even but I cross rotated them frequently.

    When I bumped to 285s the steering felt a lot more squirmy so I got LR UCAs and now it drives like it should and no adverse tire wear.
     
  3. Mar 18, 2012 at 10:35 AM
    #3
    Hairy Taco

    Hairy Taco [OP] Masterbrachiator

    Joined:
    Nov 25, 2011
    Member:
    #67666
    Messages:
    8,681
    First Name:
    Chris
    Manitoba
    Vehicle:
    08 TRD
    appreciate the input, thanks
     
To Top