1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cat. gone bad?

Discussion in '1st Gen. Tacomas (1995-2004)' started by ETaco23, Dec 19, 2009.

  1. Dec 19, 2009 at 11:33 PM
    #1
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Hey there! I had my CEL come on yesterday and had the Code pulled and its the emissions code, p0420. I replaced my AFR sensor about 2-3 months ago, and now Im ganna replace the rear sensor to see if that is the issue.
    But if not, and its the Cat. Where is the best place to get a new GOOD OEM cat?
    RockAuto is where I got my sensors.
     
  2. Dec 19, 2009 at 11:38 PM
    #2
    Krazie Sj

    Krazie Sj Resident Jackass

    Joined:
    Oct 9, 2008
    Member:
    #9849
    Messages:
    13,686
    Gender:
    Male
    First Name:
    Power Serge
    LV-426 (Acheron)
    Vehicle:
    07 TRD Off Road 4x4
    Borla Catback Exhaust, Airaid Short Ram Intake, 285x75R16 Mickey Thompson MTZs, 16" Konig Countersteer rims, ARB Bumper, All Pro LT w/Walker Evan Shocks front and back, All Pro expedition leaf pack, 10,000lb Superwinch, Intake Manifold Spacer, Bed Rack with ARB RTT, Rotopack and Hi Lift mounted, Husky Liner mats and an air freshener from 1995.
    Sawzall and down the street?

    Honestly though I couldn't tell you, sorry to head the bad news.
     
  3. Dec 20, 2009 at 12:03 PM
    #3
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Thanks.. anyone else?
    Is there a way I could test my cat to see if its still good?
     
  4. Dec 20, 2009 at 12:06 PM
    #4
    mwild

    mwild I CANT SPELL SO DONT BITCH

    Joined:
    May 18, 2008
    Member:
    #6720
    Messages:
    1,413
    Gender:
    Male
    First Name:
    Matt
    Vernon, NJ
    Vehicle:
    03 2500 Dodge Ram
    Cat-Back, weather techs, ipod and sisuis Old 04 Taco: 5100s At all 4 corners set at 2.5", Toyotec AAL, Gibson cat-back, Deck plate mod, 20% Tint on fronts, 10" Kicker Comp sub, Sirius radio, Bud Built Skid, Pro Comp 8069 Wheels
    i have the exact same problem mine came on last week for the same cat code. i just put a cat-back on and did the deck plate mod. wat a pain in my ass
     
  5. Dec 20, 2009 at 12:32 PM
    #5
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    did you put a new cat on, and the CEL is gone now?
     
  6. Dec 20, 2009 at 12:47 PM
    #6
    mwild

    mwild I CANT SPELL SO DONT BITCH

    Joined:
    May 18, 2008
    Member:
    #6720
    Messages:
    1,413
    Gender:
    Male
    First Name:
    Matt
    Vernon, NJ
    Vehicle:
    03 2500 Dodge Ram
    Cat-Back, weather techs, ipod and sisuis Old 04 Taco: 5100s At all 4 corners set at 2.5", Toyotec AAL, Gibson cat-back, Deck plate mod, 20% Tint on fronts, 10" Kicker Comp sub, Sirius radio, Bud Built Skid, Pro Comp 8069 Wheels
    not yet i have a scaner and just keep turnin in off and prtending its not gonna come back on lol. i already changed to 02 sencer and tat didnt do it so i gess i have to change the cat
     
  7. Dec 20, 2009 at 3:37 PM
    #7
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    lol, thats sucks man! yeah I just ordered my other sensor bc I replace my first one about a month ago, and it didnt do it. So If this doesnt work I geuss I need a new cat too. :(
    there freaken spendy bastards!
     
  8. Dec 20, 2009 at 4:14 PM
    #8
    mwild

    mwild I CANT SPELL SO DONT BITCH

    Joined:
    May 18, 2008
    Member:
    #6720
    Messages:
    1,413
    Gender:
    Male
    First Name:
    Matt
    Vernon, NJ
    Vehicle:
    03 2500 Dodge Ram
    Cat-Back, weather techs, ipod and sisuis Old 04 Taco: 5100s At all 4 corners set at 2.5", Toyotec AAL, Gibson cat-back, Deck plate mod, 20% Tint on fronts, 10" Kicker Comp sub, Sirius radio, Bud Built Skid, Pro Comp 8069 Wheels
    yea they are im gonna put a high flow cat on it they are cheaper
     
  9. Dec 20, 2009 at 5:05 PM
    #9
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Huh... I was wondering how you would know which cat is bad? Front or Rear...
     
  10. Dec 20, 2009 at 5:21 PM
    #10
    WhatThePho?

    WhatThePho? Greg Graffin 2016

    Joined:
    Jun 30, 2009
    Member:
    #19096
    Messages:
    5,396
    Gender:
    Male
    First Name:
    Andre
    HCMC, VN
    Vehicle:
    2006 STi
    The things required to pull bitches
    I heard aftermarket cats don't really work well on our trucks, It will just come back with the codes. Can anyone confirm that?

    I have had the p0420 code come up when I first got my truck, that and both sensor codes (o2 and a/f ratio sensor) I replaced both sensor cleared the codes and the p0420 never came back.
     
  11. Dec 20, 2009 at 5:22 PM
    #11
    mwild

    mwild I CANT SPELL SO DONT BITCH

    Joined:
    May 18, 2008
    Member:
    #6720
    Messages:
    1,413
    Gender:
    Male
    First Name:
    Matt
    Vernon, NJ
    Vehicle:
    03 2500 Dodge Ram
    Cat-Back, weather techs, ipod and sisuis Old 04 Taco: 5100s At all 4 corners set at 2.5", Toyotec AAL, Gibson cat-back, Deck plate mod, 20% Tint on fronts, 10" Kicker Comp sub, Sirius radio, Bud Built Skid, Pro Comp 8069 Wheels
    when i scan mine it says bank 2 i think that is the rear cat. my bubby is a toyota mechanic i will ask himand will let you know what he says
     
  12. Dec 20, 2009 at 7:52 PM
    #12
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    k, Thanks! I bieleve mine says bank 1. witch would suck if its the front cat, bc I had to weld a new flange on that one for my TRD headers. :(
    I will talk to my dads buddy who is a machanic and see what he says.
     
  13. Dec 21, 2009 at 3:44 AM
    #13
    RacerP

    RacerP Well-Known Member

    Joined:
    Oct 4, 2008
    Member:
    #9677
    Messages:
    452
    Gender:
    Male
    Chicago
    Vehicle:
    2003 4x4
    7th Injector kit, Trans Cooler, Donohoe c/o's, Billy's in the rear, FJ Cruiser Trail Team SE wheels.
    I had to replace my cats last year, both of them. Put MagnaFlow direct bolt-ins on, about 1/3 of the price of factory and have not had a problem since. I don't remember where I bought, but, even the dealer installed them.

    Peter
     
  14. Dec 21, 2009 at 7:51 AM
    #14
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Well Im ganna try a new sensor and see if that is infact the problem, But I will also check my cats by hitting them to see if I hear any rattling. But I really hope I dont need new cats!:eek:
     
  15. Dec 22, 2009 at 8:34 PM
    #15
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Is it true that when replacing o2 sensors that you should always replace both at the same time? And that if you dont it could just screw up the new one,(if you just replace one)?
    Im waiting for my rear o2 sensor to get here, and am just hoping that my front one isnt screwed up, :( I checked my cats and they seem fine. So any Insight into this would be helpful, thanks!
     
To Top