1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

CEL light bank 1 sensor 1

Discussion in '1st Gen. Tacomas (1995-2004)' started by bill-e-boy, Jul 17, 2013.

  1. Jul 17, 2013 at 3:47 PM
    #1
    bill-e-boy

    bill-e-boy [OP] new and improved

    Joined:
    Jun 23, 2008
    Member:
    #7517
    Messages:
    216
    Gender:
    Male
    First Name:
    billy
    florence
    Vehicle:
    04 dbl cab lifted pre-Runner
    added factory roof rack, factory skid plate, removed cheesy running boards, built a pvc bike rack, added interior floor lighting, added decal plate under rear window, added sylvania silverstars, installed toytec ultimate 3" lift, added hella optilux yellow fog lights, added orange park lights to the turn signals, new 265/75/16 goodyear duratracs tires and raceline rockcrusher 16" wheels
    ok my friends, I got a CEL light, took it to advanced auto, code says P0751, 02 sensor, bank 1 sensor 1 and shift solenoid. I've have seen on here to order the 02 sensors from ROCK AUTO (and REPLACE both bank 1 & 2).....but I have not seen much on the SHIFT SOLENOIDS...anybody care to share some advice on how/where to fix these issues?....instructions for replacing shifting solenoid and 02 sensors???....please????

    thanks anybody!!!!
     
  2. Jul 17, 2013 at 3:51 PM
    #2
    bill-e-boy

    bill-e-boy [OP] new and improved

    Joined:
    Jun 23, 2008
    Member:
    #7517
    Messages:
    216
    Gender:
    Male
    First Name:
    billy
    florence
    Vehicle:
    04 dbl cab lifted pre-Runner
    added factory roof rack, factory skid plate, removed cheesy running boards, built a pvc bike rack, added interior floor lighting, added decal plate under rear window, added sylvania silverstars, installed toytec ultimate 3" lift, added hella optilux yellow fog lights, added orange park lights to the turn signals, new 265/75/16 goodyear duratracs tires and raceline rockcrusher 16" wheels
    taken from another thread...."shift solenoids are internal, when you pull the pan off they are right there"...can anybody point me to some more detailed instructions?
     
  3. Jul 17, 2013 at 3:55 PM
    #3
    04trd

    04trd Well-Known Member

    Joined:
    Dec 17, 2009
    Member:
    #27696
    Messages:
    831
    Gender:
    Male
    First Name:
    Matt
    Cleveland Ohio
    Vehicle:
    04 SR5 double cab
    Xm radio,wet oakley seat covers front and back, 2 8inch subs, 20% tint, king coil overs, alcan leaf springs, 16 inch Dick Cepek DC-1's, 265 75 16 nitto terra grapplers
    I can't say anything about the shift solenoid but the o2 sensor just un bolts and follow the wire and un plug it. Than out the new one and plug it jn
     
To Top