1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

CEL on and off??

Discussion in 'Technical Chat' started by littledvl, Jan 29, 2011.

  1. Jan 29, 2011 at 5:19 PM
    #1
    littledvl

    littledvl [OP] ride BMX!

    Joined:
    Oct 28, 2008
    Member:
    #10345
    Messages:
    3,659
    Gender:
    Male
    First Name:
    Eric
    Saint Leonard MD
    Vehicle:
    08 taco dc 4x4 / 15 tundra dc 4x4
    Too many to list
    Ok forst off I have had my charcoal canister replaced 3 times since I bought my truck new in 2008, most recently as january 6th.. The day after I got it back it the CEL came back on and my scangauge came up with p0451 then after a few days it went off. Since then its been coming on seems like every 5 starts then go off after a day and throwing a blank code with p0000. Today it came back on going to the store and is now throwing p0453, well it went off on the way home and is back on now...

    What could be causing it to be throwing codes like this? A faulty or dirty sensor somewhere? Seems everytime I goto the dealer they replace the canister and tell me that was all, I dont get how it could be going bad in less then a week. :confused:
     
  2. May 3, 2012 at 6:47 PM
    #2
    jfr02

    jfr02 Well-Known Member

    Joined:
    Apr 4, 2009
    Member:
    #15567
    Messages:
    233
    Gender:
    Male
    Vehicle:
    2012 dcsb 6spd sport
    i work at a toyota dealer.We have a 07 with the same problem.He has been to three other dealers and they all replaced the canister.The tech working on it called tech assistance and of course they were no help.Then our service manager called our zone tech rep he was told there is a gray wire in the driver's kick panel that's causing some problems.The tech cut the wire and soldered the wire together eliminating the conector.The tech is driving the truck home tonight to see if the code resets.If this does fix the issue I will get some pictures and more info.So help may be on the way.
     
  3. May 3, 2012 at 6:53 PM
    #3
    Ga tacoguy

    Ga tacoguy Well-Known Member

    Joined:
    Mar 2, 2012
    Member:
    #74020
    Messages:
    310
    Gender:
    Male
    First Name:
    Rudy
    Augusta Ga.
    Vehicle:
    Extended cab Base model 4 cyl
    Tailgate mod, horn mod,storage door mod
    :) Do you overfill to your filler neck when you gas up ? You should not pump much after the gas nozzle kicks off. I see that you do go off road, Do you climb or tilt your truck at odd angles ? You could have some check valves that prevent back flow of gas going bad. These are just some options, your question was probably answered by the other fellow. Good Luck.
     
  4. May 3, 2012 at 6:53 PM
    #4
    littledvl

    littledvl [OP] ride BMX!

    Joined:
    Oct 28, 2008
    Member:
    #10345
    Messages:
    3,659
    Gender:
    Male
    First Name:
    Eric
    Saint Leonard MD
    Vehicle:
    08 taco dc 4x4 / 15 tundra dc 4x4
    Too many to list
    Thanks alot for the info, my cel still is on and off daily throwing the same codes, iv got used to it and dont bother taking it to the dealer... I would really love to find a fix for this, would be nice to not see the cel on.

    Hope the tech comes back with some good news :D
     
  5. May 3, 2012 at 6:56 PM
    #5
    littledvl

    littledvl [OP] ride BMX!

    Joined:
    Oct 28, 2008
    Member:
    #10345
    Messages:
    3,659
    Gender:
    Male
    First Name:
    Eric
    Saint Leonard MD
    Vehicle:
    08 taco dc 4x4 / 15 tundra dc 4x4
    Too many to list

    No never have, first time to the dealer thats what they said.. I had a 1/4 tank of gas when i had the canister replaced the last time, got the truck back and within a day i had the same codes coming up and never even touched the gas cap. I always am parked on flat or damn close to flat ground.
     
  6. May 6, 2012 at 5:14 AM
    #6
    jfr02

    jfr02 Well-Known Member

    Joined:
    Apr 4, 2009
    Member:
    #15567
    Messages:
    233
    Gender:
    Male
    Vehicle:
    2012 dcsb 6spd sport
    Sorry the tech working on the truck let it go before i got pictures.He did put 87 miles on it and the dtc's did not reset.I will give it a few days to make sure the customer does not come back then i will use my truck to get pictures so you know what to do.So just give me a few days if you don't hear frome me just pm me to remind me.
     
To Top