1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Center Support Bearing

Discussion in 'Technical Chat' started by 05TacoTRD, Feb 21, 2013.

  1. Feb 21, 2013 at 5:28 AM
    #1
    05TacoTRD

    05TacoTRD [OP] Member

    Joined:
    Aug 16, 2011
    Member:
    #61792
    Messages:
    20
    Gender:
    Male
    First Name:
    Franco
    Bradenton FL
    Vehicle:
    05 PreRunner TRD Sport
    Has anyone had issues with their Center Support Bearing? I just replaced mine about 2 months ago, and all was well...Now it seems as if the similar vibration it had is slowly coming back...:confused: Is this a common issue? I have a 05 Double Cab Long Bed Pre-Runner... Any Ideas on what can cause this to go bad so quick? It's currently all stock no mods yet... Any advice will help, Thanks!!
     
  2. Feb 21, 2013 at 5:30 AM
    #2
    kws129

    kws129 Well-Known Member

    Joined:
    Jan 23, 2009
    Member:
    #12880
    Messages:
    240
    Gender:
    Male
    PA
    Vehicle:
    TRD Off Road Double Cab
    Check the real wheel bearings, take out the driveshaft and spin the rear wheels. You might have a bad bearing rather than the carrier going out again.
     
  3. Feb 21, 2013 at 5:50 AM
    #3
    05TacoTRD

    05TacoTRD [OP] Member

    Joined:
    Aug 16, 2011
    Member:
    #61792
    Messages:
    20
    Gender:
    Male
    First Name:
    Franco
    Bradenton FL
    Vehicle:
    05 PreRunner TRD Sport
    Ok, I will check that out... I did run it on stands and heard a scrubbing sound... I'm pretty sure the left rear axle is slightly bent from a previous accident if the bearing is bad I bet thats why
     
To Top