1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Certain Interior Lights Quit Working

Discussion in 'Technical Chat' started by Turbomeister, Feb 17, 2013.

  1. Feb 17, 2013 at 7:35 PM
    #1
    Turbomeister

    Turbomeister [OP] That One Guy

    Joined:
    Feb 17, 2013
    Member:
    #97788
    Messages:
    13
    Gender:
    Male
    Missouri
    Vehicle:
    09 V6 TRD Off-Road
    DTRL Switch Mod
    So I'm new here, been lurking for a while but this is my first post.

    I decided to do the DTRL Switch Mod here and successfully got it working.

    [​IMG]

    There's where I put my switch.

    But right after I finished, a front blinker bulb burned out (Great timing). I didn't realize what happened, so I pulled the switch back off, looking for a loose connection. And being the impatient idiot that I am, I used a circuit tester (Light bulb and battery, about 5 volts) to test the switch without unplugging it from the truck wiring. :p

    I quickly realized this was a mistake, because now not only is my blinker bulb burned out, but now the HVAC control backlights, all driver side dash button backlights except fogs and traction control, and all window control lights except the driver's are not lit anymore.

    My question is, did I completely fry the interior computer and make an expensive mistake, or is each individual bulb burned out? I thought about a fuse, but I figured that if it was a fuse, all the interior lights would be out, not just select ones.

    Any ideas? I know I made a stupid mistake, but just how stupid? Has anyone ever done or seen something similar, and if so how did you fix it? :confused:
     
  2. Feb 18, 2013 at 5:44 PM
    #2
    Turbomeister

    Turbomeister [OP] That One Guy

    Joined:
    Feb 17, 2013
    Member:
    #97788
    Messages:
    13
    Gender:
    Male
    Missouri
    Vehicle:
    09 V6 TRD Off-Road
    DTRL Switch Mod
    Update:
    Tonight I replaced the blinker bulb, but still no dice. I still have no front blinker on that same side, and the rear is blinking fast like you'd expect from a burned-out bulb. I'm thinking I may have fried some module computer under the dash, unless somebody knows of a special combination of fuses I could have blown to get these lights out?? Tomorrow night when I get time I'll go checking fuses :(
     
  3. Feb 18, 2013 at 5:47 PM
    #3
    Forster46

    Forster46 Very nice how much?

    Joined:
    Jul 20, 2010
    Member:
    #40487
    Messages:
    3,368
    Gender:
    Male
    First Name:
    Nick
    Mount Vernon, WA
    Vehicle:
    The doritos locos taco
    6000k HID's, AUX Reverse Lights, 3" Rough Country Suspension Lift, Pioneer AVH-P4200 Double Din, Underglow and footwell Lights, Camo Seat Covers, Duralast Tool Box, Blacked Out Badges, Grill, Front Emblem, Midland CB Radio, Amber Strobes, POWER REAR WINDOW, cup holder LED's, Firestik 3' in bed, console divider, Ultragauge.
    Are your running lights working?
     
  4. Feb 18, 2013 at 5:54 PM
    #4
    Turbomeister

    Turbomeister [OP] That One Guy

    Joined:
    Feb 17, 2013
    Member:
    #97788
    Messages:
    13
    Gender:
    Male
    Missouri
    Vehicle:
    09 V6 TRD Off-Road
    DTRL Switch Mod
    No, the running lights are off, but that may be a result of my terrible switch I was troubleshooting when I caused this mess. :p

    I just thought once I got the blinker and interior lights working again, then I can troubleshoot the running lights, which are only off because of a SPST switch on one wire. Before I burned whatever it is up, I tried the blinkers with the wire cut. Everything worked as expected, just minus the running lights.
     
  5. Feb 19, 2013 at 3:57 PM
    #5
    Turbomeister

    Turbomeister [OP] That One Guy

    Joined:
    Feb 17, 2013
    Member:
    #97788
    Messages:
    13
    Gender:
    Male
    Missouri
    Vehicle:
    09 V6 TRD Off-Road
    DTRL Switch Mod
    Summary:

    Ok, here's a summary for my long rambling series of posts. (Sorry!) Front right blinker not working (for blinkers or hazards). Bulb is good. Certain interior lights (power window switch backlights, driver's side dash button backlights for everything except fogs and traction control, and climate control knob backlights) not working. DTRL not working (although that was the goal I was trying to achieve, so it's a non-issue). Everything else in the truck works.

    After some research, I've decided it must be the body ECU on the backside on the fuse block in the lower dash on the driver's side. Does anyone have any diagrams or information on this module or any others that control these lights? I can't find any information on it, or even any place that stocks it.

    My question is first, is this the only possible module that could control these lights? I know nothing about this, and am having trouble researching it. Secondly, does anybody have any information at all about this module? Like pricing or where I could get it or anything? Any experiences at all with the body ECU?

    Please....I really need some help here! Thanks
     
To Top