1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

check eng light for tire psi?

Discussion in '1st Gen. Tacomas (1995-2004)' started by mo13, Sep 6, 2011.

  1. Sep 6, 2011 at 3:26 AM
    #1
    mo13

    mo13 [OP] Well-Known Member

    Joined:
    Jul 30, 2011
    Member:
    #60800
    Messages:
    395
    Gender:
    Male
    First Name:
    Marc
    fleming island,FL
    Vehicle:
    2010 TRD OR
    Icon RR extended length coilovers with cdc,Icon RR 2.0 custom length shocks, Icon tube UCA,all pro standard leaf pack,allpro u bolt flip kit,extended front and rear steel braided brake lines,CMC,super bumps, color matched mirror covers, relentless fab front bumper, smittybilt 8k winch with syn line, viking thimble and hawse fairlead, d2s retro fits, 20" led bar on bamf bracket, 4 rigid duallys, skygear fuse box, viper remote start, and a very shotty made satoshi raptor mesh grill made by myself haha
    So i just bought a 2004 tacoma access cab and ive had it for around 1 month and i get a check eng light. so i air up the tires and it goes away so im pretty sure it has sensors in there just wondering if yall can verify that and also tell me how to disable em or what psi they activate the light at. thanks ahead of time
     
  2. Sep 6, 2011 at 4:24 AM
    #2
    skytower

    skytower Well-Known Member

    Joined:
    Jun 7, 2010
    Member:
    #38505
    Messages:
    3,228
    Gender:
    Male
    First Name:
    Dave
    virginia
    Vehicle:
    08 Tacoma 4x4
    Hitch and wiring, aux back-up light, rear strobe lights, radio and underseat sub.
    Welcome!
    There is a separate light for the tire pressure system, if you have it. It is half a tire with a "!" inside of it. It should come on when you turn on the ignition. No light=no tpms.
    Tire pressure and check engine lights are unrelated. Go to Autozone and get the code read to find out your actual problem.
     
  3. Sep 6, 2011 at 4:33 AM
    #3
    skytower

    skytower Well-Known Member

    Joined:
    Jun 7, 2010
    Member:
    #38505
    Messages:
    3,228
    Gender:
    Male
    First Name:
    Dave
    virginia
    Vehicle:
    08 Tacoma 4x4
    Hitch and wiring, aux back-up light, rear strobe lights, radio and underseat sub.
    http://www.toyotatpms.com/

    Apparently, no direct TPMS.

    If it was indirect TPMS it would read the difference in wheel speeds.

    TPMS light (Yellow) [​IMG]
     
  4. Sep 6, 2011 at 9:49 AM
    #4
    2000GTacoma

    2000GTacoma Well-Known Member

    Joined:
    Jan 29, 2011
    Member:
    #50183
    Messages:
    2,188
    Gender:
    Male
    Snow Hill NC
    Vehicle:
    00 Tacoma Ext. 3.4L SR5
    no tpms in 1st i don't believe
     
  5. Sep 6, 2011 at 9:58 AM
    #5
    jberry813

    jberry813 The Mad Scientist

    Joined:
    Jan 21, 2011
    Member:
    #49636
    Messages:
    16,597
    Gender:
    Male
    First Name:
    Jason
    Lake Tahoe
    Vehicle:
    2012 DCSB Sport
    ...too much shit to list.
    Fact: No TPMS in 1st gens.
     
  6. Sep 6, 2011 at 10:02 AM
    #6
    capetaco12

    capetaco12 .<>./

    Joined:
    Mar 29, 2011
    Member:
    #53984
    Messages:
    3,694
    Gender:
    Male
    Cleveland Ledge, MA
    Vehicle:
    33's,armor,crawler,dents, ect
    OME lift CBI sliders, front bumper homemade rear bumper 33x12.50 m/t Gears Aussie locker inchworm crawlbox Homemade flat belly
    If it went on the off i place a bet its emissions related. Maybe gas cap. It may be coming back on in the near future. If your sticker ends anytime soon i suggest getting a new one before it comes back on.
     
  7. Sep 6, 2011 at 10:30 AM
    #7
    Yamaha Dave

    Yamaha Dave Well-Known Member

    Joined:
    Mar 27, 2010
    Member:
    #34080
    Messages:
    2,677
    Gender:
    Male


    x2. TPMS wasn't a requirement until years later. No TPMS in 1st gens.
     
  8. Sep 11, 2011 at 6:21 AM
    #8
    mo13

    mo13 [OP] Well-Known Member

    Joined:
    Jul 30, 2011
    Member:
    #60800
    Messages:
    395
    Gender:
    Male
    First Name:
    Marc
    fleming island,FL
    Vehicle:
    2010 TRD OR
    Icon RR extended length coilovers with cdc,Icon RR 2.0 custom length shocks, Icon tube UCA,all pro standard leaf pack,allpro u bolt flip kit,extended front and rear steel braided brake lines,CMC,super bumps, color matched mirror covers, relentless fab front bumper, smittybilt 8k winch with syn line, viking thimble and hawse fairlead, d2s retro fits, 20" led bar on bamf bracket, 4 rigid duallys, skygear fuse box, viper remote start, and a very shotty made satoshi raptor mesh grill made by myself haha
    Thanks y'all ended up taking it to auto zone and it was the o2 sensor upper bank but since they reset it 3 or 4 days ago hasn't given me any problems so it's all good
     
  9. Sep 11, 2011 at 8:45 AM
    #9
    capetaco12

    capetaco12 .<>./

    Joined:
    Mar 29, 2011
    Member:
    #53984
    Messages:
    3,694
    Gender:
    Male
    Cleveland Ledge, MA
    Vehicle:
    33's,armor,crawler,dents, ect
    OME lift CBI sliders, front bumper homemade rear bumper 33x12.50 m/t Gears Aussie locker inchworm crawlbox Homemade flat belly
    It takes a certain number of miles so it could take a month to come back on. Is your rear O2 starting to back out?
     
  10. Sep 11, 2011 at 8:54 AM
    #10
    4Wheelin4Banger

    4Wheelin4Banger Longtime Toyman

    Joined:
    Jun 15, 2011
    Member:
    #58306
    Messages:
    6,711
    Gender:
    Male
    First Name:
    Randy
    Ferntucky, NV Halfway between Reno & Falabama
    Vehicle:
    2011 4x4 Access Cab Silver State Edition
    3" OME lift 885s & Dakars riding on 33" KM2s Click the sig pic to see the build thread .
    [​IMG]Welcome to TW from Sparks, NV.
     
  11. Sep 11, 2011 at 10:00 AM
    #11
    mo13

    mo13 [OP] Well-Known Member

    Joined:
    Jul 30, 2011
    Member:
    #60800
    Messages:
    395
    Gender:
    Male
    First Name:
    Marc
    fleming island,FL
    Vehicle:
    2010 TRD OR
    Icon RR extended length coilovers with cdc,Icon RR 2.0 custom length shocks, Icon tube UCA,all pro standard leaf pack,allpro u bolt flip kit,extended front and rear steel braided brake lines,CMC,super bumps, color matched mirror covers, relentless fab front bumper, smittybilt 8k winch with syn line, viking thimble and hawse fairlead, d2s retro fits, 20" led bar on bamf bracket, 4 rigid duallys, skygear fuse box, viper remote start, and a very shotty made satoshi raptor mesh grill made by myself haha
    idk how to check if it’s starting to back out but the guy at auto zone said the upper bank was the first o2 sensor closets to the engine. Also read somewhere that Tacoma’s don’t like aftermarket o2's so I should probably look into a factory one form the dealer. And thanks for the whats up and hellos
     
  12. Sep 11, 2011 at 3:07 PM
    #12
    capetaco12

    capetaco12 .<>./

    Joined:
    Mar 29, 2011
    Member:
    #53984
    Messages:
    3,694
    Gender:
    Male
    Cleveland Ledge, MA
    Vehicle:
    33's,armor,crawler,dents, ect
    OME lift CBI sliders, front bumper homemade rear bumper 33x12.50 m/t Gears Aussie locker inchworm crawlbox Homemade flat belly
    He may be right. I was thinking upper ment bank 2 (rear). I havent personally run any aftermarket ones, but for the price i think the extra few bucks is worth knowing it should last a few years. Although the biggest culprit with these trucks is the gasket will decay and fall out the exhaust will leak a little (before the sensor itself gets worn out), If any water gets in you could fry the sensor, its best to take care of such problems quickly.
     
  13. Sep 11, 2011 at 3:21 PM
    #13
    mo13

    mo13 [OP] Well-Known Member

    Joined:
    Jul 30, 2011
    Member:
    #60800
    Messages:
    395
    Gender:
    Male
    First Name:
    Marc
    fleming island,FL
    Vehicle:
    2010 TRD OR
    Icon RR extended length coilovers with cdc,Icon RR 2.0 custom length shocks, Icon tube UCA,all pro standard leaf pack,allpro u bolt flip kit,extended front and rear steel braided brake lines,CMC,super bumps, color matched mirror covers, relentless fab front bumper, smittybilt 8k winch with syn line, viking thimble and hawse fairlead, d2s retro fits, 20" led bar on bamf bracket, 4 rigid duallys, skygear fuse box, viper remote start, and a very shotty made satoshi raptor mesh grill made by myself haha
    thats the plan bro ima shop around and maybe i can find one online from some toyota dealer and get it a bit cheaper. thanks for the info tho didnt even occur to me to check the gasket around the sensor
     
  14. Sep 11, 2011 at 3:30 PM
    #14
    capetaco12

    capetaco12 .<>./

    Joined:
    Mar 29, 2011
    Member:
    #53984
    Messages:
    3,694
    Gender:
    Male
    Cleveland Ledge, MA
    Vehicle:
    33's,armor,crawler,dents, ect
    OME lift CBI sliders, front bumper homemade rear bumper 33x12.50 m/t Gears Aussie locker inchworm crawlbox Homemade flat belly
To Top