1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check engine doesnt work

Discussion in '1st Gen. Tacomas (1995-2004)' started by mwild, Nov 19, 2009.

  1. Nov 19, 2009 at 1:17 PM
    #1
    mwild

    mwild [OP] I CANT SPELL SO DONT BITCH

    Joined:
    May 18, 2008
    Member:
    #6720
    Messages:
    1,413
    Gender:
    Male
    First Name:
    Matt
    Vernon, NJ
    Vehicle:
    03 2500 Dodge Ram
    Cat-Back, weather techs, ipod and sisuis Old 04 Taco: 5100s At all 4 corners set at 2.5", Toyotec AAL, Gibson cat-back, Deck plate mod, 20% Tint on fronts, 10" Kicker Comp sub, Sirius radio, Bud Built Skid, Pro Comp 8069 Wheels
    i traded in my 2008 taco for a 2004 taco trd v6 5 speed and went to my dads shop today to inspect it and as soon as he hooked it up to the inspection machine it said the check engine is not working and the 02 sencer was bad. im not to worried about the 02 sencer. we can not get the check engine light to work we had the dash apart and its not the bulb and we could not find any wires cut behind the cluster or by the ECU. anyone else run into this problem or have any ideas. im takin it back to the dealer 2morrow morning. they said they would fix it but they dont know that we already had it apart and its not just the bulb.
     
  2. Nov 19, 2009 at 1:43 PM
    #2
    mwild

    mwild [OP] I CANT SPELL SO DONT BITCH

    Joined:
    May 18, 2008
    Member:
    #6720
    Messages:
    1,413
    Gender:
    Male
    First Name:
    Matt
    Vernon, NJ
    Vehicle:
    03 2500 Dodge Ram
    Cat-Back, weather techs, ipod and sisuis Old 04 Taco: 5100s At all 4 corners set at 2.5", Toyotec AAL, Gibson cat-back, Deck plate mod, 20% Tint on fronts, 10" Kicker Comp sub, Sirius radio, Bud Built Skid, Pro Comp 8069 Wheels
    yea we checked all the fuses and took a bulb out of another light on the cluster that we knew worked and it wont work. it has power with a test light but no ground. the ECU sends the ground to turn the light on
     
  3. Nov 19, 2009 at 2:11 PM
    #3
    mwild

    mwild [OP] I CANT SPELL SO DONT BITCH

    Joined:
    May 18, 2008
    Member:
    #6720
    Messages:
    1,413
    Gender:
    Male
    First Name:
    Matt
    Vernon, NJ
    Vehicle:
    03 2500 Dodge Ram
    Cat-Back, weather techs, ipod and sisuis Old 04 Taco: 5100s At all 4 corners set at 2.5", Toyotec AAL, Gibson cat-back, Deck plate mod, 20% Tint on fronts, 10" Kicker Comp sub, Sirius radio, Bud Built Skid, Pro Comp 8069 Wheels
    yea every other light works except the CEL and it cant pass inspection in nj like that. i just hope the dealer i bought it from can figure it out. my fathers good friend is a toyota dealer mechanic and he has never heard of anything like this before
     
  4. Nov 27, 2009 at 8:39 PM
    #4
    MotoXXX

    MotoXXX Well-Known Member

    Joined:
    Oct 1, 2009
    Member:
    #23632
    Messages:
    158
    Gender:
    Male
    San Jose
    Vehicle:
    02 Pre-Runner
    Find the problem?
     
  5. Nov 28, 2009 at 6:22 AM
    #5
    blackxpress

    blackxpress Well-Known Member

    Joined:
    Oct 30, 2009
    Member:
    #25192
    Messages:
    58
    Gender:
    Male
    First Name:
    Jeff
    Carlisle, OH
    Vehicle:
    98 SR5 2WD Xcab
    If it has power with a test light but no ground and you're sure the wiring is good the problem is most likely in the ecu itself. I don't suppose you could borrow an ecu from another truck long enough to plug it in and see if your CEL starts working.
     
  6. Nov 28, 2009 at 7:56 AM
    #6
    kevhogaz

    kevhogaz Low Speed, High Drag

    Joined:
    Sep 6, 2008
    Member:
    #9055
    Messages:
    323
    Gender:
    Male
    Queen Creek, Arizona
    Vehicle:
    SR5 PreRunner
    3" lift front & rear, Air Raid Intake System
    That would be my guess, too. We never replace ECU's in Tacoma's, (Corolla's are another story!), so I'd have to wonder if somebody intentionally disabled so the could trade in the truck? too bad you're half way across the world, you could borrow my ECU to see if that was the problem.
     
To Top