1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check engine light & no overdrive

Discussion in 'Technical Chat' started by MSalerno, Feb 28, 2010.

  1. Feb 28, 2010 at 10:07 AM
    #1
    MSalerno

    MSalerno [OP] New Member

    Joined:
    Feb 28, 2010
    Member:
    #32258
    Messages:
    3
    Gender:
    Male
    New York state
    Vehicle:
    2006 Tacoma
    Just got back to Buffalo airport to find that the check engine light is on and cannot shift into overdrive. Just had this thing serviced Mon. 2/22. Any ideas, I have over 1 hour to drive home.
     
  2. Feb 28, 2010 at 11:30 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,148
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Have the code read, and post it up. And Welcome to TW :)
     
  3. Feb 28, 2010 at 8:11 PM
    #3
    kevhogaz

    kevhogaz Low Speed, High Drag

    Joined:
    Sep 6, 2008
    Member:
    #9055
    Messages:
    323
    Gender:
    Male
    Queen Creek, Arizona
    Vehicle:
    SR5 PreRunner
    3" lift front & rear, Air Raid Intake System
    Somebody left something unplugged. You can drive your truck home in 3rd gear, it won't hurt it.
     
  4. Mar 7, 2010 at 8:11 AM
    #4
    MSalerno

    MSalerno [OP] New Member

    Joined:
    Feb 28, 2010
    Member:
    #32258
    Messages:
    3
    Gender:
    Male
    New York state
    Vehicle:
    2006 Tacoma
    thanks for replies. later in the day the o/d worked and the light went off. The shop thinks something froze up, who knows. It's rare for my truck to be parked for 4 days so it coule be the problem. My first thought was something was left undone since I had a service a few days prior.

    On a side note, the temp and compass have stopped working and of course I'm told it would cost $985 to replace. I see others have had this and a simple solder corrected it. Don't know if the garage is aware that they could just do that for their customers or if they thought since my wife was the one to take the truck in that they could just get her to buy the new one.

    Once warmer weather gets here I'll do the solder myself. Gotta remember to check here before ever having anything too expensive done to my truck!
     
To Top