1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check Engine Light ON, now OFF

Discussion in 'Technical Chat' started by Chappie, Aug 20, 2009.

  1. Aug 20, 2009 at 10:28 AM
    #1
    Chappie

    Chappie [OP] Member

    Joined:
    Aug 20, 2009
    Member:
    #21461
    Messages:
    11
    Gender:
    Male
    Two days ago, my check engine light came on (definitely check engine, not maint reqd) and did not go away after startup. I took two or three more trips and it remained on throughout those trips. Today I got in it and it went off. I saw in another thread someone recommended taking it to the place where I get it inspected and having them hook up their computer and look at it.

    Is that still the recommended procedure, or now that the light is off, will they just look at me funny? With the light off will anything even show up on their computer? Can I just hope that it will go away forever and not worry about it?
     
  2. Aug 20, 2009 at 10:43 AM
    #2
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,253
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    Take it to Autozone - they should have FREE diagnostic check (code reader).

    The codes should remain in memory until they are cleared (by a diagnostics reader -Autozone won't clear codes).
     
  3. Aug 20, 2009 at 10:48 AM
    #3
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    DId you get gas any time before the the light came on and befroe it went off?
     
  4. Aug 20, 2009 at 11:32 AM
    #4
    Chappie

    Chappie [OP] Member

    Joined:
    Aug 20, 2009
    Member:
    #21461
    Messages:
    11
    Gender:
    Male
    No. 3/4 full throughout.
     
  5. Aug 20, 2009 at 11:47 AM
    #5
    97Blk_one

    97Blk_one Well-Known Member

    Joined:
    Apr 14, 2008
    Member:
    #5970
    Messages:
    731
    Gender:
    Male
    Memfrica
    Vehicle:
    not so low
    A whole lot,But not satify
    I would wait 'til it come back on again. What year is you truck?
     
  6. Aug 20, 2009 at 12:46 PM
    #6
    Chappie

    Chappie [OP] Member

    Joined:
    Aug 20, 2009
    Member:
    #21461
    Messages:
    11
    Gender:
    Male
    It's a 2006, but only 13,000 miles on it.
     
  7. Aug 20, 2009 at 2:48 PM
    #7
    97Blk_one

    97Blk_one Well-Known Member

    Joined:
    Apr 14, 2008
    Member:
    #5970
    Messages:
    731
    Gender:
    Male
    Memfrica
    Vehicle:
    not so low
    A whole lot,But not satify
    Wow..Mine '97 knock on wood,I haven't experience it yet.
     
  8. Aug 31, 2009 at 10:13 PM
    #8
    XBrown

    XBrown Spartacus!

    Joined:
    Jun 11, 2009
    Member:
    #18334
    Messages:
    58
    Gender:
    Male
    First Name:
    Xavier
    Phoenix, AZ
    Vehicle:
    04 Tacoma SR5
    The check engine light will turn off after three trouble-free drive cycles. However, the code stored in the computer will remain in memory for another 40 to 80 warm-up cycles, depending on the code.
     
  9. Aug 31, 2009 at 10:54 PM
    #9
    Chappie

    Chappie [OP] Member

    Joined:
    Aug 20, 2009
    Member:
    #21461
    Messages:
    11
    Gender:
    Male
    I would say it was very nearly if not exactly 3 drives. I took it in to toyota, and after finding out that it is covered under the 8 year portion of the warranty I opted not to spend $42 on an analyzer that I had already run for free. The tech said that these things sometimes fix themselves, but then later admitted he had only been there a short time. At any rate, I have the warranty in my back pocket in case it happens again, and it has never acted strange at least.
     
  10. Sep 1, 2009 at 5:45 AM
    #10
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    So what was the code?
     
  11. Sep 1, 2009 at 7:29 AM
    #11
    Chappie

    Chappie [OP] Member

    Joined:
    Aug 20, 2009
    Member:
    #21461
    Messages:
    11
    Gender:
    Male
    failed ECM. I actually started another thread once I had that info in hand. It shouldn't be far.
     
  12. Sep 1, 2009 at 8:03 AM
    #12
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Was it P0000?
     
  13. Sep 1, 2009 at 10:59 AM
    #13
    Chappie

    Chappie [OP] Member

    Joined:
    Aug 20, 2009
    Member:
    #21461
    Messages:
    11
    Gender:
    Male
    The only number I can make out says 661 on the ticket I have.
     
  14. Sep 1, 2009 at 11:10 AM
    #14
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    That's not a code. Oh well.
     
  15. Sep 1, 2009 at 11:12 AM
    #15
    Chappie

    Chappie [OP] Member

    Joined:
    Aug 20, 2009
    Member:
    #21461
    Messages:
    11
    Gender:
    Male
    the writing says ' ECM processor error" and I remember their computer said something like:

    Probable Cause:
    1) Improper programming
    2) Failed ECM
     
To Top