1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check engine light question?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Toyota85, Apr 20, 2012.

  1. Apr 20, 2012 at 9:48 AM
    #1
    Toyota85

    Toyota85 [OP] Member

    Joined:
    Apr 18, 2012
    Member:
    #77186
    Messages:
    13
    Gender:
    Male
    I was driving home today and my check engine light and traction control light randomly came on. I'll be throwing my friends scan tool on it this weekend. Just curious if anyone else has had this happen? Any idea what's causing it?
     
  2. Apr 20, 2012 at 9:53 AM
    #2
    OffroadToy

    OffroadToy This ain't Dodge City, and you ain't Bill Hickok

    Joined:
    Sep 12, 2009
    Member:
    #22680
    Messages:
    5,257
    Gender:
    Male
    Vehicle:
    07 TRD OFFROAD 4x4 VSC/TRAC/DAC/HAC
    snugtop, piaa, weathertech, westin, oem bed mat, trd seat covers, avs inchannel vent visors, 2" suspension lift, front diff drop, rear differential breather extension, oil filter drain hose, a/c drain hose extention & reroute, front window tint, cat theft protection plate, tailgate clamp mod, xpel headlight/foglight protecters, oem block heater, bfg 265/75R/16 a/t k/o's, cabin air rodent protection screen, rcbs illuminated 4X4 switch mod
    check your gas cap

    edit: are the lights flashing or solid?
     
  3. Apr 20, 2012 at 9:56 AM
    #3
    Toyota85

    Toyota85 [OP] Member

    Joined:
    Apr 18, 2012
    Member:
    #77186
    Messages:
    13
    Gender:
    Male
    I will but would that cause the trac control light to come on?
     
  4. Apr 20, 2012 at 10:20 AM
    #4
    Country101

    Country101 Well-Known Member

    Joined:
    Apr 7, 2012
    Member:
    #76429
    Messages:
    443
    Gender:
    Male
    NW Arkansas
    Vehicle:
    08 tacoma access cab V6 4x4 manual
    dirty truck mod, custom trailer scratch on tailgate, husky floorliners, OME Lift
    you can stop by an auto parts store(auto zone I know does it and several others will.) and have them read it. Would only take a couple minutes and it's free. It would give you a starting point atleast.
     
  5. Apr 20, 2012 at 10:32 AM
    #5
    Toyota85

    Toyota85 [OP] Member

    Joined:
    Apr 18, 2012
    Member:
    #77186
    Messages:
    13
    Gender:
    Male
    That's my plan tomorrow. My friend has a scan tool. I just wondered if anyone else had this problem?
     
  6. Apr 20, 2012 at 10:38 AM
    #6
    Toyota85

    Toyota85 [OP] Member

    Joined:
    Apr 18, 2012
    Member:
    #77186
    Messages:
    13
    Gender:
    Male
    Ok thanks
     
  7. Apr 20, 2012 at 10:43 AM
    #7
    OffroadToy

    OffroadToy This ain't Dodge City, and you ain't Bill Hickok

    Joined:
    Sep 12, 2009
    Member:
    #22680
    Messages:
    5,257
    Gender:
    Male
    Vehicle:
    07 TRD OFFROAD 4x4 VSC/TRAC/DAC/HAC
    snugtop, piaa, weathertech, westin, oem bed mat, trd seat covers, avs inchannel vent visors, 2" suspension lift, front diff drop, rear differential breather extension, oil filter drain hose, a/c drain hose extention & reroute, front window tint, cat theft protection plate, tailgate clamp mod, xpel headlight/foglight protecters, oem block heater, bfg 265/75R/16 a/t k/o's, cabin air rodent protection screen, rcbs illuminated 4X4 switch mod
    mine had the same 2 lights on (traction light might have been flashing)...ended up being the gas cap.
     
  8. Oct 29, 2012 at 6:55 PM
    #8
    wileyC

    wileyC Well-Known Member

    Joined:
    Oct 22, 2011
    Member:
    #65685
    Messages:
    3,067
    Gender:
    Male
    Centerville, OH
    Vehicle:
    2012 PreRunner Double Cab TRD Sport
    i just had this happen to me - CEL + TRAC OFF lights came on after starting it up after the vehicle sat for like 90 mins... will try to retighten the gas cap, hopefully that is it... although i'm curious why the TRAC OFF light is on since, i've never messed w/ this system?...
     
To Top