1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check engine light

Discussion in '1st Gen. Tacomas (1995-2004)' started by nicnicman, Jun 10, 2011.

  1. Jun 10, 2011 at 6:30 PM
    #1
    nicnicman

    nicnicman [OP] Active Member

    Joined:
    Jun 2, 2011
    Member:
    #57640
    Messages:
    31
    Gender:
    Male
    Maine
    Vehicle:
    03 Tacoma SR5 4 Cyl Manual
    The check engine light is not on in my 2003 Toyota Tacoma sr5 4wd 4cyl manual transmission. Does this mean my catalytic converter is good? Or, could a catalytic converter be bad and not cause the check engine light to glow.

    The truck is not showing a symptoms of a bad cat, but I just wanted to know if the lack of check engine light is a sure sign of a good cat.

    This may be a strange question, but I just want to make sure things are working correctly.

    Thanks for any replies.
     
  2. Jun 10, 2011 at 6:36 PM
    #2
    MapleMoose

    MapleMoose Drunk Canadian

    Joined:
    Feb 15, 2011
    Member:
    #51211
    Messages:
    8,589
    Gender:
    Male
    First Name:
    Ian
    West Kootenays
    Vehicle:
    1996 Tacoma SR5
    3" Eibach Coils, 3" AP Springs, AP 6" Shackles Toytec Diff drop, BAMF Sliders, Deck plate mod,Volt meter, Highbeam mod, PIAA fogs, 18" Magnaflow, LED dash swap, Color matched Satoshi Grille, Custom Rear Plate Bumper
    What makes you think the catalytic is bad?
     
  3. Jun 10, 2011 at 6:43 PM
    #3
    nicnicman

    nicnicman [OP] Active Member

    Joined:
    Jun 2, 2011
    Member:
    #57640
    Messages:
    31
    Gender:
    Male
    Maine
    Vehicle:
    03 Tacoma SR5 4 Cyl Manual
    I noticed in some of the old maintenance records (from a previous owner) that the truck's check engine light had come on, and the dealership gave an estimate which included replacing an o2 sensor and both cats. However, only the o2 sensor was replaced. I'm not sure if it was simply not necessary to replace the cats or the owner just didn't want to spend the money.
     
  4. Jun 10, 2011 at 6:50 PM
    #4
    MapleMoose

    MapleMoose Drunk Canadian

    Joined:
    Feb 15, 2011
    Member:
    #51211
    Messages:
    8,589
    Gender:
    Male
    First Name:
    Ian
    West Kootenays
    Vehicle:
    1996 Tacoma SR5
    3" Eibach Coils, 3" AP Springs, AP 6" Shackles Toytec Diff drop, BAMF Sliders, Deck plate mod,Volt meter, Highbeam mod, PIAA fogs, 18" Magnaflow, LED dash swap, Color matched Satoshi Grille, Custom Rear Plate Bumper
    If the CEL did not come back on after the o2 sensor's were installed then it probley did not need to be replaced
     
  5. Jun 10, 2011 at 6:55 PM
    #5
    nicnicman

    nicnicman [OP] Active Member

    Joined:
    Jun 2, 2011
    Member:
    #57640
    Messages:
    31
    Gender:
    Male
    Maine
    Vehicle:
    03 Tacoma SR5 4 Cyl Manual
    That's what I was thinking. Just to be on the safe side, I might try to contact the previous owner and check if this is indeed what happened. I know a bad cat is usually caused by another issue so I just want to make sure everything's good.
     
  6. Jun 10, 2011 at 7:56 PM
    #6
    97Blk_one

    97Blk_one Well-Known Member

    Joined:
    Apr 14, 2008
    Member:
    #5970
    Messages:
    731
    Gender:
    Male
    Memfrica
    Vehicle:
    not so low
    A whole lot,But not satify
    I got '97. Check Engine Light off and on, talk to mechanic he said if everything running smoothly don't worry about it. So I kept on going and goin'....
     
  7. Jun 10, 2011 at 8:10 PM
    #7
    pittim

    pittim mittip

    Joined:
    May 28, 2008
    Member:
    #6939
    Messages:
    16,556
    Gender:
    Male
    Vehicle:
    Respect your elder gen.
    Pink slider.
    go to autozone/aamco/anywhere that offers to pull a code for free then post what it was.

    CEL ranges from exhaust leak, to bad sensors, to bad cat, to bad charcoal canister, etc.
     
  8. Jun 10, 2011 at 9:08 PM
    #8
    nicnicman

    nicnicman [OP] Active Member

    Joined:
    Jun 2, 2011
    Member:
    #57640
    Messages:
    31
    Gender:
    Male
    Maine
    Vehicle:
    03 Tacoma SR5 4 Cyl Manual
    The CEL is not on anymore and, as far as I know, has not been on for a while.

    What I am trying to determine is if this indicates that the catalytic converters are good. Could the catalytic converters be bad and not be detected by the 02 sensors? In other words, is the lack of CEL definitively showing that the catalytic converters are good.
     
  9. Jun 10, 2011 at 9:10 PM
    #9
    nicnicman

    nicnicman [OP] Active Member

    Joined:
    Jun 2, 2011
    Member:
    #57640
    Messages:
    31
    Gender:
    Male
    Maine
    Vehicle:
    03 Tacoma SR5 4 Cyl Manual
    Yeah, that's what I'm thinkin'. I guess if it doesn't turn back on I shouldn't worry about it.
     
  10. Jun 10, 2011 at 9:21 PM
    #10
    pittim

    pittim mittip

    Joined:
    May 28, 2008
    Member:
    #6939
    Messages:
    16,556
    Gender:
    Male
    Vehicle:
    Respect your elder gen.
    Pink slider.
    if its on there is a problem. if it's off you're gravy.
     
  11. Jun 10, 2011 at 10:23 PM
    #11
    nicnicman

    nicnicman [OP] Active Member

    Joined:
    Jun 2, 2011
    Member:
    #57640
    Messages:
    31
    Gender:
    Male
    Maine
    Vehicle:
    03 Tacoma SR5 4 Cyl Manual
    I read the previous maintenance records a bit more and found that the codes thrown were po136 and p0420. Evidently the o2 sensor fixed it though because the lights not on anymore. I guess I'm worrying over nothing.
     
  12. Apr 5, 2014 at 7:22 AM
    #12
    warbirdfotos

    warbirdfotos Member

    Joined:
    Jan 3, 2014
    Member:
    #119767
    Messages:
    5
    Gender:
    Male
    First Name:
    ADT
    Riverside, Ca
    Vehicle:
    TRD
    2003 Tacoma SR5 TRD V6 4x4 check engine light came on at 105,000 mi!

    Is there a scheduled maintainance at 105K?
     
To Top