1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

check engine light

Discussion in '1st Gen. Tacomas (1995-2004)' started by 99YOTA412, Dec 8, 2011.

  1. Dec 8, 2011 at 5:37 PM
    #1
    99YOTA412

    99YOTA412 [OP] Active Member

    Joined:
    Apr 25, 2011
    Member:
    #55547
    Messages:
    40
    Gender:
    Male
    First Name:
    layton
    south carolina
    Vehicle:
    06 Tacoma TRD Offroad, Bilstein 5100 shocks
    hey guys, my check engine light came on so i took it to autozone to get them to scan it. the code came back as a p0446 code and i want to know how to go about fixing that
     
  2. Dec 8, 2011 at 5:41 PM
    #2
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
  3. Dec 8, 2011 at 5:43 PM
    #3
    Manwithoutaplan

    Manwithoutaplan the full Monty

    Joined:
    Jan 30, 2008
    Member:
    #4500
    Messages:
    49,526
    Gender:
    Male
    ID
    Vehicle:
    07 Tacoma Speedway Blue Trd 4x4
    -Nitro 4.56 gears - Arb Front and Rear lockers. -Rear Swing out bumper Curiosity of ( Dept .94) https://www.facebook.com/Dept94 -Tinted, -ProComp 6 inch lift with Icon Coil overs and Bilstein's 7100Resi -315/70/17 - 17x8 in Pro Comp Matte black rims 4.5 bs -East Coast Gear Supply Sliders -ALL Pro EXP LEaf pack -Camburg UCA's -CAB mount CHOP
    Evaporative emission control system vent control circuit fault.

    there is a electrical solenoid (evap solenoid valve)mounted on the fuel vapor canister this it what is wrong,some times you need to replace canister also it will get saturated with fuel because valve is not working properly
     
  4. Dec 8, 2011 at 5:45 PM
    #4
    Manwithoutaplan

    Manwithoutaplan the full Monty

    Joined:
    Jan 30, 2008
    Member:
    #4500
    Messages:
    49,526
    Gender:
    Male
    ID
    Vehicle:
    07 Tacoma Speedway Blue Trd 4x4
    -Nitro 4.56 gears - Arb Front and Rear lockers. -Rear Swing out bumper Curiosity of ( Dept .94) https://www.facebook.com/Dept94 -Tinted, -ProComp 6 inch lift with Icon Coil overs and Bilstein's 7100Resi -315/70/17 - 17x8 in Pro Comp Matte black rims 4.5 bs -East Coast Gear Supply Sliders -ALL Pro EXP LEaf pack -Camburg UCA's -CAB mount CHOP
  5. Dec 8, 2011 at 6:01 PM
    #5
    99YOTA412

    99YOTA412 [OP] Active Member

    Joined:
    Apr 25, 2011
    Member:
    #55547
    Messages:
    40
    Gender:
    Male
    First Name:
    layton
    south carolina
    Vehicle:
    06 Tacoma TRD Offroad, Bilstein 5100 shocks
    thanks how hard is that to fix?
     
  6. Dec 15, 2011 at 12:29 PM
    #6
    FettsVette

    FettsVette Member

    Joined:
    Jan 30, 2011
    Member:
    #50201
    Messages:
    6
    Gender:
    Male
    Albany
    Vehicle:
    02 Tacoma SR5
    Hey man, don't know what motor your runnin, but I have a '02 3.4 and my (dreaded) cel was on, throwing 6 codes 2 each of p0441,p0442, and p0446, all evap stuff. Figured I'd start with the gas cap and it worked. Got a stant one from napa for about 10 bucks. So before you go messing around with the vsv's or that 200+ evap canister from the dealer, you might wanna give that a shot!
     
To Top