1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check Engine Light!!!!!!!!!!!

Discussion in '1st Gen. Tacomas (1995-2004)' started by hillinsan, Mar 19, 2012.

  1. Mar 19, 2012 at 11:13 PM
    #1
    hillinsan

    hillinsan [OP] Active Member

    Joined:
    Nov 26, 2011
    Member:
    #67712
    Messages:
    41
    Gender:
    Male
    Beavercreek,OR
    Vehicle:
    tacoma 4wd TRD
    My 2001 Tacoma TRD was running a little wierd the other day, wasnt winding out and not shifting right.. Its an automatic. Today I was driving to work and it started doing that again and the Engine Light Came on. On the way home about half way it was running like crap again. Going up a steep long hill i floored it and it seemed to be what I call "cutting out". Wasnt reving like it should or shifting right. Any help would be greatly appreciated!!!!! Thanx
     
  2. Mar 19, 2012 at 11:16 PM
    #2
    KalamaKid

    KalamaKid Well-Known Member

    Joined:
    Aug 3, 2008
    Member:
    #8323
    Messages:
    5,249
    Gender:
    Male
    First Name:
    Jason
    Socialist Republic of Oregon
    same shit as everyone else
    Do you know what code your check engine light is giving you?
     
  3. Mar 19, 2012 at 11:37 PM
    #3
    hillinsan

    hillinsan [OP] Active Member

    Joined:
    Nov 26, 2011
    Member:
    #67712
    Messages:
    41
    Gender:
    Male
    Beavercreek,OR
    Vehicle:
    tacoma 4wd TRD
    No I haven't got it diagnosed as of yet, going to auto parts store tomorrow to have it checked for what code.
     
  4. Mar 20, 2012 at 6:27 AM
    #4
    Yamaha Dave

    Yamaha Dave Well-Known Member

    Joined:
    Mar 27, 2010
    Member:
    #34080
    Messages:
    2,677
    Gender:
    Male
    No code we we'll just be throwing a bunch of misinformation since it could be several things causing it..
     
  5. Mar 20, 2012 at 10:44 AM
    #5
    hillinsan

    hillinsan [OP] Active Member

    Joined:
    Nov 26, 2011
    Member:
    #67712
    Messages:
    41
    Gender:
    Male
    Beavercreek,OR
    Vehicle:
    tacoma 4wd TRD
    Ok so I had the diagnostic test ran and its spitting out a knock sensor code. The guy told me it wasn't good to drive the truck. I talked to a friend of mine with a Tacoma and he said he drove his around for 6 months before getting it fixed. Will it cause engine damage to drive it for a few weeks until I can get it to a shop?
     
  6. Mar 20, 2012 at 11:00 AM
    #6
    KalamaKid

    KalamaKid Well-Known Member

    Joined:
    Aug 3, 2008
    Member:
    #8323
    Messages:
    5,249
    Gender:
    Male
    First Name:
    Jason
    Socialist Republic of Oregon
    same shit as everyone else
    What code exactly?
     
  7. Mar 20, 2012 at 11:04 AM
    #7
    TMW

    TMW Well-Known Member

    Joined:
    Apr 21, 2011
    Member:
    #55300
    Messages:
    317
    Gender:
    Male
    First Name:
    Tom
    Bakersfield, CA
    Vehicle:
    04 Tacoma 4x4 SR5
    Light bar and bumper guard, 3/16 steel skid plates for engine, tranny and transfer box, OME 881 springs with 5100 shocks at mid clip. AAL in rear. Positraction rear diff.
    if it's running like crap you need to get it fixed.
     
  8. Mar 20, 2012 at 11:06 AM
    #8
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,741
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
  9. Mar 20, 2012 at 11:06 PM
    #9
    hillinsan

    hillinsan [OP] Active Member

    Joined:
    Nov 26, 2011
    Member:
    #67712
    Messages:
    41
    Gender:
    Male
    Beavercreek,OR
    Vehicle:
    tacoma 4wd TRD
    The Code is P0330. Does this mean anything to you other then what the autozone guy told me? Taking it in to a shop beginning of next week. It is running like cr@p.....!
     
  10. Mar 21, 2012 at 4:47 AM
    #10
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,741
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
  11. Mar 22, 2012 at 11:17 PM
    #11
    hillinsan

    hillinsan [OP] Active Member

    Joined:
    Nov 26, 2011
    Member:
    #67712
    Messages:
    41
    Gender:
    Male
    Beavercreek,OR
    Vehicle:
    tacoma 4wd TRD
    Been driving it this week had to cuz of the snow we have, is it normal for the truck to run crappy with a bad knock sensor. Or am I looking at costly repairs? HELP!!!!!!!!!!!!!!!!!!
     
  12. Mar 23, 2012 at 4:52 AM
    #12
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,741
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Yes, the motor is probably detonating on one side. Which means the fuel/air mixture is igniting before the piston is reaching TDC. The sensor is only about $100. The hardest part is getting to it.


    http://www.ehow.com/how-does_5491841_knock-sensor-work.html
     
To Top